Contents

1. WebFOCUS Business User Edition .............................................. 7
   Introducing WebFOCUS Business User Edition ............................... 7
   WebFOCUS Business User Edition Components ............................... 7
   Installation ............................................................................. 8
   Installing WebFOCUS Business User Edition on a Windows Environment .... 8
         Hardware Requirements ....................................................... 8
         Software Requirements ...................................................... 8
   Installing WebFOCUS Business User Edition .................................... 9
   Updating WebFOCUS Business User Edition ..................................... 17
   Running WebFOCUS Business User Edition Services Manually .................. 18
   Uninstalling WebFOCUS Business User Edition .................................. 20
   Troubleshooting WebFOCUS Business User Edition ............................ 22
      Port Assignment ..................................................................... 23
      WebFOCUS Business User Edition Log Files ................................. 23
      Troubleshooting the Uninstall Process ....................................... 23
   Installing the WebFOCUS Business User Edition on a Linux Environment ........ 26
      WebFOCUS Business User Edition System Requirements on a Linux Environment . . 27
         Installation Prerequisites .................................................... 27
         System Resource Limits ....................................................... 28
      Configuring Java Memory Allocation for the Application Server ............... 30
      Launching WebFOCUS Business User Edition ................................ 31
      Running WebFOCUS Business User Edition Servers Manually .................. 31
         Creating Shell Scripts to Start and Stop Servers .......................... 32
      Updating WebFOCUS Business User Edition .................................. 33
      Uninstalling WebFOCUS Business User Edition ............................... 35
      Configuring for Email Distribution ............................................. 35
   Navigating the Environment .................................................................. 37
      Navigating the Business User Edition Portal .................................. 38
      Home Page ............................................................................. 38
      Menu Bar ............................................................................... 39
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Understanding Output Options</td>
<td>74</td>
</tr>
<tr>
<td>Using the Navigation Taskbar</td>
<td>76</td>
</tr>
<tr>
<td>Using the Status Bar</td>
<td>77</td>
</tr>
<tr>
<td>Understanding the Resources Panel</td>
<td>77</td>
</tr>
<tr>
<td>Using the Data Pane</td>
<td>79</td>
</tr>
<tr>
<td>Using the Data Pane to Add Fields to a Report</td>
<td>81</td>
</tr>
<tr>
<td>Using the Query Pane and Filter Pane</td>
<td>83</td>
</tr>
<tr>
<td>Using Field Containers</td>
<td>85</td>
</tr>
<tr>
<td>Field Containers for Reports</td>
<td>85</td>
</tr>
<tr>
<td>Field Containers for Charts and Visualizations</td>
<td>85</td>
</tr>
<tr>
<td>Using Shortcut Menu Options in the Query Pane</td>
<td>89</td>
</tr>
<tr>
<td>Dynamic Grouping</td>
<td>93</td>
</tr>
</tbody>
</table>

In this chapter:

- Introducing WebFOCUS Business User Edition
- Installation
- Navigating the Environment

Introducing WebFOCUS Business User Edition

This topic provides an overview of WebFOCUS Business User Edition.

WebFOCUS Business User Edition Components

With WebFOCUS Business User Edition, you can quickly and easily perform the following functions, all in a single web-based environment:

**Business User Edition Portal**

The Business User Edition Portal provides access to the Home page, the default landing page that opens when you first sign in. It serves as a centralized place for creating, organizing, accessing, or sharing content, performing administrative tasks, scheduling reports and procedures, and working with your data. You can develop new content or interact with content that has been created by other users, as well as create pages and InfoApps with WebFOCUS Designer.

**Reporting and Analysis**

Create ad hoc queries, develop reports, charts, documents, and other analytic views for personal usage or sharing and distribution in static or interactive formats. You can also create more advanced information assets, such as multi-page analytic documents and multi-source dashboards.

**Data Discovery**

WebFOCUS Business User Edition
Explore your data to find trends, patterns, and gain new insight, by creating visualizations. Running against a high-speed data sandbox and other data sources, you can create interactive visualizations that can be saved, shared, published, and delivered as PowerPoint presentations to help you build business cases through storytelling.

**Scheduling and Distribution**

ReportCaster provides scheduling and distribution capabilities for reports and procedures, as well as independent files and URLs. Reports and files are automatically distributed on a monthly, weekly, daily, or specific basis.

**Installation**

This topic provides the step-by-step instructions that you need to install WebFOCUS Business User Edition.

**Installing WebFOCUS Business User Edition on a Windows Environment**

The following section describes how to install WebFOCUS Business User Edition on a Windows environment.

You can begin using WebFOCUS Business User Edition immediately after you install the product. No additional configuration steps are required.

**WebFOCUS Business User Edition System Requirements for Windows**

To install WebFOCUS Business User Edition, you must have administrator privileges. Additionally, your machine must meet the system requirements that are defined in *Hardware Requirements* on page 8 and *Software Requirements* on page 8.

**Hardware Requirements**

- Quad-core processor, 2.5 GHz minimum per core is recommended.
- 16 GB of RAM or higher is recommended for optimal performance. 8 GB of RAM minimum.
- 8 GB of free disk space.
- Ensure that the Windows page file is properly configured and that is set to *Automatically manage paging file size*. For Windows 64-bit, the recommended paging file size is three times the size of the RAM.

**Software Requirements**

Note: The Windows 10 Anniversary upgrade Version 1607 (OS Build 14398.82) is not supported. This version causes Hyperstage to become unstable and disconnect.

- 64-bit Version of Windows.

- Supported browsers: Internet Explorer®, 11, Microsoft Edge®, Google Chrome™ (latest version), Mozilla Firefox® (latest version).

Note: Accessibility Compliance is not supported at this time.

Installing WebFOCUS Business User Edition

This section describes how to install WebFOCUS Business User Edition.

Procedure: How to Install WebFOCUS Business User Edition

1. Download the installation files.
2. Double-click installWebFOCUS_BUE8202.exe.

Note:

- Java Version 8 Update 152 (8u152) and Tomcat 8.5.20 are included with the WebFOCUS Business User Edition product installation.

- The installation program includes the following third-party components: Tomcat, Java, and Derby. Later versions or releases of these third-party components, which often contain fixes for security vulnerabilities, may exist at installation time. It is your responsibility to check the vendor sites listed below for updates to newer versions or releases of these third-party components if you intend to use them with WebFOCUS Business User Edition. Install the new updates or versions prior to proceeding with the WebFOCUS Business User Edition installation. If these components are installed through the WebFOCUS Business User Edition installation program, it is your responsibility to update these components after the installation is completed.

- The latest version of Tomcat is available at https://tomcat.apache.org.

- The latest version of Java is available at https://www.java.com.

- The latest version of Derby is available at https://db.apache.org/derby.
The Tomcat initial memory pool size (JvmMs) is configured to use 1/8 of the physical memory of the machine. For example, on a machine with 16 GB RAM, the pool size is set to 2130. The maximum memory pool size (JvmMx) is configured to use 1/4 of the physical memory of the machine. For example, on a machine with 16 GB RAM, the pool size is set to 4261.

You can change the Java memory allocation by running the WfBUE82AppSrvw.exe Tomcat configuration utility, located in the drive:\ibi\WebFOCUS_BUE82\tomcat\bin folder, and selecting the Java tab.

The InstallAnywhere installation program opens, as shown in the following image.

3. Choose the appropriate language from the drop-down list and click OK.

The list of languages depends on the regional language settings of the Windows Operating System where WebFOCUS Business User Edition is being installed.

**Note:** The language selected will be the language used during the installation program. This language is also used to set the code page of the Reporting Server, which is responsible for data access.

If your data sources are in a different language, you will have to change the code page of the Reporting Server.
The Welcome window opens.

4. Click Next to continue.
The License Agreement window opens.

5. Click I accept the terms of the License Agreement, and then click Next.

   **Note:**

   - Only one installation per platform is supported.
   - If you have an earlier release of WebFOCUS Business User Edition installed on your machine, you will be prompted to update your installation and to provide Administrator credentials to load new roles and BI Portal page templates. For more information, see *Updating WebFOCUS Business User Edition* on page 17. To perform a full or new installation, you must quit the installation program, uninstall the existing version, and perform a new installation. When you uninstall WebFOCUS Business User Edition, all components are removed from your directory structure, except the WebFOCUS Business User Edition Reporting Server applications. For more information, see *Uninstalling WebFOCUS Business User Edition* on page 20.
The License Code window opens, as shown in the following image.

6. Type the WebFOCUS Business User Edition license code and first four digits of the site code that were provided with your copy of WebFOCUS Business User Edition, and then click Next.
The Setup Preferences window opens, as shown in the following image.

7. In the Setup Preferences window, complete the following steps:

a. The installation program preconfigures a user name, but requires that you type a password. You must complete the User Name credentials section to proceed with the installation. In the Password field, type a password, and then confirm your password.

   **Note:** During the database creation, the password supports ASCII characters from 32 to 126 and cannot include the following characters: caret (^), ampersand (&), percent (%), or double quotation marks ("). Refer to the ASCII character table to determine the characters to use for the password. As a reference, see [https://msdn.microsoft.com/en-us/library/60ecse8t(v=vs.71).aspx](https://msdn.microsoft.com/en-us/library/60ecse8t(v=vs.71).aspx). The password for the user name must be between four and 20 characters. Leading blanks and trailing blanks will be removed.
b. Optionally, select the **Configure email distribution** check box to select the type of Mail Server to be used for report distribution. Valid options are:

- **Google.** This requires a Google Account Name and Password.
  
  **Note:** Google may block sign-in attempts when delivering reports through WebFOCUS Business User Edition. To allow WebFOCUS Business User Edition to connect to the Google email account that was configured for email distribution, sign in to the Google account, navigate to **My Account** settings, select **Sign-In & security**, and turn the Allow less secure apps option On.
  
  For more information, see:
  
  [https://www.google.com/settings/security/lesssecureapps](https://www.google.com/settings/security/lesssecureapps)

- **Yahoo.** This requires a Yahoo Account Name and Password.

- **Other.** Select this for all other mail servers. This option requires you to type the host name or IP address for your SMTP mail server.

c. The **Configure WebFOCUS BUE services to start automatically** check box is selected, by default. You can leave this check box selected to keep the services Startup Type as Automatic. This will ensure that the services required to run the product are always running, and will not require that you start the services manually, even if you restart the machine.

  Optionally, you can clear the **Configure WebFOCUS BUE services to start automatically** check box so you can manually start and stop the WebFOCUS Business User Edition services from the shortcut options found in the WebFOCUS Business User Edition 82 group, or through the Windows services program.

d. Select the **Advanced Configuration** check box if you want to customize the location of your Reporting Server applications directory. The default location is `\WebFOCUS_BUE82\data\apps`.

8. Click **Next** to continue.

   The Pre-Installation summary window opens.
**Note:** If you selected the Advanced Configuration check box, the following window opens.

Server applications can be created in the default location or in a new location outside of the `drive:\ibi\WebFOCUS_BUE82\` folder. Select the location of your applications and then click Next.

9. Confirm that the summary information is correct, and then click **Install**.

10. When the installation completes, click **Done** to close the installation program.
The Sign In page opens, as shown in the following image.

11. Sign in using the manager user credentials that you configured during the installation program.

**Updating WebFOCUS Business User Edition**

The following needs to be performed after the upgrade completes:

- Ensure all WebFOCUS Business User Edition services are running.
- Run the following .bat file, if this step failed to run during the installation update process.
  
  `drive:\ibi\WebFOCUS_BUE82\WebFOCUS\utilities\WFReposUtil\update_repos.bat`

  This script will make updates to the WebFOCUS Business User Edition repository that are required to load new roles and BI Portal page templates.

- The update_repos.bat utility imports the following Change Management packages:
  
  - `bip_pages_templates_Vnn.zip`, where `nn` is the version of the package.
  - `roles.zip`
  - `pgx_page_templates_Vnn.zip`, where `nn` is the version of the package.
  - `themes_Vnn.zip`, where `nn` is the version of the package.
  - `wfbue_getting_started.zip`
Logs are created in the `drive:\ibi\WebFOCUS_BUE82\WebFOCUS\logs` folder under the following names:

- `cm_import_bip_page_templates_<date_time>.log`
- `cm_import_roles_<date_time>.log`
- `cm_import_pgx_page_templates_Vnn_<date_time>.log`
- `cm_import_themes_Vnn_<date_time>.log`
- `cm_import_wfbue_getting_started_<date_time>.log`
- `cm_import_wfbue_Collaborative_portal_<date_time>.log`

Currently, Tomcat does not provide an upgrade option in WebFOCUS Business User Edition. An installation utility will be available post-Release 8.2 Version 02 to enable you to upgrade existing Tomcat installations.

The solution for Release 8.2 Version 02 is as follows:

3. Restore the backed up data to the new installation.

By default, the data that needs to be backed up is located in the following folders:

- `drive:\ibi\WebFOCUS_BUE82\derby\WFBUE82\`
- `drive:\ibi\WebFOCUS_BUE82\data\apps\`
- `drive:\ibi\WebFOCUS_BUE82\srv\wfs\hs\`

**Running WebFOCUS Business User Edition Services Manually**

You should refer to this topic if you did not select the **Configure WebFOCUS BUE services to start automatically after a reboot** check box during the installation program.

The installation program installs the following services:

- An application server
- A Distribution Server
- A repository server
- A Reporting Server

**Note:** If you are updating an earlier release of WebFOCUS Business User Edition, you must manually stop all WebFOCUS Business User Edition services before beginning the installation program. For more information, see *Running WebFOCUS Business User Edition Services Manually* on page 18.

To view the status of these services, launch your Windows Services program from the Control Panel, and click the *Standard* tab. The following image highlights the WebFOCUS Business User Edition services as they appear in the Windows Services program.

![Windows Services Program](image)

<table>
<thead>
<tr>
<th>Display name</th>
<th>Service Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>WebFOCUS BUE 82 Application Server</td>
<td>WfBUE82AppSrv</td>
</tr>
<tr>
<td>WebFOCUS BUE 82 Distribution Server</td>
<td>WfBUE82DistSrv</td>
</tr>
<tr>
<td>WebFOCUS BUE 82 Reporting Server</td>
<td>WebFOCUS BUE 82 Reporting Server</td>
</tr>
<tr>
<td>WebFOCUS BUE 82 Repository Server</td>
<td>WfBUE82DbSrv</td>
</tr>
</tbody>
</table>
**Procedure:** How to Start or Stop WebFOCUS Business User Edition Services Manually

From the Start menu, navigate to the WebFOCUS Business User Edition shortcut, under the Information Builders program group.

- Click **Start WebFOCUS_BUE Services** to start the WebFOCUS Business User Edition services.
- Click **Stop WebFOCUS_BUE Services** to stop the WEBFOCUS Business User Edition services.

**Uninstalling WebFOCUS Business User Edition**

If you want to remove an existing WebFOCUS Business User Edition installation and want to perform a full installation of a newer release, you can run the uninstall program.

**Note:** Before you uninstall WebFOCUS Business User Edition, it is recommended that you save the cleanup utility to a different location on your machine in case the uninstall fails and you need to manually uninstall any components. For more information, see *Troubleshooting WebFOCUS Business User Edition* on page 22.

**Procedure:** How to Preserve Your Data

The following steps can be performed if you want to preserve your data and perform a new installation, if you need to move your data to another location, or if an upgrade installation fails and you need to perform a new full installation.

1. Back up the WebFOCUS Business User Edition repository server and Reporting Server application folders to a different location on your machine.
   
   By default, these are located in the following folders:
   
   - `drive:\ibi\WebFOCUS_BUE82\derby\WFBUE82\`
   - `drive:\ibi\WebFOCUS_BUE82\data\apps\`
   - `drive:\ibi\WebFOCUS_BUE82\srv\wfs\hs\`


**Procedure:** How to Restore and Move Backed Up Data

2. After the installation program is complete, do the following:
   
   a. Manually stop the repository server service.
   
   b. Replace the new repository server and Reporting Server application folders, using the backup directories that you made in step 1 of *How to Preserve Your Data* on page 20.
c. Restart the repository server service.

**Procedure:** How to Uninstall WebFOCUS Business User Edition

1. From the Start menu, navigate to the Uninstall shortcut, under the Information Builders Program group.
2. Click *Uninstall*.

The InstallAnywhere installation program opens.

**Note:** If the uninstall program is not visible from the Windows Start menu, uninstall the software using the Programs and Features option on the Control Panel. Alternatively, create a shortcut to `C:\ProgramData\Microsoft\Windows\Start Menu\Programs`. This will open Windows Explorer with a classic view of all installed programs. You can use this to navigate to WebFOCUS Business User Edition 82 in the Information Builders folder, and then run the uninstall program.
3. In the Uninstall WebFOCUS Business User Edition 82 window, click Uninstall, as shown in the following image.

The installation program begins and uninstalls the WebFOCUS Business User Edition components.

**Troubleshooting WebFOCUS Business User Edition**

If you are unable to launch WebFOCUS Business User Edition, ensure that all services are running. If they are not, do the following:

- Stop all services.

- Restart the services, and launch WebFOCUS Business User Edition.
If this does not work, stop the services again. Before you restart the services, ensure that the Hyperstage processes, `ibengine.exe` and `postgres.exe`, are also stopped. Restart your machine if you are still unable to restart the services.

**Port Assignment**

By default, ports in the range of 26000 to 26040 are checked for availability. If the installation program detects that no ports in that range are available, it then increases the range by 10 and checks again for availability. For example, if ports 26000 to 26040 are unavailable, ports 26010 to 26050 are then checked.

**Default Port Assignment.**

- Ports 26000 to 26003 are used by the application server.
- Port 26010 is used by the repository server.
- Ports 26020 to 26023 and port 26040 are used by the Reporting Server.
- Port 26030 is used by the Distribution Server.

**WebFOCUS Business User Edition Log Files**

WebFOCUS Business User Edition creates a log file in the following location for Windows 7:

`drive:\Users\user_id\WebFOCUS_BUE82_Install_date_time.log`

`drive:\Users\user_id\WebFOCUS_BUE82_Debug_date_time.log`

where:

- `user_id` is your Windows user ID.
- `date_time` is the date and time the log file was created.

These log files provide information about the WebFOCUS Business User Edition installation. If you contact Customer Support Services with an installation problem, have these files available.

**Troubleshooting the Uninstall Process**

If you choose to uninstall WebFOCUS Business User Edition, and the uninstall process fails, you can follow one of the procedures in this section to clean up your machine before reinstalling the product.
Before performing one of the following procedures, ensure that you have uninstalled WebFOCUS Business User Edition, as described in Uninstalling WebFOCUS Business User Edition on page 20.

**Procedure:** How to Manually Uninstall WebFOCUS Business User Edition Components Using the Cleanup Utility

If the WebFOCUS Business User Edition uninstall process fails, you can run the wf_cleanup.bat file to clean a damaged installation on your machine.

1. Navigate to the following location on your machine:
   ```
   drive:\ibi\WebFOCUS_BUE82\WebFOCUS\utilities\install\ 
   ```
2. Copy the `wf_cleanup.bat` file from the install directory to a different directory (for example, `drive:\ibi\`).
3. Right-click `wf_cleanup.bat`, and then click Run as administrator.
4. When prompted, type the location of the install directory to proceed.
   **Note:** By default, the utility will back up the Reporting Server apps, data, and the Derby database.

**Procedure:** How to Manually Uninstall WebFOCUS Business User Edition Components

If the WebFOCUS Business User Edition uninstall process fails, you can do the following to manually cleanup the remaining WebFOCUS Business User Edition components on your machine.

2. Remove any remaining services from your machine.
   a. Locate the existing WebFOCUS Business User Edition services. To get the service name, right-click the service in the Windows Services program and click Properties. The Properties dialog box opens, where you can right-click the service name and click Copy, as shown in the following image.

   ![Properties dialog box](image)

   b. To remove a service, open the Command Prompt as an Administrator and issue the following command:

   ```
   sc delete "service name"
   ```

   where:

   ```
   service name
   ```

   Is the name of the service you are manually deleting. For example:
C:\sc delete "WfBUE82AppSrv"

Note: The service name must be enclosed in double quotation marks (".
Repeat this for the remaining services.

3. Open Task Manager and ensure that the process ibengine.exe is not running.

4. Remove files from disk, except for the Reporting Server application folders.
   For example, if WebFOCUS Business User Edition is installed on the C:\ drive, remove all
   folders under C:\ibi\WebFOCUS_BUE82\, except for the following folders:
   - C:\ibi\WebFOCUS_BUE82\data\n   - C:\ibi\WebFOCUS_BUE82\srv\wfs\hs\
   - C:\ibi\WebFOCUS_BUE82\Derby\WFBUE82\n
5. Click Start, point to All Programs, and expand the Information Builders folder.


7. Launch the Windows Registry Editor, and remove the following registry keys.
   - HKEY_LOCAL_MACHINE\SOFTWARE\WebFOCUS_BUE82
   - HKEY_LOCAL_MACHINE\SOFTWARE\Information Builders\Derby\WfBUE82DbSrv
   - HKEY_LOCAL_MACHINE\SOFTWARE\Information Builders\WebFOCUS BUE 82
     Reporting Server
   - HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Information Builders
     \ReportCaster\WfBUE82DistSrv
   - HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Apache Software Foundation
     \Procrun 2.0\WfBUE82AppSrv

Installing the WebFOCUS Business User Edition on a Linux Environment

The following section describes how to install WebFOCUS Business User Edition on a Linux environment. WebFOCUS Business User Edition is supported on:

- Intel Linux - Kernel-2.6.32-glibc-2.6 and higher x86_64 64-bit

   Note: Java Version 8 Update 152 (8u152) and Tomcat 8.5.20 are included with the

- Intel Linux - Kernel-3.10.0-glibc-2.17 and higher x86_64 64-bit
Note: Java Version 8 Update 152 (8u152) and Tomcat 8.5.20 are included with the WebFOCUS Business User Edition product installation.

- Linux on IBM Power Systems - Kernel-3.16.0-libc6-2.19 and higher ppc64le 64-bit (Little Endian)

Note: Java Version 8 Update 144 (8u144) and Tomcat 8.5.20 are included with the WebFOCUS Business User Edition product installation.

The installation program includes the following third-party components: Tomcat, Java, and Derby. Later versions or releases of these third-party components, which often contain fixes for security vulnerabilities, may exist at installation time. It is your responsibility to check the vendor sites listed below for updates to newer versions or releases of these third-party components if you intend to use them with WebFOCUS Business User Edition. Install the new updates or versions prior to proceeding with the WebFOCUS Business User Edition installation. If these components are installed through the WebFOCUS Business User Edition installation program, it is your responsibility to update these components after the installation is completed.

The latest version of Tomcat is available at https://tomcat.apache.org.

The latest version of Java is available at https://www.java.com.

The latest version of Derby is available at https://db.apache.org/derby.

WebFOCUS Business User Edition System Requirements on a Linux Environment

The following section describes the system requirements for installing WebFOCUS Business User Edition on a Linux environment.

Note: Only one installation per platform is supported.

Installation Prerequisites

The following are installation prerequisites for installing WebFOCUS Business User Edition on Linux:

- WebFOCUS Business User Edition cannot be installed as user root, due to requirements of the PostgreSQL database used by Hyperstage. If user root is detected, the installation will exit and the following message displays:

  The installation cannot proceed under the root user account and will terminate. Restart the installation as a non-root user.

- When installing WebFOCUS Business User Edition on Linux machines, if the unzip application is not found, the following message displays:
Invalid unzip command found.

This is generated by the installation program and does not prevent the installation from proceeding and completing successfully.

- WebFOCUS Business User Edition requires a minimum of 5GB of available disk space to successfully install on the target system.

- An additional 8GB of required disk space is used during the installation of the product. This temporary use of disk space will be removed at the end of the installation.

  If the temp directory on the host does not meet the minimum size requirements, the InstallAnywhere environment variable IATEMPDIR can be set to use an alternate directory.

  You may specify an alternate /tmp location by setting the following environment variable:

  \[
  \text{IATEMPDIR}=/large\_tmp
  \]

  \[
  \text{export IATEMPDIR}
  \]

**System Resource Limits**

The operating system provides ways of limiting the amount of resources that can be used. These limits can affect the installation process.

Use the `ulimit` command to set process memory-related resource limits for your session.

The WebFOCUS Business User Edition installation program requires `ulimit` to be set to 8192.

Limits can be *hard* or *soft*. Hard limits are set by the root user. Only the root user can increase hard limits, although other users can decrease them. Soft limits can be set and changed by other users, but they cannot exceed the hard limits. To view the current limits, enter the following command:

\[
\text{ulimit -a}
\]

Use the `/etc/security/limits.conf` file to store `ulimit` settings. Changes to this file should be made by a system administrator.

**Installing WebFOCUS Business User Edition Using Console Mode**

The following section describes how to install WebFOCUS Business User Edition using Console Mode.

**Procedure:** How to Install WebFOCUS Business User Edition Using Console Mode

1. Download the self extracting installation program, `installWebFOCUSBU8202.bin`. 

   Information Builders
2. Apply the permissions necessary for the owner of the file to execute the installation by using the following command:

```bash
chmod u+x installWebFOCUSBUE8202.bin
```

3. Run the installation program using the following command:

```bash
./installWebFOCUSBUE8202.bin -i console
```

The Welcome to WebFOCUS Business User Edition 82 prompt displays.

4. Press Enter to continue.

The License Agreement prompt displays.

5. Read the License Agreement. Press Enter after each screen until you receive the License Agreement Acceptance prompt.

6. Type `Y` to accept the terms of the agreement and press Enter to continue.

The Choose Install Type prompt displays.

7. Type `2` to perform a full installation of WebFOCUS Business User Edition.

8. Press Enter.

The License Code prompt displays.

9. Type the license code (17 digits) for the WebFOCUS Business User Edition Installation.

This code was sent to you as part of the email message that contained the download link for the software.

You are prompted to enter the site code.

10. Type the site code (4 digits) for the WebFOCUS Business User Edition Installation.

This code was sent to you as part of the email message that contained the download link for the software.

11. Press Enter.

The Setup Preferences prompt displays.

12. Accept the default destination folder for the installation. If you want to install WebFOCUS Business User Edition in a different folder, type the path to the location where you want to install the software.

   **Note:** Spaces are not allowed in the destination path.

   You are prompted to enter the WebFOCUS Business User Edition Administration credentials.

13. Type a password to use with the Administration ID, `manager`. 


Note:

- The manager Administration ID cannot be changed.
- During the database creation, the password supports ASCII characters from 32 to 126 and cannot include the following characters: caret (^), ampersand (&), percent (%), or double quotation marks ("). Refer to the ASCII character table to determine the characters to use for the password. As a reference, see https://msdn.microsoft.com/en-us/library/60ecse8t(v=vs.71).aspx. The password for the user name must be between four and 20 characters. Leading blanks and trailing blanks will be removed.

The Advanced Configuration prompt displays. Type Y and press Enter if you want to change the default directory location of the WebFOCUS Business User Edition Reporting Server application. Type N and press Enter if you want to use the default directory location of the WebFOCUS Business User Edition Reporting Server.

If you chose to use the default WebFOCUS Business User Edition Reporting Server directory, the Pre-Installation Summary prompt displays.

14. Verify that the information in the Pre-Installation Summary window is correct, and press Enter to continue.

   The installation begins.

   During installation, the activity window indicates which installation program tasks are being performed.

   When installation is complete, a summary is provided displaying the servers that were installed and the ports that have been assigned.

Configuring Java Memory Allocation for the Application Server

For UNIX installations, the default Tomcat Java memory configuration is set to use an initial Java heap size of 256MB and a maximum Java heap size of 512MB.

These settings are in located in the /ibi/WebFOCUS_BUE82/tomcat/bin/catalina.sh file. For example:

```
JAVA_OPTS="-XX:MaxPermSize=256m -Xms256m -Xmx512m -Djava.awt.headless=true"
```

For better product performance, it is recommended to increase these values. The initial Java heap size should be at least 1024MB (1GB). The size is normally set in Megabytes. For example:

```
-Xms1024m
-Xmx2048m
```
These values need to be set based on the physical memory of the machine. It is recommended to set the minimum/initial memory value to one eighth (1/8) of the physical memory. The maximum value needs to be one quarter (1/4) of the physical memory.

**Launching WebFOCUS Business User Edition**

To launch WebFOCUS Business User Edition, type the following:

```
http://host:port/ibi_apps/
```

**Note:** Enter the application server port number when using this command to start WebFOCUS Business User Edition. The application server port number is the lowest port number displayed in the summary at the end of the WebFOCUS Business User Edition installation.

The default port for the WebFOCUS Business User Edition application server is 26000. It is listed during the end of the installation and also available in the installation log file.

Installation log files are under the user home directory. An example of an installation log file is shown in the example below:

```
/$HOME/WebFOCUS_BUE82_Install_date_time.log

/$HOME/WebFOCUS_BUE82_Debug_date_time.log
```

where:

```
date_time
```

Is the date and time the log file was created.

These log files provide information about the WebFOCUS Business User Edition installation. If you contact Customer Support Services with an installation problem, have these files available.

**Running WebFOCUS Business User Edition Servers Manually**

The following commands are used to manually start and stop the required WebFOCUS Business User Edition servers.

**Note:** The /home/user/ path depends on your installation.

**Starting Servers**

You must start the servers in the following order:

- Repository Server
- Application Server
Distribution Server

To start the WebFOCUS Business User Edition Repository Server, run:
nohup /home/user/ibi/WebFOCUS_BUE82/derby/bin/start.sh &

To start the WebFOCUS Business User Edition Application Server, run:
/home/user/ibi/WebFOCUS_BUE82/tomcat/bin/startup.sh

To start the WebFOCUS Business User Edition Distribution Server, run:
nohup /home/user/ibi/WebFOCUS_BUE82/WebFOCUS/ReportCaster/bin/schbkr &

To start the WebFOCUS Business User Edition Reporting Server, run:
/home/user/ibi/WebFOCUS_BUE82/srv/wfs/bin/edastart -start

Stopping Servers

You must stop the servers in the following order:

Application Server

Distribution Server

Repository Server

Reporting Server

To stop the WebFOCUS Business User Edition Application Server, run:
/home/user/ibi/WebFOCUS_BUE82/tomcat/bin/shutdown.sh

To stop the WebFOCUS Business User Edition Distribution Server, run:
/home/user/ibi/WebFOCUS_BUE82/WebFOCUS/ReportCaster/bin/stopit

To stop the WebFOCUS Business User Edition Repository Server, run:
/home/user/ibi/WebFOCUS_BUE82/derby/bin/stop.sh

To stop the WebFOCUS Business User Edition Reporting Server, run:
/home/user/ibi/WebFOCUS_BUE82/srv/wfs/bin/edastart -stop

Creating Shell Scripts to Start and Stop Servers

You can create shell scripts that run the following commands to start and stop servers:
Start Servers

```
nohup /home/user/ibi/WebFOCUS_BUE82/derby/bin/start.sh &
sleep 5
/home/user/ibi/WebFOCUS_BUE82/tomcat/bin/startup.sh
nohup /home/user/ibi/WebFOCUS_BUE82/WebFOCUS/ReportCaster/bin/schbkr &
/home/user/ibi/WebFOCUS_BUE82/srv/wfs/bin/edastart -start
```

Stop Servers

```
/home/user/ibi/WebFOCUS_BUE82/tomcat/bin/shutdown.sh
/home/user/ibi/WebFOCUS_BUE82/WebFOCUS/ReportCaster/bin/stopit
/home/user/ibi/WebFOCUS_BUE82/derby/bin/stop.sh
/home/user/ibi/WebFOCUS_BUE82/srv/wfs/bin/edastart -stop
```

Note:

- Adjust the paths based on your installation directories.
- The sleep 5 command adds a wait period to ensure Derby has started.

Updating WebFOCUS Business User Edition

You can update an earlier release of WebFOCUS Business User Edition using the following steps.

**Procedure:** How to Update WebFOCUS Business User Edition

2. Ensure that all ports that are used by WebFOCUS Business User Edition processes are stopped. You can run a command, such as `netstat`, to check the ports.
   
   **Note:** If the ports are busy, run a command, such as `lsof`, to identify what processes are still running, and stop those processes. Before you proceed, you must rerun the `netstat` command.

3. Download the self extracting installation program, `installWebFOCUSBUE8202.bin`.
4. Apply the permissions necessary for the owner of the file to execute the installation by using the following command:
   
   ```
   chmod u+x installWebFOCUSBUE8202.bin
   ```

5. Press Enter to continue.
   
   The License Agreement prompt displays.

6. Run the installation program using the following command:
   
   ```
   ./installWebFOCUSBUE8202.bin -i console
   ```

7. Read the License Agreement. Press Enter after each screen until you receive the License Agreement Acceptance prompt.

8. Type Y to accept the terms of the agreement and press Enter to continue.

The Choose Install Type prompt displays.

9. Type 1 to update an existing WebFOCUS Business User Edition installation to a new Service Pack level.

10. Press Enter.

11. Verify that the information in the Pre-Installation Summary window is correct, and press Enter to continue.

The installation begins.

During installation, the activity window indicates which installation program tasks are being performed.

12. Clear the Tomcat cache, all folders under:

   /home/user/ibi/WebFOCUS_BUE82/tomcat/work/catalina/localhost/


14. Start the WebFOCUS Business User Edition Repository Server by running:

   nohup /home/user/ibi/WebFOCUS_BUE82/derby/bin/start.sh &

15. Run the following script file, if this step failed to run during the installation update process.

   /home/user/ibi/WebFOCUS_BUE82/WebFOCUS/utilities/WF ReposUtil/update_repos.sh

   This script will make updates to the WebFOCUS Business User Edition repository that are required to load new roles and BI Portal page templates.

   You are prompted for WebFOCUS Business User Edition Administrator credentials. The built-in user ID is manager.

16. Start the other servers:

   /home/user/ibi/WebFOCUS_BUE82/tomcat/bin/startup.sh
   nohup /home/user/ibi/WebFOCUS_BUE82/WebFOCUS/ReportCaster/bin/schbkr &
   /home/user/ibi/WebFOCUS_BUE82/srv/wfs/bin/edastart -start

The upgrade is now complete and you can use the software.
Uninstalling WebFOCUS Business User Edition

To uninstall WebFOCUS Business User Edition, delete the /home/user/ibi/WebFOCUS_BUE82/ folder or run the uninstall program using the following command:

/home/user/ibi/WebFOCUS_BUE82/Uninstall/Uninstall

Configuring for Email Distribution

An email server is required for email distribution and notifications. The following procedures provide the steps for configuring the supported mail servers.

Procedure: How to Configure the Mail Server

1. From the Business User Edition Portal Menu bar, click Administration, then click Administration Console. Click the ReportCaster tab.

   or

   From the Business User Edition Portal Menu bar, click Tools, then click ReportCaster Status.

2. Click the Configuration option on the ribbon.

3. Select the Email Distribution folder.

4. Type the name of your mail server in the Mail Server text box.

   In addition, if your mail server uses a secure connection or requires authentication, select the appropriate options and type the required credentials. You need to save your configuration changes and restart ReportCaster to make the changes effective.

   If you use Google as your email server, see How to Configure Google as the Email Server on page 36.

   If you use Yahoo as your email server, see How to Configure Yahoo as the Email Server on page 37.
Procedure: How to Configure Google as the Email Server

1. Type the name of the Google SMTP Server in the Mail Server text box, as shown in the following image.

2. Select the This Server Requires a Secure SSL Connection check box.
3. Do not select the This Server Requires a Secure TLS Connection check box.
4. Select the This Server Requires Authentication check box.
5. Click the button to open the SMTP User ID/Password dialog box.
6. Type your Google account name.
7. Type the password for this account.
8. Confirm the password for this account.
9. Click OK to close the dialog box.
10. Click Save in the Manage Configuration group on the ribbon.
11. Click Restart in the Manage Configuration group on the ribbon.
Procedure: How to Configure Yahoo as the Email Server

1. Type the name of the Yahoo SMTP Server in the Mail Server text box, as shown in the following image.

2. Select the This Server Requires a Secure SSL Connection check box.
3. Select the This Server Requires a Secure TLS Connection check box.
4. Select the This Server Requires Authentication check box.
5. Click the button to open the SMTP User ID/Password dialog box.
6. Type your Yahoo account name.
7. Type the password for this account.
8. Confirm the password for this account.
9. Click OK to close the dialog box.
10. Click Save in the Manage Configuration group on the ribbon.
11. Click Restart in the Manage Configuration group on the ribbon.

Navigating the Environment

This topic introduces the Business User Edition environment. It describes how to navigate the Business User Edition portal, the Administration Console, and InfoAssist+.
It is also important to understand that Manager users, Developers, Advanced users, and Basic users have different access to environment options. That access is determined by the group of users to which you are assigned.

**Navigating the Business User Edition Portal**

When you access the Business User Edition, using the Sign-in page or browser URL, you are presented with the Business User Edition portal. From the portal, depending on your user role, you can create and edit content, view content that other users published or shared, create and edit personal pages, manage users, configure the system, upload files to the repository, connect to data and edit data, and access interactive help and instructional materials.

The main components of the Business User Edition portal include a Home page, Resources tree, and Menu bar.

**Home Page**

The Home page, which is shown in the following image, is the first page that you see when you sign in.

![Home page image](image)

The Home page has three sections with which you can interact:

- Menu bar
- Sidebar
- Explorer

The content in these sections varies, depending on your user type.
Menu Bar

The Menu bar is located in the upper-right section of the screen, inside the top banner. The following image shows the Menu bar that appears when you are signed in as a Manager.

The Menu bar gives you access to the following options:

- Change your password (click your username).

- Tools:
  - View the status of deferred reports, and manage them.
  - Stop your outstanding interactive requests that are running.
  - Access Session Viewer, where you can visualize the exploratory analysis of the current web session.
  - Access the ReportCaster Status, where you view the status of your scheduled jobs and log reports.

- Administration:
  - Access the Security Center, where you define users and groups and grant access permissions.
  - Access the Administration Console, where you configure, administer, and monitor the components of the application.
  - Access the Reporting Server Console, where you can view and manage the server environment.
  - View and administer the private resources for groups and users.
  - Switch between Normal mode (seeing your own content) and Manager mode (managing other user content).

- Open the WebFOCUS Resources panel on the right side of the window, so you can manage content on personal portal pages.

- Access the online Help, additional Technical Content resources, Information Builders Home page, as well as information about the Business User Edition application, version, and available licenses.
Sidebar

You can use the sidebar to switch between two views of your repository content. These include:

- **Content.** Displays your repository content and provides options so you can create, share, and modify domains and content. Here, you can also upload files and spreadsheets, connect to data, create portals and pages, and generate sample content.

- **Favorites.** Displays the items that you designate as favorites. To designate an item as a Favorite, right-click the item, and click *Favorites*.

Explorer

The Explorer is the main component of the Home page. Here, you can create and interact with content, work with data, create sample content, organize your repository structure and perform other essential tasks. The Explorer is shown in the following image.

[Image of the Explorer]

The Explorer consists of the following elements:

- **Navigation bar**
- **Resources tree**
Navigation Bar

The navigation bar is located beneath the banner and above the explorer area. You can use the navigation bar to move between folders in your repository, search the contents of a domain or folder, change the view of items in the content area, and refresh content in a domain or folder you select.

A domain node is the highest level of folder organization in the Resources tree. All of the domains that a user is authorized to access are displayed in the tree. Domains contain all of the components and content that you can create.

When you drill down into folders in your repository, the navigation bar generates a breadcrumb trail that you can use to move between folders. You can move back one folder or multiple folders in a single click. You can click a folder name to view the contents of that folder. You can also click arrows between the folders, to see the file structure that is currently displayed, as shown in the following image. The selected folder appears in bold text.
From the navigation bar, you can also search for items in your repository. To search for an item, type a keyword in the Search field and press Enter. The results of your search display in the content area. If the items in your results contain tags, these tags display with your search results. An example of user-defined tags in a search is shown in the following image.

![Search results example](image)

**Note:** Until you enter text, the Search field contains the name of the domain or folder as placeholder text. When you enter text into the Search field, an X appears. Click the X to clear the Search field. The X does not appear if you use a Firefox browser.

You also can toggle the view of your content between Grid View and List View, and refresh all content in a domain or folder. By default, content displays in Grid View. Click the Grid view icon or List view icon to change your view.
Grid View allows you to see the thumbnails of your items, which you can customize to add transparency to your display. The List View is useful when you need to see a large number of items at a glance. You can sort your items by various criteria. An example of a List View is shown in the following image.

You can sort the list by clicking any column title. Each column features a three-step toggle sorting: ascending, descending, and back to default. You can also specify which columns display in the content area by clicking the Settings button, and selecting the desired columns from the list. An example of an expanded settings menu is shown in the following image.
To refresh all content in a selected domain or folder, click Refresh 🔄.

**Resources Tree**

The Resources tree provides a way to view your repository structure and navigate between domains and folders that are available to you. The following image shows an example of a Resources tree.

![Resources Tree Example](image)

You can expand or collapse folders by clicking the plus (+) or minus (-) sign. When you click a folder, its contents display in the content area. You can also right-click a folder to access a shortcut menu of available options. From the shortcut menu, you can perform the following actions:

- Expand or collapse a folder
- Duplicate a folder
- Cut or copy a folder
- Paste content or another folder inside a folder
- Delete a folder
- Allow or suppress access to a folder
- Show or hide a folder
- Configure security rules for a folder
- View and edit properties for a folder
You can customize the width of the Resources tree. To do so, put your cursor on top of the left edge of the Resources tree area, as shown in the following image, and drag the edge to achieve the desired width. Your new width is remembered, and displays the next time you sign in.

![](image)

You can also collapse the Resources tree to allow more room for the content area. To collapse the Resources tree, click the arrow on the left side of the tree. Click the arrow again to expand the Resources tree.

**Actions Bar**

You can use the actions bar to create analytical content, upload files and spreadsheets, connect to data, build portals and pages, schedule procedures, and generate sample content using the options available to you for a domain or folder. The following image shows an example of the actions bar an advanced or basic user has access to for a domain or folder.

![Actions Bar](image)

The default view of the actions bar displays the most common options available to you. You can access additional options by clicking *More*.

The actions bar only displays the items that you can create for the domain or folder that is currently selected. If you click the Domains node, the actions bar only displays the Domain and Folder options. The items that display on the actions bar are also subject to permissions. You can only see the items that are available to you based on your role.
Similar to the Resources tree, you can collapse the actions bar to make more room for the content area. To collapse the actions bar, click the arrow in the upper-right corner of the actions bar, as shown in the following image.

![Actions Bar](image)

Types of Content You Can Create in the Business User Edition

There are many types of content that you can create in the Business User Edition, using the action bar on the Home page. The most common content items include: charts, visualizations, reports, and pages. To access more options, click More.

**Note:** Access to all options on the actions bar is determined by your role in a domain. Contact your administrator to obtain access to additional options.

The following table lists and describes all of the content items that you can create from the Home page.

<table>
<thead>
<tr>
<th>Action Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Chart" /></td>
<td><strong>Chart.</strong> Creates a graphical representation of your data.</td>
</tr>
<tr>
<td><img src="image" alt="Visualization" /></td>
<td><strong>Visualization.</strong> Creates a graphical representation of your data, comprised of one or more visuals. Visuals can be charts, maps, or grids.</td>
</tr>
<tr>
<td><img src="image" alt="Report" /></td>
<td><strong>Report.</strong> Creates a tabular representation of your data.</td>
</tr>
<tr>
<td><img src="image" alt="Document" /></td>
<td><strong>Document.</strong> Creates a customized document.</td>
</tr>
<tr>
<td><img src="image" alt="Sample Content" /></td>
<td><strong>Sample Content.</strong> A set of sample charts, reports, and dashboard that is generated automatically based on uploaded Excel workbooks, CSV files, or existing single-segment Master Files in your repository.</td>
</tr>
<tr>
<td>Action Button</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="image" alt="Page Icon" /></td>
<td><strong>Page.</strong> Launches WebFOCUS Designer, where you can create a flexible interactive application for various BI content, including charts, visualization, reports, maps, URLs, and other resources.</td>
</tr>
<tr>
<td><img src="image" alt="Portal Page Icon" /></td>
<td><strong>Portal Page.</strong> Creates a domain portal page from which you can organizes dynamic content. Domain portal pages can be added to the portal.</td>
</tr>
<tr>
<td><img src="image" alt="Blog Icon" /></td>
<td><strong>Blog.</strong> Creates an interactive item that operates as commonly seen blogs on the internet, and allows users to post and view comments.</td>
</tr>
<tr>
<td><img src="image" alt="Distribution List Icon" /></td>
<td><strong>Distribution List.</strong> Specifies the email addresses, directory locations, or printers that you can configure to distribute a schedule. This includes Email, FTP, or Printer.</td>
</tr>
<tr>
<td><img src="image" alt="URL Icon" /></td>
<td><strong>URL.</strong> Creates a link to a webpage that can be displayed inside a portal or page or within the Repository.</td>
</tr>
<tr>
<td><img src="image" alt="Shortcut Icon" /></td>
<td><strong>Shortcut.</strong> Creates a shortcut to a repository file or a Master file.</td>
</tr>
<tr>
<td><img src="image" alt="Upload File Icon" /></td>
<td><strong>Upload File.</strong> Uploads files such as images and office documents to the repository.</td>
</tr>
</tbody>
</table>
Content Area

The content area displays the items contained within a domain or folder that is currently selected. An example of a content area is shown in the following image.

If a resource contains folders and items, the folders are always displayed first, followed by the items. Items shown in the content area include reports, charts, pages, portals, and more.

You can sort your content by using the two sorting menus in the upper-left corner of the Content Area. One allows you to sort by various criteria, such as title, summary, size, last modified and published dates. The other menu toggles between the descending and an ascending orders. You can also create a customized sorting order, by configuring the Sort Order property for the item. If the sort order is configured, the Default Sort option is added to the menu.

You can right-click any folder or item to access a shortcut menu of options. The following options are available when you right-click a folder or item in the content area.

**Expand/Collapse**
- Expands or collapses a folder. This option is only available for folders.

**Run**
- Runs the report procedure or schedule.

**Run in new window**
- Runs the item in a new window.

**Run deferred**
- Submits a report procedure or a schedule for deferred execution.
Schedule
Launches the scheduling tool, where you can schedules a report procedure to be run. Scheduling options include Email, Printer, and Repository.

View log
Launches the Schedule Log Options dialog box, where you can select whether to view the most recent log report for the schedule, or specify a time range for which to obtain log reports. This option is only available for schedules.

View
Enables you to launch the URL or download a copy of the file to your browser. This option is available for URLs, Excel Workbooks, PDF, HTML, and Image Files.

Edit
Edits an item with the tool that was used to create it.

Duplicate
Makes a copy of the folder or item with an underscore and number appended to the title, for example, duplicating Sales_Report creates Sales_Report_1 in the same location. The number is incremented each time a duplicate is created.

Cut, Copy, and Paste
Cuts, copies, or pastes the folder and its contents or item.

Create shortcut
Creates a shortcut to this item.

Delete
Deletes the folder and its contents or item.

Publish/Unpublish
Allows or suppresses public access to the content.

Show/Hide
Shows or hides the folder or item.

Share/Unshare
Shares content with all users that are permitted to access this content. Unshare stops sharing content with all users.

Comments
Provides access to the following options:

View comments
Opens the blog item and expands all comments.

Remove all comments
Clears all comments from the blog.

Note: These options are only available for blogs.
Add to favorites
Adds the item to the Favorites folder.

Remove favorite
Removes the Favorite from the list. This option is only available for Favorites.

Security
Provide access to the Owner option, which allows you to set the resource owner, either Published (no specific owner), or a specific group or user.

Properties
Shows the properties of the folder or item.

Folder and Item Properties
Authorized users can select the Properties option to review information about a folder or item, including when it was created, the date it was last modified, title, name, and settings that control the functionality available to users when they access the folder, run, or schedule an item.

The General Properties tab includes the following settings:

- **Language.** Indicates the current language of your environment.
- **View All.** Opens the Language Properties dialog box, where you can select a language.
- **Title.** Displays the value that you can use to identify the content in the Resources tree.
- **Name.** Refers to the unique name of the item or folder. Click the Edit button to change the name.
- **Summary.** Detailed explanation that provides additional information about the item.
- **Path.** Full path of the folder or item in the Repository.
- **Created.** Shows the date the folder or item was created.
- **Modified.** Shows the date the folder or item properties were last modified, and identifies the user that modified them.
- **Accessed** Shows the date the folder or item was last opened, and identifies the user that opened it.
- **Tool.** Specifies the type of an item.
- **Owner.** Identifies the user who created the folder or item.
- **Size.** Displays N/A bytes for folders. For items, displays the size in bytes.

- **Publish.** Provides an option to publish or unpublish the folder or item.

- **Show.** Provides an option to show or hide the folder or item.

The Advanced tab allows you to customize the functionality and behavior of the folder or item.

The Advanced Properties tab includes the following properties.

**Explorer/Portal Properties:**

- **Thumbnail.** Allows you to preview and change the thumbnail for an item.

- **Tags.** Adds tag values to the item that display in the search results.

- **Sort order.** Specifies the order to list the folder in the tree or item within other items in a folder.

- **Load in iFrame.** Grants or suppresses a permission to load an item in an iFrame container.

- **Default width.** Sets a default width value for the item, when it is displayed inside the portal at run time.

- **Default height.** Sets a default height value for the item, when it is displayed inside the portal at run time.

**Interactive Reporting Properties:**

- **Prompt for parameters.** Indicates whether to display the Autoprompt HTML page to allow the user to view and select parameter values. When this check box is clear, users will still be prompted if there are any parameters that do not have a value supplied.

- **Enable AutoLinking.** Establishes drill-down links from column data to the target reports that you link together.

- **AutoLink target.** Identifies a report as the target report that is run when the drill-down link is triggered.

  **Note:** The AutoLinking between reports only works if the target report contains a parameterized field that corresponds to one of the fields in the primary AutoLink report.

- **Enable AutoDrill.** Creates drill-down links in reports and charts that contain hierarchical data.

- **Use title for deferred report description.** Indicates whether or not to prompt for a custom deferred report description. If selected, this option gives you an alternative to being prompted for a custom deferred report description.
Only run as deferred report. Runs the report in deferred mode.

The Query Detail Properties tab is only available for reports, charts, and visualizations. It shows which data elements, parameters, and conditions were used in an item.

Navigating the Administration Console

The Administration Console contains four tabs and a menu bar that help you navigate to its settings and other features.

These tabs organize administration activities into the following categories:

- **Configuration.** Configures Reporting Server Connections, Application Settings, Custom Settings, NLS Settings, Dynamic Language Switch, Redirection Settings, and InfoAssist+ Properties.

- **Security.** Configures general security settings for Internal and External Authentication.

- **ReportCaster.** Opens the ReportCaster Console, where you can configure ReportCaster, restart the Distribution Server, configure environment parameters, and turn traces on and off. The Administration Console authenticates to ReportCaster with the value of the user ID, IBIMR_RC_SVCUSER. If this authentication fails, users are prompted for their credentials.

- **Diagnostics.** Displays component installation and configuration details, turns session logging on or off, and enables Managers to view or delete log files.

You can view traces with the Session Viewer, which is accessible from the Tools option on the Menu bar in the Portal.

Options on the menu bar connect you to basic tasks, such as reviewing Business User Edition and third-party licensing information, clearing the cache, closing the Administration Console, or opening the online Help.

To update or review an Administration Console setting, click a tab, and then click the folder or page icon from the main menu on your selected tab. The main window refreshes and the individual settings assigned to your selected page become available.
### Navigating the Configuration Tab

The Configuration tab contains settings and features that describe Reporting Server connections and other application settings, which are listed and described in the following table.

<table>
<thead>
<tr>
<th>Folder [Page]</th>
<th>Available Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reporting Servers</td>
<td>The Reporting Servers subfolders contain the tools that manage all connections from the client to remote servers. Using the following sub-folders, you can:</td>
</tr>
<tr>
<td></td>
<td>- <strong>Server Connections.</strong> Add and change Remote Services settings. In WebFOCUS Business User Edition, this feature is limited to the main reporting server, EDASERVE.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Alternate Server Mappings.</strong> Configure alternate mappings to individual Remote Servers. This feature is not available in WebFOCUS Business User Edition.</td>
</tr>
<tr>
<td>Configuration [Application Settings]</td>
<td>Pages in the Application Settings folder of the Configuration tab manage settings for the WebFOCUS Business User Edition application. Pages in this folder include settings for the following functional areas:</td>
</tr>
<tr>
<td></td>
<td>- Change Management</td>
</tr>
<tr>
<td></td>
<td>- Deferred Reporting</td>
</tr>
<tr>
<td></td>
<td>- ESRI</td>
</tr>
<tr>
<td></td>
<td>- Parameter Prompting</td>
</tr>
<tr>
<td></td>
<td>- Text Generation Server</td>
</tr>
<tr>
<td>Folder [Page]</td>
<td>Available Functionality</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Configuration [Custom Settings] | The Custom Settings page of the Configuration tab contains a text-based input field where you can define advanced customization settings for the Client. Using this page, you can:  
  - Customize Client settings.  
  - Create a Client site profile.  
  - Create a Client universal profile. |
| Configuration [Dynamic Language Switch] | The Dynamic Language Switch page of the Configuration tab contains a list of languages that can be included in this feature.  
| Configuration [Redirection Settings] | The Redirection Settings page of the Configuration tab contains settings that manage the redirection of report output. |
Navigating the Security Tab

The Security tab contains internal and external security settings, which are listed and described in the following table.

<table>
<thead>
<tr>
<th>Folder [Page]</th>
<th>Available Functionality</th>
</tr>
</thead>
</table>

Navigating the ReportCaster Tab

When you click the ReportCaster tab, the ReportCaster Server Status page opens, by default. Features on that page identify the current status of ReportCaster Server operations. For more information, see *Using the ReportCaster Console*. 
Navigating the Diagnostics Tab

The Diagnostics tab contains settings and features that describe system performance and activities, which are listed and described in the following table.

<table>
<thead>
<tr>
<th>Folder [Page]</th>
<th>Available Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Diagnostics</strong></td>
<td>The Diagnostics section of the Administration Console contains the following functional areas:</td>
</tr>
<tr>
<td></td>
<td>🔄 <strong>About WebFOCUS.</strong> Displays version and release information about your installation of WebFOCUS Business User Edition.</td>
</tr>
<tr>
<td></td>
<td>🔄 <strong>Client Verification.</strong> Displays your directory permissions and the status of your ability to perform common operations.</td>
</tr>
<tr>
<td></td>
<td>🔄 <strong>HTTP Request Info.</strong> Displays information about HTTP request headers.</td>
</tr>
<tr>
<td></td>
<td>🔄 <strong>JVM Property Info.</strong> Displays information about your Java VM environment.</td>
</tr>
<tr>
<td></td>
<td>🔄 <strong>Session Monitor.</strong> Displays session monitor events and links to detailed traces.</td>
</tr>
<tr>
<td></td>
<td>🔄 <strong>Log Files.</strong> Displays links to WebFOCUS Business User Edition log files.</td>
</tr>
</tbody>
</table>

Reviewing Version Information

The About WebFOCUS page displays information about the release you are using and the optional components installed with it.

You can use the information on this page to identify your current product release and service pack when corresponding with the Information Builders Customer Support team.

When you click About WebFOCUS, the following information appears in the main window:

- **Edition.** Name of the edition of WebFOCUS, for example, WebFOCUS Business User Edition.
- **Product Release.** Release number, for example, 8.2.
- **Service Pack.** Service pack number, for example, 0.2.
- **Package Name.** Installation file package name, for example, wb102417b.
**Release ID.** Product release number, for example, 8202.

**Build/GEN Number.** Specific product build number, for example, 88.

**Build/GEN Date.** Date and time the build number was generated, for example, October 24, 2017 9:09:01 PM EDT.

**Application Server.** Application Server, for example, Apache Tomcat/8.5.20.

This version of the About WebFOCUS page, that opens from the Diagnostics tab, is only available to those users whose privileges allow them to open and review the Administration Console.

However, the information on this page is also available to those users whose privileges allow them to view the About WebFOCUS Business Intelligence window. To open this other window, in the Business User Edition Portal, on the Menu bar, click **Help**, and then click **About**.

**Reviewing Client Verification**

The Client Verification page displays the current status of client configuration and application settings. When you open this page, the client automatically conducts the test required to verify that configuration and application settings are open and available.

Settings marked pass are available for use. Settings marked fail are not available for use.

The automated verification process includes checking web server aliases and directory permissions for each type of client communication mode (CGI, WFServlet, or ISAPI).

The Client verification tools, by default, place the verification logs in the \logs directory. These tools test read, write, and remove permissions for the \logs directory. They also test read and write permissions for the \config directory.

To test a Reporting Server connection and the current status of the Graph or Table functionality it can deliver, you must open the Configuration tab, and right-click the icon for the Reporting Server you wish to test. All three tests are available on the shortcut menu assigned to each server icon.

**Procedure:** **How to Verify WebFOCUS Business User Edition**

From the Administration Console, click **Diagnostics**, and then click **Client Verification**.

The Client Verification page displays your directory permissions, such as creating and deleting applications, signing in as the administrator, reading and writing from the standard directories, creating and deleting domains, and creating and deleting reports.
Note: If you run this test immediately after performing the installation procedure, there might be a delay resulting from a slow or delayed first time initialization of the Tomcat Web Application that supports client operations.

HTTP Request Headers and JVM Property Information

The Diagnostics tab also contains information about HTTP request headers and your Java VM environment.

- Settings on the HTTP Request Info page display information about the HTTP or HTTPS headers returned to your browser. This information is useful for troubleshooting and configuring HTTP headers, especially if you integrate web or application server security with WebFOCUS Business User Edition or if your web or application server uses virtual hosts (HTTP headers).

- Settings on the JVM Property Info page display information about your Java VM environment. This information is useful for troubleshooting and configuring the Java environment for web applications and for resolving memory or resource issues.

Navigating the InfoAssist+ Interface

InfoAssist+ provides an intelligent, flexible layout for creating reports, charts, visualizations, and documents.

The application window provides intuitive menus and toolbars, a versatile ribbon that provides access to specialized groups for different functional areas of report design, a taskbar for selecting output, and a status bar for directing output.

The application window also provides a resources area for selecting and sorting data, and a multi-faceted results area that can display report design, a preview of report output, or actual report output.
InfoAssist+ Application Window

The components of the InfoAssist+ Application window are shown in the following image.

The main interface components are explained as follows:

1. **Application button.** Provides access to the Application menu of procedure-related commands.

2. **Quick Access Toolbar.** Displays frequently-used commands, such as New, Open, Save, Undo, Redo, View code, Run, and Preview, in a toolbar that remains visible. For more information, see [Quick Access Toolbar](#) on page 63.

3. **Ribbon.** Displays the commands you need to create reports, charts, visualizations, and documents. It also displays the Help menu. For details, see [Ribbon](#) on page 66.

4. **Help.** Provides access to the online technical content for InfoAssist+ in a new browser window.

5. **Resources panel.** Displays the Data pane, Query pane, and Filter pane.

6. **Canvas.** Displays the results of your report. In Live Preview mode, the canvas displays a preview of the file as it is developed.
Depending on the type of file that you are developing, the canvas may display differently. For example, when creating a document, the canvas includes rulers around the development area. This is to assist you in placing the components on to the document.

7. **Navigation taskbar.** Displays groups and icons that provide different views and quick access to all active reports and report output. For details, see *Using the Navigation Taskbar* on page 76.

8. **Status bar.** Provides an output format button that you click to see the selected format and an output target button that you click to view the selected option for displaying new output windows or tabs. For more information, see *Using the Status Bar* on page 77.

**Application Main Menu**

In the upper-left corner of the InfoAssist+ interface, click the IA button to open the Application main menu.

You can run the following commands from the Application main menu:

- **New.** Opens the InfoAssist+ splash screen, where you can create a new report, chart, visualization, or document. The exact functionality of the New command depends on your current InfoAssist+ session.
  
  When you open a new session of InfoAssist+ and then click New, a new report is created. You are prompted to choose a data source.

- **Open.** Opens an existing report, chart, visualization, or document.

- **Save.** Saves a report, chart, visualization, or document.

- **Save As.** Saves a report, chart, visualization, or document with a new name.

- **Run.** Runs a report, chart, visualization, or document.

- **Run Deferred.** Submits a report, chart, or document for processing in the background while you continue to work on other tasks.

- **Close.** Closes the currently active report, chart, visualization, or document.
**Recent Items.** Displays recent reports, charts, visualizations, and documents and those items that have been pinned to the menu. The Recent Items area of the InfoAssist+ Application main menu is shown in the following image.

![Recent Items Image]

Pinned reports, charts, visualizations, and documents are represented by a blue pin icon. Pinned items appear at the top of the list in alphabetical order.

Recent reports, charts, visualizations, and documents are represented by a sideways blue pin icon. Recent items appear below the separator bar in the order in which they were created, with the most recently created item at the top.

You can pin important reports, charts, visualizations, and documents to the top of the Recent Reports section of the Application main menu for quick and easy access. To promote a recent report to pinned report, click the sideways blue pin icon. The icon turns upright and the report is moved to the pinned report area of the Recent Items window, where it stays until it is unpinned.

To demote a pinned report, click the blue pin icon. The icon turns sideways and the report is moved below the separator bar.
A shortcut menu is available when right-clicking a recent item, as shown in the following image.

The options in the menu are:

- **Open.** Opens the selected report, chart, visualization, or document.
- **Pin to list.** Pins or unpins a recent report, chart, visualization, or document to the pinned reports list above the separator bar.
- **Remove from list.** Unpins a pinned report, chart, visualization, or document from the pinned reports list.
- **Clear unpinned list.** Clears all unpinned reports, charts, visualization, or documents from the Recent Items list.
- **Options.** Opens the Options window to customize your user preferences.
- **Exit.** Exits the application.
Reference: Open Dialog Box

The Open dialog box displays when you launch InfoAssist+. It also displays when you join and blend data. You can use this dialog box to do the following:

- Select data sources for creating reports, charts, visualizations, and documents.
- Select data sources for joining and blending data.
- Configure data adapters for connecting to an existing database and creating synonyms.
- Upload user data.

The Open dialog box contains the following options:

Connect to Data

Opens the Connect to Data wizard, where you can configure a Data Adapter to connect to an existing database and create synonyms.

Upload Data

Opens the Upload wizard, where you can upload user data from a machine to which you have access. This data can be used with WebFOCUS reporting.

Open

Opens the selected Master File.

Quick Access Toolbar

The Quick Access Toolbar provides access to the most commonly used functions. It is located to the right of the Application main menu button and is always visible no matter which options are selected.

- Create a new report, chart, document, or visualization. Opens the InfoAssist+ splash screen, where you can create a new report, chart, document, or visualization.
- Open existing item. Opens the Open dialog box, where you can select an existing item.
- Save. Saves a report, chart, document, or visualization.
- Undo and Redo. The Undo icon undoes your last action. The Redo icon repeats your last action.

The Undo icon is enabled (blue) when there is an action to undo. Otherwise, the icon is unavailable (gray). The Redo icon is enabled (blue) when there is an action to redo. Otherwise, the icon is unavailable (gray).
For example, if you add a database field to a report, the Undo icon turns blue. You can now click the Undo icon to remove the database field from the report. The Undo icon turns gray, and the Redo icon turns blue. To restore the field to the report, click the blue Redo icon.

You can also press Ctrl+Z to undo an action, or Ctrl+Y to redo an action.

You can undo and redo up to 25 actions per session. InfoAssist+ maintains the undo and redo list of actions even when you switch between reports.

When a dialog box is open in the application window, you cannot use the Undo and Redo icons. However, when you click OK and close the dialog box, the icons become available for use. With a single click of Undo, you can undo all the actions that you performed in the dialog box, and you can reinstate them with a single click of Redo.

- **View code.** View the underlying code for the report.

- **Procedure Settings.** Click the Procedure Settings button to specify and control items for inclusion in a procedure. The Procedure Settings dialog box presents various SET commands which are useful when you need to tailor your report, chart, or document presentation or content to meet your individual needs. For more information, see Using Procedure Settings.

- **Create Thumbnail.** In InfoAssist+, you can create and store thumbnail images for use in the Business Intelligence Portal. Thumbnail images allow you to see a snapshot of a report or chart without opening the file. In InfoAssist+, you can create a thumbnail image by clicking on the Create Thumbnail icon, which is located on the Quick Access toolbar.
You can create thumbnail images when working in Report and Chart mode in InfoAssist+. These images are smaller renditions (220x160px) of your actual report or chart as it displays in Live Preview. Once you create the thumbnail and save the report or chart, you can access the thumbnail image from the file list on the Home page, as shown in the following image.

**Note:** Thumbnail images are stored as part of the procedure when it is saved in the repository. For more information, see *Create a Thumbnail Image of a Report or Chart*.

- **Run.** Click the *Run* button to run a report, chart, visualization, or document immediately. Click the down arrow to open the Run menu, which contains the following additional options:

- **Preview.** Runs the report, chart, or document in the selected format with the limited number of records as set in the Design group on the Home tab.

- **Run with Default Parameter Values.** Runs a report or chart using the default parameter values. If you have parameters defined, the default value is the first data field defined for the parameter. If you do not have parameters defined, the report or chart will run, regardless.

- **SQL Trace.** Returns the SQL commands for the request.
SQL Preview Trace. Returns the SQL commands for the Live Preview run.

Ribbon

The ribbon is a rectangular area of distinct groups of buttons that spans the top of the InfoAssist+ application window.

The ribbon is contextual and changes depending on the type of file that you are developing. For example, in Chart mode, the ribbon is made up of nine tabs, whereas when working in Visualization mode, the ribbon consists of five tabs. Each tab contains a subset of InfoAssist+ functionality organized in logically-related groups of controls and commands graphically represented by distinctive icons.

Working With the Ribbon

The ribbon contains two types of arrow-based buttons. The first type of button opens a menu when you click it. The Orientation button is an example of this type of button. Clicking the Orientation button opens a menu of options, as shown in the following image.

The second type of button is a split button. Clicking the left side of the split button performs a default action. Clicking the down arrow, on the right side of the button, opens a menu of options. The Header & Footer button is an example of a split button. It is shown in the following image.
Clicking the Header & Footer button on the left opens the Header & Footer dialog box. Clicking the down arrow on the right opens a menu of options.

Some options open dialog boxes of additional commands and option lists.

The ribbon displays all controls and commands using different sized icons and groups, depending on the size of the monitor and application window.

When you reduce the size of the application window, some groups are collapsed into single icons as determined by the amount of available space.

When a group is collapsed into a single icon, the individual icons are removed from view, but are still available. Clicking a collapsed group icon restores the group to its normal full size and displays all of the individual icons.

When expanding a collapsed group, the ribbon collapses a neighboring group to make enough room to expand the selected group.

When an icon, button, or option in a menu or dialog box appears dimmed, that functionality is not available for that report as it currently exists. Some functionality is available for reports only, charts only, visualizations only, or documents only.

In some situations, selecting one or more options makes other options incompatible with the previously selected ones. As a result, the incompatible options are dimmed and unavailable for selection. InfoAssist+ automatically makes incompatible options unavailable as you create and modify a report.

**Note:** If you do not have access to a particular option, contact your administrator.

**Home Tab**

The Home tab contains the most commonly used commands and options, which you can use when developing reports, charts, documents, or visualizations. The following list highlights the features on the Home tab for each mode.

- For reports, the Format, Design, Filter, and Report groups offer options for changing the output format of your report, as well as styling it.

- For charts, the Format, Design, Filter, and Report groups enable you to change the theme or your chart or add a header and footer.

- For documents, options are enabled in the Format and Design groups only. Available options for documents include changing the data source for the document and changing the output format.
For visualizations, the Clipboard, Data, Visual, and Storyboard groups enable you to perform some of the more basic functions, such as copy and paste. You also use the Home tab to change your visual type.

**Related Information for Reports, Charts, and Documents:**

- Using Filters to Customize the Display of Data

**Related Information for Visualizations:**

- Building Visualizations
- Using Storyboards
- Joins

**Insert Tab**

The Insert tab contains options to add reports, charts, existing reports, text, images, and active form controls (for active reports only) to a canvas in Document mode.

**Note:** The Insert tab is only available in Document mode.

**Related Information for Documents:**

- Building a Document

**Format Tab**

The Format tab provides options for formatting your report, chart, document, or visualization. Depending on the mode you are using, you can perform tasks such as selecting a chart type, enabling Auto Linking, or adding navigational aspects to a report.

The following list highlights the features on the Format tab for each mode.

- For reports, the Format tab provides access to the Destination, Navigation, Features, Run with, and Auto Linking groups. These options enable you to perform many functions related to reports, including Auto Drill or any other report navigation feature.

- For charts, the Format tab provides access to the Destination, Chart Types, Features, Labels, Interactive, Run with, and Auto Linking groups. These options enable you to perform a variety of charting tasks, including changing the chart type and adding interactive options.

- For documents, the Format tab enables you to change to Report or Chart mode. You can also access InfoMini.
For visualizations, the Format tab provides access to the Report, Features, Labels, and Interactive groups. These options enable you to format your visualization. Also included are grid commands, as well as various features and label commands.

Related Information for Reports, Charts, and Documents:

- Customizing Reports
- Formatting a Series
- Formatting Data Labels
- Formatting a Legend
- Style and Customize a Report
- Style and Customize a Chart
- Using Auto Drill
- Using the Auto Linking Feature to Link Content

Related Information for Visualizations:

- Building Visualizations
- Customizing Charts and Visualizations

Data Tab

The Data tab contains data manipulation and data display options. For example, you can access Join functionality and work with Defines and Computes. The Data tab is available in the Report, Chart, and Document mode. It is not available in Visualization mode.

The following list highlights the features on the Data tab for each available mode.

- For reports, the Data tab provides access to the Calculation, Join, Filter, Display, and Data Source groups. When working with reports, you can join data sources or create Defines and Computes. You can also filter data.

- For charts, the Data tab provides access to the Calculation, Join, Filter, Display, and Data Source groups. When working with charts, these options enable you to join data sources, create a Define or Compute, and filter data.

- For documents, the Data tab provides access to the Calculation, Join, Filter, Display, and Data Source groups. When working with a document, you can create a define or join data sources. You can also add or switch data sources.
Related Information for Reports, Charts, and Documents:

- Joins
- Using Filters to Customize the Display of Data

Slicers Tab

The Slicers tab provides the ability to create and edit slicers. Slicers are dynamic filters that you can use with reports, charts, and documents.

Note: The Slicers tab is unavailable in Visualization mode.

The features on the Slicers tab are the same for reports, charts, and documents. You can perform the following functions with the slicer functionality:

- Add slicers to your report, chart, or document to create dynamic filters.
- Set a record limit for the display of your data.
- Create groups of slicers to filter your data.
- Add fields to existing slicers.
- Clear slicers to clear all selected values from existing slicers.

Related Information for Reports, Charts, and Documents:

- Creating Slicers

Note: The slicer capabilities are only available in the full version of InfoAssist+.

Layout Tab

The Layout tab provides access to page display and layout options. These include page orientation and AutoFit, which is a feature that limits the width of columns in a report to be no wider than the largest value in each column.

The Layout tab is available in Report, Chart, and Document mode.

Note: The Layout tab is unavailable in Visualization mode.

The following list highlights the features on the Layout tab for each available mode.

- For reports, the Layout tab provides access to the Page Setup and Report groups. These options allow you to change the size or orientation of your report. You can also add page numbers.
For charts, the Layout tab provides access to the Page Setup and Size & Arrange groups. These options allow you to change the orientation or size of your chart. You can also set a height and width for your chart, and enable the AutoFit functionality.

For documents, Layout tab provides access to the Page Setup and Size & Arrange groups. You can change the size of your document and adjust its orientation. You can also lock the height and width aspect ratio of your document.

Related Information for Reports, Charts, and Documents:

Customizing Reports

View Tab

The View tab provides access to reporting options, including design and display options. Some of the options on the View tab control how information is displayed, whether it be in structured view or list view. The View tab is available in all modes of InfoAssist+.

The following list highlights the features on the View tab for each mode.

- For reports, the View tab provides access to the Design, Show/Hide, Data Panel, Query Panel, Output Window and Report groups. When creating your report, you can change the way your data displays or switch to another mode, such as document.

- For charts, the View tab provides access to the Design, Show/Hide, Data Panel, Query Panel, Output Window and Report groups. When creating your chart, you can change the output location for the chart or switch to another report or chart.

- For documents, the View tab provides access to the Design, Show/Hide, Data Panel, Query Panel, Output Window and Report groups. When working with your document, you may want to change the display of data in the Data pane or Query pane.

- For visualizations, the View tab provides access to the Show/Hide, Data Panel, and Report groups. When creating your visualization, you can use these options to show or hide the resources panel. You can also change the display of your data to either logical, list or structured.

Related Information for Reports, Charts, and Documents:

Using the Query Pane and Filter Pane on the Canvas on page 74
Field Tab

The Field tab is enabled in the ribbon when you select a data source field. The options available in the Field tab are specific to the data type that is selected. The options available for numeric fields are different from the options available for non-numeric and date fields. The Field tab provides access to the Filter, Sort, Break, Style, Format, Display, and Links groups.

The following list highlights the features on the Field tab for each mode.

- For reports, the Field tab provides options for filtering and styling your report. It also provides you with access to the Traffic Lights and Within functionality, making your reports more robust and customized.

- For charts, the Field tab enables you to hide a particular field or group values in your chart. You can also use the filter options to limit the display of information in your chart.

- For documents, the Field tab provides options for filtering, as well as Traffic Light functionality. You can also hide fields and add aggregations.

- For visualizations, the Field tab provides options for filtering and sorting, as well as access to the Multi Drill feature. You can also hide fields and add aggregations.

Related Information for Reports, Charts, and Documents:

- Apply Traffic Light Conditional Styling to a Report (By Constant)
- Apply Traffic Light Conditional Styling to a Report (By Field)
- Changing a Field Format

Series Tab

The Series tab provides access to chart options through the Select, Style, Properties, Line, and Pie groups. The Series tab is available in Document, Chart, and Visualization mode. It is not available in Report mode.

The following list highlights the features on the Series tab for each available mode.

- For charts, the Series tab enables you to add such features as a trendline or data labels to your chart. If multiple series are specified, you can select a series and specify options specific to that series.

- For documents, the Series tab displays once you have specified fields within your document or embedded chart. You can use the options on the Series tab to add markers, smoothlines, or trendlines to your data.
For visualizations, the Series tab enables you to switch between series, style the selected series, or add any other property or line features, as required.

**Related Information for Reports, Charts, and Documents:**

- Formatting a Series
- Formatting Data Labels

**Related Information for Visualizations:**

- Formatting Axis Labels

**Understanding the Canvas**

The canvas displays a preview of the report being created or modified on the canvas when you are in the default Live Preview. To select Live Preview, go to Home tab, and in the Design group, click Live Preview, or on the View tab, in the Design group, click Live Preview. The canvas is always fully maximized and cannot be minimized, cascaded, or tiled. However, a blank canvas opens when there is no report.

The canvas displays either live data or sample data.

- To display live data, on the Home tab, in the Design group, click Data from Source (default).
  
  When you select Data from Source, a live preview of the report being built is refreshed on the canvas as you add, remove, and style data source fields in the report.

- To display sample data, on the Home tab, in the Design group, click Use Sample Data.
  
  When you select Use Sample Data, the canvas displays sample data based on the field type, with the same formatting and styling used to display live data.

When you execute a report, the canvas displays the Output window. If the Output is minimized, or if there is no report to preview, the canvas is blank. To change the canvas view, you can select Query Design view or Live Preview from the Design group of the View tab or Home tab.

When working with a report in Live Preview, you can rearrange the columns of the report by dragging them to the left or right, depending on your display preference. If the column is numeric, you are presented with the option to Drop as Sum or Drop as Sort.

**Note:** If you select Drop as Sort, the values are listed individually and they are sorted. If you select Drop as Sum, the values are summed for that particular row. The default is Drop as Sum.
When placing the column in a new location, a red indicator bar displays, indicating the location of placement for the moved column. This allows you to see where the column will be placed before you actually perform the operation.

**Note:** Column sort order can also be rearranged by dragging the fields in the Query field containers of the Query pane to reorder them.

If you create a filter, then the filter appears in the Filter pane.

**Using the Query Pane and Filter Pane on the Canvas**

If you click **Query** on the **Home** tab, in the **Design** group, the Query and Filter panes expand into the canvas.

This provides a larger area for displaying the Query and Filter panes. This feature is useful when you are designing a report with multiple filters or numerous fields.

Depending on whether you are creating a report or a chart, the Query pane displays selected data source fields using different types of Query field containers.

**Related Information:**
- Using Filters to Customize the Display of Data
- Using Field Containers on page 85

**Understanding Output Options**

When you run a report, the output appears, either in a tab on the canvas, or in a new browser window. You can create and display output in several different ways, depending on the following options. You can select these options on the **View** tab, in the **Output Window** group:

- Cascade
- Tile Horizontally
- Tile Vertically
- Single Tab
- New Tab
- Single Window
- New Window
- Switch Output
Output window and tab options are also available in the status bar, and output window display options are also available in the Navigation taskbar.

**Note:** When you run a report, tab focus is not on the output window and pressing the Tab key does not move the selection. To move the Tab focus out of the output window, press F6.

**Reference:** Output Target Options

The following are output target options that you can select.

- **Single Tab.** When you click *Single Tab* and run a report, a new output window is created on the canvas, a report instance is created, and an output tab is placed on the Navigation taskbar. As you modify a report, the same output window is refreshed each time the report is run. This option, which is the default, is ideal when you are working with just one report.

- **New Tab.** When you click *New Tab*, each time you run a report, a new output window is created on the canvas. A new report instance is also created and preserved by the addition of a new output tab on the Navigation taskbar. Each output tab maintains the output of the report that generated the corresponding output window. Selecting an output tab on the Navigation taskbar loads the associated output instance into the output window.

- **Single Window.** When you click *Single Window* and run a report, a new browser window is opened and populated with the report output. As you modify the report, the same browser window is refreshed each time the report is run. If the browser window is closed and the report is run, a new browser window is opened again and is refreshed for each subsequent run. The output is not displayed on the canvas, and an output tab is not added to the Navigation taskbar.

- **New Window.** When you click *New Window*, each time you run a report, a new browser window is opened and populated with the report output. The output is not displayed on the canvas, and an output tab is not added to the Navigation Taskbar.

**Reference:** Output View Options

The following are output view options (Arrange) that you can select.

- **Cascade.** When you click *Cascade*, if multiple output windows exist, they are cascaded diagonally across the canvas. This option does not affect open browser windows when you select New Window or Single Window.

- **Tile Horizontally.** When you click *Tile Horizontally*, if multiple output windows exist, they are tiled horizontally, one above another, across the canvas. This option does not affect open browser windows when you select New Window or Single Window.
Tile Vertically. When you click *Tile Vertically*, if multiple output windows exist, they are tiled vertically, side by side, across the canvas. This option does not affect open browser windows when you select New Window or Single Window.

Switch Output. When you click *Switch Output*, a drop-down menu opens, where you can select any active report to view the output. The selected report is loaded into the output window or browser window, depending on the selected output window or tab option.

Reference: Output Format Options

The Output window can display report output in the following formats: HTML, HTML5, active report, and PDF.

Note: Excel and PowerPoint formats open in their native programs in a window external to InfoAssist+.

Using the Navigation Taskbar

The Navigation taskbar provides quick access to all active output windows and to the report design that generated the output. You can return to the last report that you edited in the Query pane by clicking *Display Design View* on the taskbar. The Navigation taskbar is always visible. It is located near the bottom of the application window, just above the status bar.

Each of the active output windows displays a tab on the Navigation taskbar. Selecting the tab displays that output window on the canvas. If you save a report with a unique name each time you modify it, when the report is executed and a new output window is generated, the unique name appears as a tab on the taskbar. If you continue to modify and execute a report without saving it with a unique name, a number in parentheses is appended to the original, saved report name to differentiate it among the multiple output windows.

The ability to select report output from the Navigation taskbar depends on the output window option selected from the status bar or from the Output Window group of the View tab. For more information, see *Using the Status Bar* on page 77, or *Understanding Output Options* on page 74.

Each report tab on the Navigation taskbar has a shortcut menu with the following options:

- Restore
- Minimize
- Maximize
- Close
Auto Resize

Restore, Minimize, Maximize, and Close are standard options available in any browser window or software application. Minimize, Maximize (if the window is not maximized), or Restore (if the window is maximized), and Close can also be found in the top-right corner of the output window.

The Auto Resize option enables automatic resizing of an output window as needed when you add or remove fields.

The Window Options menu at the far left of the Navigation taskbar provides options for displaying all active output windows on the canvas. The display options that you can select are Cascade, Tile Horizontally, Tile Vertically, Restore All, Minimize All, Maximize All, or Close All. The name of each active output window appears at the bottom of the menu.

The Window Options menu options are directly linked to the options available in the Output Window group of the View tab.

Using the Status Bar

The status bar displays the status of the last selected action, a reports button that shows the number of open reports, an output format button that shows the selected format, as well as a list of the available formats, and an output target button that shows the selected option for displaying new output windows or tabs.

When you click the reports button, a menu opens, with options for selecting any of the open reports. Each report is listed by name and an icon which represents the report type (report, chart, visualization, document). The report you select becomes active.

When you click the output format button, a menu opens, with options for selecting a different output format. For a complete list of options, see Understanding Output Options on page 74.

When you click the output target button, a menu opens, with options for Single Tab (default), New Tab, Single Window, and New Window. For more information, see Understanding Output Options on page 74.

Understanding the Resources Panel

The Resources panel is comprised of the Data pane, the Filter pane, and the Query pane. It is located on the left side of the InfoAssist+ interface and is visible by default. You can customize how the Resources panel displays by using the options on the Home tab and View tab. For example, on the View tab, in the Design group, click Query to display only the Query and Filter panes.
The Data pane, which contains all the fields from the selected data sources, is always displayed.

You can manually adjust the size of the Resources panel. To do so, move the mouse pointer over the border. When the pointer changes to a two-way arrow, drag the border.

Reference: **Field Image List**

In the Resources panel, each field has an image associated with it. The following table displays each image and describes what it represents.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Blob" /></td>
<td>Blob</td>
</tr>
<tr>
<td><img src="image" alt="Calculated Date Field" /></td>
<td>Calculated Date Field</td>
</tr>
<tr>
<td><img src="image" alt="Calculated Numeric Field" /></td>
<td>Calculated Numeric Field</td>
</tr>
<tr>
<td><img src="image" alt="Calculated Other Field" /></td>
<td>Calculated Other Field</td>
</tr>
<tr>
<td><img src="image" alt="Calculated Text Field" /></td>
<td>Calculated Text Field</td>
</tr>
<tr>
<td><img src="image" alt="Cube Property" /></td>
<td>Cube Property</td>
</tr>
<tr>
<td><img src="image" alt="Date or Date and Time Field" /></td>
<td>Date or Date and Time Field</td>
</tr>
<tr>
<td><img src="image" alt="Dimension Field (Standalone or Drillable)" /></td>
<td>Dimension Field (Standalone or Drillable)</td>
</tr>
<tr>
<td><img src="image" alt="Dimension Field (Drillable, Second-level)" /></td>
<td>Dimension Field (Drillable, Second-level)</td>
</tr>
<tr>
<td><img src="image" alt="Dimension Field (Drillable, Third-level)" /></td>
<td>Dimension Field (Drillable, Third-level)</td>
</tr>
<tr>
<td><img src="image" alt="Note: There are 17 dimension field levels. Level 0 is specific to certain databases." /></td>
<td><strong>Note:</strong> There are 17 dimension field levels. Level 0 is specific to certain databases.</td>
</tr>
<tr>
<td><img src="image" alt="Geographic Role Dimension Field (Standalone or Drillable)" /></td>
<td>Geographic Role Dimension Field (Standalone or Drillable)</td>
</tr>
<tr>
<td><img src="image" alt="Geographic Role Dimension Field (Drillable, Second-level)" /></td>
<td>Geographic Role Dimension Field (Drillable, Second-level)</td>
</tr>
<tr>
<td>Icon</td>
<td>Type</td>
</tr>
<tr>
<td>------</td>
<td>------</td>
</tr>
<tr>
<td><img src="image1.png" alt="Icon" /></td>
<td>Geographic Role Dimension Field (Drillable, Third-level)</td>
</tr>
<tr>
<td><img src="image2.png" alt="Icon" /></td>
<td>Note: There are 17 geographic role dimension field levels. Level 0 is specific to certain databases.</td>
</tr>
<tr>
<td><img src="image3.png" alt="Icon" /></td>
<td>Funnel (filter)</td>
</tr>
<tr>
<td><img src="image4.png" alt="Icon" /></td>
<td>Geolocation</td>
</tr>
<tr>
<td><img src="image5.png" alt="Icon" /></td>
<td>Index Field</td>
</tr>
<tr>
<td><img src="image6.png" alt="Icon" /></td>
<td>Key Field</td>
</tr>
<tr>
<td><img src="image7.png" alt="Icon" /></td>
<td>Measure</td>
</tr>
<tr>
<td><img src="image8.png" alt="Icon" /></td>
<td>Numeric Field</td>
</tr>
<tr>
<td><img src="image9.png" alt="Icon" /></td>
<td>Text or Alpha Field</td>
</tr>
</tbody>
</table>

**Note:** This list of icons changes based on the type of database that is in use.

**Reference:** Filter Pane

The Filter pane displays all filters that have been created for the selected report.

For more information on filtering, see *Field Tab* on page 72 and *Data Tab* on page 69.

**Note:** The Filter pane displays all created filters, both active (included) and inactive (excluded).

**Using the Data Pane**

The Data pane contains the data fields that are used to construct reports, charts, or visualizations. The default structure of data in the Data pane displays your data by field type, for example, measure field or dimension field. You can explore this structure using the sample retail database that is included with InfoAssist+. The structure of this sample database, which is a cube database, includes measure groups, measure fields, dimension hierarchies, dimension fields, and attributes.
The data fields that display in the Data pane may vary. Depending on the underlying structure of your metadata, these fields may be organized and presented differently. For example, you may have just measures and dimensions, or you may have fields that represent multiple drill levels. You can also have any combination of these field types.

The structure of your metadata dictates the order of the fields, as well as the hierarchy that they employ. InfoAssist+ displays this hierarchy based on the structure defined for the master file that you choose. For more information on the specific field types, see Field Image List on page 78.

If you are using a Business View Plus (BV+) data source, which is built based on a predetermined targeted hierarchy or structure, the view of your Data pane will be set to Structured, by default. When using a BV+ data source, Logical view is disabled. These options are available on the View tab, in the Data Panel group.

**Note:** When you open a BV+ data source, you will have access to common components, such as measures, dimensions, and filters, but values are not supported.

The fields in the database structure are displayed in Logical view, by default. You can use the commands in the View tab to change how your data fields are organized in the Data pane. These commands display the data fields in a Logical, List, or Structured view. All three views provide options for displaying each data source field as a Title, Description, Field, or Alias. The List view also includes options to show the Alias, Format, and Reference of each field.

Field list search functionality is also available in the Data pane, which you can use to search for specific fields within a tree or list. When conducting a search in the Tree view, the search functionality searches only the attribute that is displayed.

When searching in List view, all attributes are searched at once.

**Note:** There are additional options on which you can search, including Name, Title, Alias, Format, Segment, Filename, Description, and Reference.

As you enter search criteria, InfoAssist+ begins the search process. When you enter just a few letters, the list of records that is returned is typically long. As your search criteria gets more specific, the list of returned fields narrows.

If you are conducting a search that you wish to cancel, click the X icon in the field list search tool to abort the search.

**Note:** The X icon displays only when you have search criteria specified in the Search fields box.
Using the Data Pane to Add Fields to a Report

There are several ways that you can add data source fields to a report. You can drag, double-click, or right-click data source fields in the Data pane to add them to a Query field container or the Filter pane.

After you add data source fields to a Query field container, you can change the order of the fields by dragging and dropping one field above or below another field.

**Drag.** This method provides the most control. You can drag data source fields from the Data pane to the appropriate Query field container or Filter pane.

For a larger work area in which to drop data source fields in the appropriate Query field container, make sure that Query Design view is selected, and then, on the View tab, in the Query Panel group, click Areas 2x2 or Areas 1x4.
You can select Query Design view on the Home tab, in the Design group, by clicking Query or on the View tab, in the Design group by clicking Query. That selection expands the Query and Filter panes.

**Multi-Select.** You can multi-select data source fields that you want to add to a report in Live Preview, Query Design view, and Document mode. To select multiple data source fields to add to a report, click the appropriate fields while holding the Ctrl key on the keyboard. You can drag fields onto the canvas, or add them to the Query field container.

**Double-Click.** To automatically add a field to the appropriate Query field container in the Query pane, you can double-click a data source field in the Data pane.

- When you double-click a measure field in the Data pane, it is automatically added to the Sum Query field container.

- When you double-click a dimension field in the Data pane, it is added to the By (Row Label) Query field container for a report, or to the X-axis Query field container for a chart.

You cannot automatically add a field to the Across (Column Label) Query field container for a report, or to the Legend (Series) and Multi-graph Query field containers for a chart.

**Right-Click.** You can right-click a field in the Data pane to add it to the Filter area or a Query field container in the Query pane. For reports, the available shortcut menu options are as follows:

- **Across.** For dimension fields.

- **Add to Query.** Opens a menu of available Query field containers, to which you can add your data.

- **Create Group.** Allows you to create a group of elements based on the field data type that you select.

- **Include as Category Axis.** For dimension fields.

- **Include as Coordinated.** Only available in Document mode.

- **Include as Legends Series.** For dimension fields.

- **Filter.** For all types of fields.

- **Slicers.** For all types of fields.

- **Sort.** Adds the field to the Sort field container. This is for all types of fields.

- **Sum.** For measure fields.
Create Bins. Allows you to create a bin for the selected measure. Bins are used with the Binning functionality. For more information, see Binning.

A measure is a numeric value, such as Gross Profit or Cost of Goods Sold, that you may want to aggregate. All numeric values that can be summed are measures. Numeric fields that cannot be summed, such as product number and miles per gallon, are not treated as measures. Instead, they may be used in the same way as dimension fields to analyze measures. It is up to you to understand your data and determine whether each numeric field can be summed. Related measures can be organized into measure groups. For example, Gross Profit and Cost of Goods Sold can be part of a Sales measure group.

A dimension is a way to categorize data. You can use a dimension to analyze and compare measures. Generally, any field that is not a measure, usually an alphanumeric field such as product, is a dimension. Dimensions can be organized into hierarchies to define the relationships between the fields in the hierarchies. For example, a Geography hierarchy can contain the Continent, Country, State, and City dimensions. You can also define dimension fields that are not part of a dimension hierarchy.

Using the Query Pane and Filter Pane

The Query and Filter panes appear to the right of the Data pane, except when you select Query Design view, which expands the size of the Query and Filter panes. There are different Query field containers for reports and charts.

Note: If you have more than one item in either Sum, By, or Across Query field containers (for reports) or Measure (Sum) or X-axis Query field containers (for charts), you can drag them up or down in the Query pane to rearrange the order in which they display in your report or chart.

When you drag fields to rearrange them, an indicator line displays, providing guidance as to where the field will be placed. The color of this line is determined by the theme. Once you have performed the rearrangement, the Live Preview refreshes based on the newly indicated order.

Reports. For all reports, the Query field containers in the Query pane include Sum, By, and Across.

- Use the Sum field container to aggregate or display numeric measure fields. Its context menu provides options to Sum (default), Print, Count, or List the fields in the report.
- Use the By Query field container to vertically sort dimension fields to produce row labels in the report output. Dimension fields are normally non-numeric or date fields.
- Use the Across Query field container to horizontally sort dimension fields to produce column labels in the report output.
**Charts.** For most charts, the Query field containers in the Query pane include Measure (Sum), X Axis, Legend (Series), Multi-graph and Coordinated. More complex charts that require additional dimension fields have alternative Query field containers.

- **Measure (Sum).** Use this Query field container to aggregate or display numeric measure field values.

- **Location.** Use this Query field container to display a location field. This Query field container displays for maps only.

- **X Axis.** Use this Query field container to sort dimension fields in the chart output.

- **Legend (Series).** Use this Query field container to display dimension fields as color-coded values (lines, bars, areas, scatter plots) that match the color-coded dimension values displayed in the legend below the chart. Legend (Series) provides functionality that is similar to an Across field in a report.

- **Multi-graph.** Use this Query field container to create outermost sort fields and to serve as a page break for working with multiple charts. The sort field added to this Multi-graph Query field container is not plotted on the chart, but each unique sort field value is listed for every chart.

- **Coordinated.** Use this Query field container to collectively sort and collate by a common sort group (for documents only).

For pie charts, the Query field containers in the Query pane include Measure (Sum), Slices, Category, Multi-graph, and Coordinated.

- **Measure (Sum).** Use this Query field container to aggregate or display numeric measure field values in the pie.

- **Pie slices.** Use this Query field container to display dimension fields as color-coded pie slices that match the color-coded dimension values displayed in the legend below the chart. The Pie slices Query field container is equivalent to the Legend (Series) Query field container used for other chart types.

- **Multi-graph.** Use this Query field container to create outermost sort fields and to serve as a page break for working with multiple charts. The sort field added to this Multi-graph Query field container is not plotted on the chart, but each unique sort field value is listed for every chart.

- **Category.** Use this Query field container to sort dimension fields in the chart output. Category is equivalent to the X-axis Query field container used for other chart types.
Coordinated. Use this Query field container to collectively sort and collate by a common sort group (for documents only).

Using Field Containers

Field containers are used to hold fields that you select based on the function that you want it to perform. For example, in Chart and Visualization mode, you can add a field to the Color field container, which will color your data based on the selected field.

For reports, the available field containers are different than those presented for charts and visualizations. This section reviews all of the field containers, providing you with a reference point when working with field containers.

Field Containers for Reports

The following field containers display when creating reports.

Across

Enables you to display column headings across the top of the report for the measure or dimension that is placed in this field container.

By

Enables you to specify sort fields for your report.

Note: You can rearrange the display order of your By sorts by dragging them into the desired order in the Query pane.

Sum

Displays numeric totals for numeric (measure) fields that are added to this field container.

Field Containers for Charts and Visualizations

The following field containers display when creating charts and visualizations.

Animate

Enables you to animate time progression using a slider control. As you move the control along the slider bar, an animation effect results. The slider control has a Play button that allows you to play and pause the animation. When you click Play, the Pause option is activated, enabling you to pause the progression and analyze your data. Slider controls are limited to one sort field and should be time or sequence related, such as month or year. This field container displays for many different chart types.
By

Use this field container to differentiate data types in a field that contains multiple categorical values. For example, when creating a gauge chart, the field that you specify in this field container becomes a By field, by which all values are displayed as a separate chart.

Category

Enables you to display data categorically in a chart. This field container displays for Tag Cloud charts, which are available in the Other charts category.

Category Axis

Use this field container to specify a field that contains categorical data. These categories display on the categorical portion of a 3D bar chart. The other axis, Series Axis, is plotted against the categorical data.

Close

Enables you to specify a numeric field to indicate the closing value of a stock. Other required values include: Open, High, and Low. This field container displays for Stock charts, which are available in the Other charts category.

Color

Enables the application of different colors based on the underlying data set for the field in this field container. When you place a numeric field in the Color field container, the legend displays as a heat scale. When you place an alphanumeric or a date field (non-measure) in the Color field container, the legend displays as colored markers. To change how the legend displays, right-click the Color field container and click Color BY.

Columns

Enables you to specify a field to display column data in a matrix chart in a visual. The use of measure fields is supported. Column data is displayed at the top of the visual, along the X axis. This field container is available for charts and visualizations.

Detail

Use this field container to add detail to your visual by adding a data field to it. For example, if you add Sale,Quarter to the Detail field container in your Scatter plot, the points on the plot are quadrupled, one for each quarter. In addition, the field that you specify in the Detail field container also displays on the hover menu for each point in the plot.

Grouping

Enables you to specify a field by which to present your data in categories or groups. For example, this data field controls how a treemap is grouped.
High
Enables you to specify a numeric field to indicate the high value of a stock. Other required values include: Open, Low, and Close. This field container displays for Stock charts, which are available in the Other charts category.

Horizontal Axis
Displays the data for the selected along the X axis. This field container is available for charts and visualizations.

Note: You can specify up to three fields on the horizontal axis.

Layer
Enables you to specify a Geolocation field for use in a map.

Note: Geolocation fields are listed in the Data pane with a Geolocation icon 🗺️.

Legend (Series)
Enables you to add a field to specify for the legend of the chart. This field container displays for a number of charts that are available in the Other chart category.

Low
Enables you to specify a numeric field to indicate the low value of a stock. Other required values include: Open, High, and Close. This field container displays for Stock charts, which are available in the Other charts category.

Lower Limit
Enables you to specify a numeric (measure) field by which to establish a lower limit. This field container displays for Vertical Box Plot charts, which are available in the Other chart category.

Lower quartile
Enables you to specify a numeric (measure) field by which to establish a lower quartile. This field container displays for Vertical Box Plot charts, which are available in the Other chart category.

Measure
Use this field container to specify a measure that will serve as the basis for a pie chart. The Measure metric is used with the Color field container for pie charts to create sections based on your field selections. It is also used with Gauge charts.
**Measure (Sum)**

Enables you to specify a numeric (measure field) by which to sum data. This field container displays for a number of charts that are available in the Other chart category.

**Median**

Enables you to specify a numeric (measure) field by which to establish an median. This field container displays for Vertical Box Plot charts, which are available in the Other chart category.

**Multi-graph**

Enables the creation of multiple graphs based on the field that you place in this field container. This field container displays for many different chart types, including Spectral Heatmaps, which are available from the Other dialog box.

**Open**

Enables you to specify a numeric field to indicate the opening value of a stock. Other required values include: High, Low, and Close. This field container displays for Stock charts, which are available in the Other charts category.

**Rows**

Enables you to specify a field to display row data in a matrix chart in a visual. The use of measure fields is supported. Row data is displayed on the left side of the visual, along the Y axis. This field container is available for charts and visualizations.

**Series Axis**

Use this field container to specify a series to plot against the data presented on the Categorical Axis. This field container displays for 3D bar charts.

**Size**

Controls the size of markers or other data points.

**Size (Sum)**

Enables you to specify a numeric (measure) field, which will control the size of the data presented in a chart. This field container displays for Tag Cloud charts, which are available in the Other charts category.

**Slices**

Enables you to specify a field whose data values will dictate the size of the slices in a chart. This field container is available for Funnel charts, which are available in the Other chart category.
**Tooltip**

When you place a field in this field container, InfoAssist+ enables you to view additional information in the tooltip for a chart or visual.

**Upper limit**

Enables you to specify a numeric (measure) field by which to establish an upper limit. This field container displays for Vertical Box Plot charts, which are available in the Other chart category.

**Upper quartile**

Enables you to specify a numeric (measure) field by which to establish an upper quartile. This field container displays for Vertical Box Plot charts, which are available in the Other chart category.

**Vertical Axis**

Displays the data for the selected field along the Y axis. This field container is available for charts and visualizations.

**X Axis**

Enables the specification of a field on the X Axis of certain chart types. For example, XY Polar. This field container displays for a number of charts that are available in the Other chart category.

**Y1 Measure (Sum)**

Enables you to specify a measure (numeric) field for the Y Axis in a Pareto and certain line charts, which can be accessed from the Other chart category.

**Y2 Measure**

Use this field container to indicate a measure to serve as the basis for second Y axis. This field is used in various line charts, which can be accessed from the Other chart category.

**Using Shortcut Menu Options in the Query Pane**

In the Query pane, you can right-click any field and select from a list of available options that are displayed in the menu that appears. The options that you can select vary, depending on the type of Query field container in which the field is located and the type of report that you are creating.

You can also rename the content type in the Query pane. You can right-click the component and click *Rename* to change the title.
This allows you to customize the title in the Query pane. In addition, when working in Excel format, the name that you provide is used as the worksheet name in the workbook that is generated at run-time.

**Note:** If you are working with a report or chart in HTML format, you can also access Sum, Print, List, and Count aggregations from the shortcut menu on the report or chart component.

**Related Information:**

- [Using Field Containers](#) on page 85
- [Right-Click Field Options in the Query and Filter Panes](#) on page 90

**Reference:** **Right-Click Field Options in the Query and Filter Panes**

The following table lists and describes all the right-click field options available in the Query and Filter panes for a selected field.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td># of Columns</td>
<td>Opens the Number of Columns dialog box, where you can indicate the number of columns in which you wish to display multiple graphs.</td>
</tr>
<tr>
<td>Aggregation Functions</td>
<td>Provides a menu for selecting options to assign an aggregation type value to a selected numeric field in a report.</td>
</tr>
<tr>
<td>Break</td>
<td>Provides a menu of options to enable page breaks and subtotals, and resetting page numbers.</td>
</tr>
<tr>
<td>Create Group</td>
<td>Allows you to create a group of elements based on the field data type that you select. Once you define a new group, a higher-level field is created that contains the selected elements. For more information, see <a href="#">How to Create a Dynamic Group</a> on page 94.</td>
</tr>
<tr>
<td>Change Title</td>
<td>Opens the Edit Title dialog box, where you can change the title of the selected field by typing the new title in the Enter Title field. <strong>Note:</strong> When changing the title of a column heading, you can place a comma between words in the Enter Title field to create a multi-line header.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Color BY</td>
<td>Changes the Color field container to Color BY. The field container also changes to Color BY when you place a field into the Color field container. You can disable Color BY, which changes a dimension field into a measure field. This option is only available for charts and visualizations.</td>
</tr>
<tr>
<td>Data Bars</td>
<td>Provides a menu for enabling the data bar representation functionality. Selecting On adds a data visualization column to the right of a selected numeric field. The column displays values in each row using horizontal bars that extend from left to right in varying lengths, depending on the corresponding data values.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the selected field.</td>
</tr>
<tr>
<td>Note: In the Query and Filter panes, you can select and delete multiple data fields at one time. Using the CTRL key, select two or more data fields, right-mouse click, and then click Delete.</td>
<td></td>
</tr>
<tr>
<td>Drill Down</td>
<td>Opens the Drill Down dialog box, where you can create multiple drilldown links on a data field to external procedures or websites.</td>
</tr>
<tr>
<td>Edit Format</td>
<td>Opens the Field Format Options dialog box, where you can edit the field type and display options. This option is available for fields within the Sum field container in a report, as well as measure fields in a chart or visualization.</td>
</tr>
<tr>
<td>Note: Any changes to the format of a field will be reflected in the tooltip for charts at run time, as well as for visualizations at design and run time.</td>
<td></td>
</tr>
<tr>
<td>Filter Values</td>
<td>Opens the Filter dialog box for creating WHERE statements, which enable you to select only the data that you want and to exclude all unwanted data.</td>
</tr>
<tr>
<td>Missing</td>
<td>Allows you to show or hide fields with no value.</td>
</tr>
<tr>
<td>Multi-Y Split</td>
<td>Allows you to display individual charts for each measure field where multiple measures are specified. Located on the Vertical Axis, this option is available for charts and visualizations.</td>
</tr>
<tr>
<td><strong>Option</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>----------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>New Parameter</td>
<td>Allows you to add new parameters to your report or chart, which creates parameter options for selection at run time. You can create a new parameter in a report or chart in any field container. <strong>Note:</strong> When working with charts, a new parameter can only be added for charts that use the new attribute syntax.</td>
</tr>
<tr>
<td>Sort</td>
<td>Provides access to the Sort, Rank, and Limit menus. The Sort menu allows you to sort your data either in ascending or descending order. The Limit menu allows you to specify the number of unique values displayed for a sort group that has been added. The Rank menu allows you to insert a rank column immediately to the left if a Sort By field is selected and adds a rank column to the left of the Sort By field if a Measure field is selected. Ranking a Measure field results in two copies of the field, the original Measure field and the Sort By field that is created during ranking.</td>
</tr>
<tr>
<td>Sub Footer</td>
<td>Opens the Sub Header &amp; Sub Footer dialog box where you can edit and style your footers.</td>
</tr>
<tr>
<td>Sub Header</td>
<td>Opens the Sub Header &amp; Sub Footer dialog box where you can edit and style your headers.</td>
</tr>
<tr>
<td>Suppress Empty Group</td>
<td>Suppresses any part of your chart that is empty. You can deselect this option, which is enabled by default. This option is available on the Horizontal axis in both Chart and Visualization mode.</td>
</tr>
</tbody>
</table>
### Option 1: Sort by Total Value

**Description:** Enables you to sort the output in a chart or visualization using the values from the y-axis (Horizontal axis) of a stacked bar chart. While this feature was implemented specifically for Stacked Bar charts, it also applies to regular bar charts, as well as line and area charts. This enables you to view your data as ranked, or sorted, from highest value to lowest value. Accordingly, this option sorts the output by the bar (or other) with the highest total. This option is set to Off by default, but you can select Ascending or Descending to sort your data. This option is available on the Horizontal axis in both Chart and Visualization mode.

**Note:** If you rotate your chart horizontally, the Sort By Total Value menu option displays on the Vertical Axis.

For more information, see *Sort a Chart by Total Value*.

### Option 2: Traffic Light Conditions

**Description:** Opens the Traffic Light Condition dialog box, where you can add new conditional styling or modify existing conditional styling by applying traffic light (and other) colors to a selected field in the report output when the field meets specified criteria.

### Option 3: Visibility

**Description:** Provides a menu for controlling the visibility of the selected field. Clicking *Hide* removes the selected field from the report output. Clicking *Show* (default) displays the selected field in the report output.

All of the shortcut menu options that are available in the Query and Filter panes are also available in the Field tab. For more information, see *Field Tab* on page 72.

### Dynamic Grouping

Dynamic grouping allows you to create groups of elements based on the field data type that you select. For example, in the *wf_retail_lite* database, there are a number of brands of televisions. Using the dynamic grouping functionality, you can create groups based on the popularity of a particular brand. The first group might include top sellers such as LG and Sony. The second group might contain the remaining brands (Panasonic, GPX, Supersonic, Tivax, and Audiovox). This would allow you to group top sellers into one group, and the remaining brands into another group.
**Note:** The Create Group option is only available for dimension fields of non-numeric format or attribute.

You can also specify multiple, unique groupings in the same session. For example, you might want to group the data to indicate groups or products, or specific regions.

**Note:** If you want to exclude a specific data element from your analysis, you can use the filter functionality.

The grouping that you specify is applied and this new group then replaces the original field that you selected in the Query pane. The name that you specify when creating the group is reflected in the Query pane.

**Note:** You can edit the group once it has been created by right-clicking on the higher-level field and clicking *Edit Group*.

**Procedure:** How to Create a Dynamic Group

1. From the Data pane, add one or more data fields to your report or chart.
   
   **Note:** You can use the dynamic grouping functionality on non-numeric dimension fields only.

2. In the Query pane, right-click the data field for which you want to apply dynamic grouping.
   
   **Note:** The Create Group option is also available in the Data pane shortcut menu.

3. Click *Create Group*.
   
   The Create a Group dialog box displays.

4. In the Field text box, optionally type a name for the new group.
   
   **Note:** The fully qualified field name is displayed in the Field Origin text field. This field is enabled and has a read-only attribute. The display of the fully qualified field name is particularly useful when renaming or editing a group, as it identifies the data source followed by the hierarchical location of the field within a data set. For example, WF_RETAIL_LITE.WF_RETAIL_PRODUCT.BRAND.
5. Select the data values that you want to group. Use CTRL + click to select more than one value, as shown in the following image.

![Create a Group dialog box](image)

6. Click **Group**.

**Note:** To ungroup values, click a group and then click **Ungroup**.
7. Optionally, create additional groups, as shown in the following image.

8. Click OK.

Your grouped data will display in the Data pane when your report, chart, or visualization refreshes, as shown in the following image.
Index

A
Administration Console
  Client Verification 57
  Diagnostics 57
  navigating 52
  verification tools 57
application button 59
application main menu 60
application window 59

B
browser requirements 8

C
canvas 59, 73
chart
  Sort By Total Value 93
cleanup utility 24
Client Verification 57
Configuration Tab 53

D
Data pane 79
  adding fields to a report 81
Data Panel group 80
Data tab 69
Diagnostics Tab 56
  Client Verification 57
field images 78
Field tab 72
Filter pane 79
Format tab 68
hardware requirements 8
Help 59
Home tab 68
HTTP request headers 58
HTTP Request Info setting 58

I
InfoAssist+ interface
  application button 59
  application window 59
  canvas 59
  Help 59
  main components 59
  Navigation taskbar 60
  Quick Access Toolbar 59
  Resources panel 59
  ribbon 59
  status bar 60
Insert tab 68
installation 8
installation steps
   Linux 28

J
Java environment 58
JVM Property Info 58

L
Layout tab 71
List view 81
Logical view 81

M
Menu Bar 39

N
Navigation taskbar 60, 76

O
Output window 74
   cascade 75
   output format options 76
   output target options 75
   output view options 75
   switch output 76
   tile horizontally 75
   tile vertically 76

Q
Query pane 74
   right-click options 89
Quick Access Toolbar 59, 63

R
ReportCaster Tab 55
Resources panel 59, 77
   field images 78
   using Query pane in 83
   ribbon 59

S
Security Tab 55
Series tab 73
Slicers tab 70
software requirements 8
status bar 60, 77
Structured view 81
system requirements 8

T
troubleshooting 22

U
uninstalling
   on Linux 35
   on Windows 20, 23
v

verification tools 57

View tab 71

   Data Panel group 80

w

WebFOCUS 58

   Diagnostics menu 58
Feedback

Customer success is our top priority. Connect with us today!

Information Builders Technical Content Management team is comprised of many talented individuals who work together to design and deliver quality technical documentation products. Your feedback supports our ongoing efforts!

You can also preview new innovations to get an early look at new content products and services. Your participation helps us create great experiences for every customer.

To send us feedback or make a connection, contact Sarah Buccellato, Technical Editor, Technical Content Management at Sarah_Buccellato@ibi.com.

To request permission to repurpose copyrighted material, please contact Frances Gambino, Vice President, Technical Content Management at Frances_Gambino@ibi.com.