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Chapter

Customizing Content

After you create your content, you can use the WebFOCUS Business User Edition's vast
array of features and styling options to customize your content.

In this chapter:

-1 Customizing Reports

Customizing Charts and Visualizations

Using Storyboards

Animating Visualizations

Using Filters to Customize the Display of Data
Using Auto Dirill

Using the Auto Linking Feature to Link Content
Using Multi Drill

Adding Parameters for Data Selection at Run Time
Working With Slicers

Changing a Field Format

L v v v U v udJ oJ dodoud

Dynamic Grouping

Customizing Reports
You can customize reports using the various options on the Layout tab and Field tab.

. Cell Padding. Opens the Cell Padding dialog box, where you can set specific values to
control the amount of space inserted between rows and columns in a report. For more
information, see How to Use Cell Padding in a Report on page 19.
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Customizing Reports

- AutoFit. Limits the width of columns in a report to be no wider than the largest value in
each column. When additional fields are added, the report automatically grows at design
time. AutoFit Column is selected, by default.

1 Page Break. Starts a new page when the primary sort field changes. Clicking the drop-down
icon enables you to select Reset Page Numbers, which allows you to reset page humbers
on a page break to start at 1.

- Line Break. Inserts a line in the report output when the primary sort field changes.

-l Sub Header. Opens a dialog box where you can type text to add a subheading just below
the column titles in the report output when the primary sort field changes.

- Sub Footer. Opens a dialog box where you can type text to add a subfooting at the end of
the data on each page of the report output when the primary sort field changes.

- Subtotal. Inserts a line, total text (TOTAL FIELD Value), and subtotals for all numeric fields
when the primary sort field changes.

The drop-down menu on the Field tab, in the Format group provides three field-type options for
the selected column, which are Alphanumeric, Integer, and Decimal. Selecting the fourth
option, More options, opens the Field Format Options dialog box, which provides further
formatting options for the selected field. For more information, see Changing a Field Format on
page 126.

You can also apply floating and non-floating currency, percent signs, and commas. You can
increase and decrease decimal places by clicking the appropriate buttons under the drop-down
menu.

The Currency button is a split button that turns the currency symbol on or off. Click the
Currency button to turn on the default floating currency option. Click the Currency button a
second time to turn off the floating currency option.

To turn on the non-floating currency option, open the drop-down menu and select Non floating
currency. To turn off the non-floating currency option, click the Currency button.

The following options on the Field tab, in the Display group:

- Hide Field. Allows you to hide a selected field.

- Hide Missing. Allows you to hide fields that have no value.

- Aggregation. Opens a drop-down menu of the following options:

1 None (default)

8 Information Builders
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Sum

Average

Count

Count Distinct
Percent of Count
Distinct Values
First Value
Last Value
Maximum
Minimum

Total

Percent

Row Percent
Median

Average Square

Sum is the default aggregation type value for all numeric fields added to the Measure Query
field container in the Query pane. Changing the Measure Query field container from Sum to
Print, Count, or List overrides all assigned aggregation type values. For more information
related to charts, see How to Display Aggregations on Measure Data on page 37.

. Traffic Lights. Opens the Traffic Light Condition dialog box. From this dialog box you can do
the following:

_I

_I

_I

add new conditional styling by applying traffic light (and other) colors to a selected field

in the output when the field meets specified criteria
modify existing conditional styling

enable conditional drill-down

For more information related to reports, see Styling Reports on page 10. For more
information related to charts, see Traffic Light Condition Dialog Box on page 29.
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Styling Reports

-

Data Bars. (Reports only.) Adds a data visualization column to the right of a selected
numeric field. The column displays values in each row using horizontal bars that extend
from left to right in varying lengths, depending on the corresponding data values.

Within. Allows you to use specific aggregation tasks at different report levels. You can use
the Within phrase to manipulate display field values as they are aggregated within a sort
group rather than a report column.

Column(s). Allows you to indicate the number of columns in which you wish to display
multiple graphs. The value can be between 1 and 512. The default is 1. This option is also
available from the Query pane shortcut menu for a Multi-graph component.

You can apply custom styling to specific areas of a report. When creating a report, you can
perform the following styling customization.

_I

_I

Global styling for the entire report.
Style data and column titles.

Style headings and footings. For more information, see How to Style Headings and Footings
in a Report on page 15.

Style the rows of data with alternating colors. For more information, see How to Style Rows
of Data With Alternating Colors in a Report on page 16.

Apply traffic light conditional styling to data. For more information, see How to Apply Traffic
Light Conditional Styling to a Report (By Constant) on page 16 and How to Apply Traffic
Light Conditional Styling to a Report (By Field) on page 18.

Increase or decrease the amount of space inserted between rows and columns. For more
information, see How to Use Cell Padding in a Report on page 19.

Procedure: How to Apply Styling to an Entire Report

10

1.
2.

Create a report, or open an existing report.
On the Home tab, in the Report group, click Style.
The Report Style dialog box opens.

Select any of the following styling options that are available in the Style group.

.4 Font. Opens a drop-down list, which you can use to change the font.
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Font size. Opens a drop-down list, which you can use to change the font size value.
Bold. Applies bold font formatting to the selected text.

Italic. Applies italic font formatting to the selected text

Underline. Underlines the selected text.

Justify Left. Aligns the text to the left of the canvas.

Justify Center. Aligns the text to the center of the canvas.

Justify Right. Aligns the text to the right of the canvas.

Font color. Opens the Color dialog box, where you can select the font color.

Background color. Opens the Color dialog box, where you can select the background
color for the report.

Note: If you have chosen to specify a color, you must click OK to return to the Report
Style dialog box.

Currency Symbol. Opens a drop-down menu, from which you can choose a currency
symbol. Options are US dollar, British Pound, Japanese Yen, Euro, New Israeli Shekel.

Reset to Quick Styles from Template. Resets all settings to the default settings from
the template.

Note: Reset only works while the Report Style dialog box is open. Once you click OK, all
changes are committed. To undo global styling after it has been committed, you must use
the Undo command on the Quick Access Toolbar.

Preview. Displays the text as you have formatted it.

4. Click OK. The report is styled accordingly.

Procedure: How to Perform Field-Level Styling in a Report

You can style data, column titles, or both, in the report output for the selected data source

field.

1. Create a report.

2. In the Query pane, select a data source field.

The Field tab appears on the ribbon.

Customizing Content
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3. In the Style group, click one of the following:

-

-

-

Data Style. Styles only the data for the selected data source field.
Title Style. Styles only the column title for the selected data source field.

Data + Title. Styles both the data and the column title for the selected data source
field.

4. Select any of the following styling options that are available in the Style group.

-

-
-
-

L LU U v U U o u

Font. Opens a drop-down list, which you can use to change the font.
Font size. Opens a drop-down list, which you can use to change the font size value.
Font color. Opens the Color dialog box, where you can select the font color.

Reset to Quick Styles from Template. Resets all settings to the default settings from
the template.

Note: Reset only works while the Report Style dialog box is open. Once you click OK, all
changes are committed. To undo global styling after it has been committed, you must
use the Undo command on the Quick Access Toolbar.

Bold. Applies bold font formatting to the selected text.
Italic. Applies italic font formatting to the selected text
Underline. Underlines the selected text.

Justify Left. Aligns the text to the left of the canvas.
Justify Center. Aligns the text to the center of the canvas.
Justify Right. Aligns the text to the right of the canvas.

Background color. Click the button to open the Color dialog box, where you can select
the background color for the report.

Note: When working with font or background colors, you must click OK on the Color
dialog box to return to the Report Style dialog box.

5. Click OK. The report is styled accordingly.

12
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Procedure: How to Add Headings and Footings to a Report

You can make a report more meaningful by adding headings and footings. Headings and
footings supply context and key information about a report, such as its purpose and audience.
Headings and footings also provide structure, helping you navigate to the detail sought. They
enhance visual appeal.

In this procedure, you will add and style a report heading and page heading. The procedure
uses sample values, but you can supply values that apply to your own, reports.

Headings and Footings are available in Query Design view, Live Preview, and Document view.
1. Create a report.
2. On the Home tab, in the Report group, click the Header & Footer button.
The Header & Footer dialog box opens.
3. Click the tab for the heading or footing element that you want to add.

For a report, you can add a report heading, page heading, page footing, or report footing.
By default, the Report Header tab is selected. In this procedure, accept the default.

4. Click inside the design area of the dialog box, and type the text for the heading.
For example, the text for a sample report heading might be Quantity Sold by Product.
5. Using the styling ribbon, apply styling to the report heading text.

For example, click HELVETICA from the Font drop-down list. From the Font size drop-down
list, click 12.

The sample report heading with the selected styling values is shown in the following
image.

I_%]H eader & Footer

s = &l
HELVETICA ~ 12 » (B I U = = = ﬁ@?@v
Quantity Sold by Product

v “ (S) 2,

6. Click Apply to save the changes you have made so far, without closing the dialog box.
7. To add a page heading, click the Page Header tab.

In this procedure, you are going to add one of the supplied quick text options.

Customizing Content 13



Customizing Reports

14

10.

Click the last icon @ T (Insert preformatted text content for headers/footers) on the
right of the styling ribbon, and click Confidential in the list.

Change the font and font size. For example, change the font to HELVETICA and the size to
10.

You can add your own text before or after the supplied text, for example, For Regional
Managers Only.

%Header & Footer
= g E
HVETCA ~ 8 B I m (= E = B @4 2 5-
Confidential
For Regional Managers Clnly{
o - ® 2

Click OK to save the report heading and page heading and close the Header & Footer
dialog box.

The report heading and page heading that you added and styled are shown in Live Preview
in the following image.

Quantity Sold by Product
Confidential

For Regional Managers Only
Product Quantity
Category Sold
ACCessOries 511,667
Camcorder 455 244
Computers R NEEi
Media Player 771,934
Stereo Systems 1,114,332
Televisions 105,188
Wideo Production 199,749
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11. To make changes, to either the report, or page heading, right-click the heading and click
Edit. You can also double-click on the header to open the Header & Footer dialog box.

Procedure: How to Style Headings and Footings in a Report

You can style headings and footings in the report output for the selected heading or footing
field.

1.
2.

Create a report.

With the report opened in Live Preview, select the heading or footing text that you want to
style.

On the Home tab, in the Report group, click Header & Footer.

The Header & Footer dialog box opens.

Select any of the following styling options that are available in the Style dialog box.

_I

.

L U U U U U U

Font. Opens a drop-down list, which you can use to change the font.

Font size. Opens a drop-down list, which you can use to change the font size value.
Bold. Applies bold font formatting to the selected text.

Italic. Applies italic font formatting to the selected text

Underline. Underlines the selected text.

Justify Left. Aligns the text to the left of the canvas.

Justify Center. Aligns the text to the center of the canvas.

Justify Right. Aligns the text to the right of the canvas.

Font color. Opens the Color dialog box, where you can select the font color.

Background color. Opens the Color dialog box, where you can select the background
color for the report.

Reset to Quick Styles from Template. Resets all settings to the default settings from
the template.

Note: Reset only works while the Report Style dialog box is open. Once you click OK, all
changes are committed. To undo global styling after it has been committed, you must
use the Undo command on the Quick Access Toolbar.

5. Click OK. The report is styled accordingly.

Customizing Content
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Procedure: How to Style Rows of Data With Alternating Colors in a Report
You can style rows of data in a report with alternating colors.
1. Create a report.
2. Open the report in Live Preview.
3. On the Home tab, in the Report group, click Banded.
The Color dialog box opens.
Select a color.
Click OK.

The selected color provides an alternating color scheme for the report. The report output
displays alternating rows of data, using a white background for one row and a background
of the selected color for the next row. This pattern continues throughout the report, as
shown in the following image of Banded report output.

Product Quantity
Category Sold
Accessories 511,667
Camcorder 455 244
Computers 3B1,77T
Media Player 771934
Stereo Systems 1,114, 332
Televisions 105,188
Wideo Production 199,749

Procedure: How to Apply Traffic Light Conditional Styling to a Report (By Constant)

You can apply traffic light conditional styling to data for a selected measure field. By default
the report displays the values that satisfy the first condition in green, and the values that
satisfy the second condition in red.

1. Open a report in Live Preview.

2. Open the Traffic Light Condition dialog box in one of the following ways:

.d Ribbon: Select a field on the report, and then on the Field tab, in the Display group,
click Traffic Lights.

.4 Shortcut Menu: Right-click a field on the report, point to More, and then click Traffic
Light Conditions.

16 Information Builders
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10.
11.

12.
13.

14.

15.

The Traffic Light Condition dialog box opens.

From the Relational Operators drop-down menu below the field name, click a relational
operator. For example, Equal to.

In the field to the right of the Relational Operators drop-down menu, click the down arrow
for the Type drop-down menu.

The Type menu opens.

In the Type drop-down list, click Constant.
Enter a value in the Value field.

or

a. From the Get Values drop-down menu, select one of the following values: All, First,
Last, Minimum, Maximum, or From File. The value that you select appears in the Get
Values field.

b. Select the value in the Get Values field. The value that you selected appears in the
Value field.

Click OK.

The value that you selected appears in the field to the right of the Relational Operators
drop-down menu.

Click the Style button.

The Style menu opens.

From the Style menu, click the Font Color or Background Color button.
The Color dialog box opens.

Select a color.

Click OK.

The color appears in the Preview box.

Click Apply to apply the colors to the report.

Click the Drill Down button.

The Drill Down dialog box opens.

In the Drill Down dialog box, use the radio buttons to specify the action you wish to
perform. For example, drill down to a report or webpage, create an auto link target, or
refresh a Bl portal.

Click OK to close the dialog box.

Customizing Content 17
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16.

In the Traffic Light Condition window, click the New button to set traffic light conditions for
additional fields.

Procedure: How to Apply Traffic Light Conditional Styling to a Report (By Field)

18

You can apply traffic light conditional styling to data for a selected measure field. By default
the report displays the values that satisfy the first condition in green, and the values that
satisfy the second condition in red.

1.
2.

10.

Open a report in Live Preview.

Open the Traffic Light Condition dialog box in one of the following ways:

- Ribbon: Select a field on the report, and then on the Field tab, in the Display group,
click Traffic Lights.

- Shortcut Menu: Right-click a field on the report, point to More, and then click Traffic
Light Conditions.

The Traffic Light Condition dialog box opens.

From the drop-down menu below the field name, select a relational operator. For example,
Equal to.

In the field to the right of the Relational Operators drop-down menu, click the arrow for the
Type drop-down menu.

The Type dialog box opens.

In the Type drop-down list, select Field.

The Type dialog box displays a list of the data fields that you can choose from.
Select a data field from the list.

Click OK.

The field that you selected appears in the field to the right of the Relational Operators
drop-down menu.

Click the Style button.

The Style menu opens.

From the Style menu, click the Color button.
The Color dialog box opens.

Select a color.

The color appears in the Preview box.

Information Builders



1. Customizing Content I

11. Click OK.
12. Click the Drill Down button.
The Drill Down dialog opens.
13. In the Drill Down dialog, specify each of the following;:
. Drill down to a report or a webpage
4 URL of the webpage
. An alternate comment
d Target (New Window, Same Window)

.d Parameters that you want to use (Name, Value)

14. Click OK.
15. Click the New button to set traffic light conditions for additional fields.

Procedure: How to Use Cell Padding in a Report

You can customize the amount of space inserted between rows and columns in a report.

1. Open a report in Live Preview.

2. On the Layout tab, in the Report group, click Cell Padding, and then click Custom.
The Cell Padding dialog box opens.
Type the cell padding values that you want in the Top, Bottom, Left, and Right fields.
Click OK.
The report reflects the cell padding that you set.

Customizing Content 19
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The following image shows a report with custom cell padding.

& | Reportl[0]

Quantity Sold by Product

Confidential

For Regional Managers Only

Product Quantity
Category Sold
Accessories 511,667
Camcorder 455 244
Computers 351,777
Media Flayer 771,934
Stereo Systems 1,114,332
Televisions 105,188
Video Production 199,749
Report Style Dialog Box

The Report Style dialog box provides options to style your report, as described below.

4 Font. Use the drop-down menu to change the font.

Font size. Use the drop-down menu to change the numeric value for the font size.

Font style. Click the appropriate button (bold, italic, underline) to style the selected text.

Text alignment. Click the appropriate button (left, center, right) to align the selected text.

L U o U

Font color. Click the button to open the Color dialog box, where you can select the font
color. For more information, see Color Dialog Box on page 21.

Information Builders



1. Customizing Content I

-1 Background. Click the button to open the Color dialog box, where you can select the
background color for the report.

.4 Currency Symbol. Click the button to access the following currency symbols US Dollar,
British Pound, Japanese Yen, Euro, New Israeli Shekel.

Note: The New Israeli Shekel currency symbol can be displayed with the following settings
only:

4 Server codepage = 1255, 65001, 424, or 65002.

. Client codepage = 1255 or 65001.

.4 Application server encoding = Cp1255 or UTF8.

.4 Font name = Lucida Sans Unicode or Arial Unicode MS.

d Reset to Quick Styles from Template. Click the button to reset all settings to the default
settings from the template.

Note: Reset only works while the Report Style dialog box is open. Once you click OK, all
changes are committed. To undo global styling after it has been committed, you must use
the Undo command on the Quick Access Toolbar.

Color Dialog Box
The Color dialog box provides options for working with color in your report.

The Color dialog box options are:

4 Standard Color Swatches. Provides a set of 48 predefined colors from which to choose on
the left side of the dialog box. Your selection appears in the Selected Color field.

.d Custom Color Palette. Provides a palette on the right side of the dialog box to define a
custom color. Your selection appears in the Selected Color field.

d Luminesity bar. Drag the slider to change the luminosity (relative lightness or darkness) of
a color. The corresponding numerical value appears in Lum.

-1 Hue. Indicates the hue value of your selected color. You can enter a value, or increase or
decrease the hue value by using the up and down arrows, respectively.

. Sat. Indicates the saturation value of your selected color. You can enter a value, or
increase or decrease the saturation value by using the up and down arrows, respectively.

Customizing Content 21
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-
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Lum. Indicates the luminosity (lightness or darkness) of your selected color. You can enter
a value, or increase or decrease the luminosity value by using the up and down arrows,
respectively.

Red. Represents the numeric value of red (0 to 255).
Green. Represents the numeric value of green (0 to 255).
Blue. Represents the numeric value of blue (0 to 255).
Selected Color. Displays the color that you selected.

Transparent. Makes the color transparent. This is only available for background colors.

Report Group

The Report group on the Home tab contains commands to enhance a report.

_I

Theme. Opens a dialog box where you can select a theme to style your report. You can use
the default style sheet by clicking the Use Default Stylesheet button.

You can also select a document styling theme or an application theme to style all reports
created. Use the Environment and Styling section of the Options window, which is
accessible by clicking Options in the Application main menu.

Style. Opens a Report Style dialog box for applying global styling to the entire report. For
more information about the Report Style dialog box, see Report Style Dialog Box on page
20. For more information about styling reports, see Styling Reports on page 10.

Banded. Opens a Color dialog box for choosing a color that provides an alternating color
scheme for the report. The report output displays alternating rows of data, using a white
background for one row and a background of the selected color for the next row. This
pattern continues throughout the report. For more information about the Color dialog box,
see Color Dialog Box on page 21. For more information about banded styling, see How to
Style Rows of Data With Alternating Colors in a Report on page 16.

Header & Footer. Opens the Header & Footer dialog box, from which you can add and style
headings and footings.

. For a report, you can add and style report headings, page headings, page footings, and
report footings. In the dialog box, the tab for Report Header is active by default.

.4 For a chart, you can add and style page headings and page footings. Page Header is
active by default.

Information Builders



1. Customizing Content I

- You can drag fields from the Data pane into the Header & Footer dialog box.

Another way to access the Header & Footer dialog box is to click the down arrow next to the
Header & Footer button. It opens a drop-down menu from which you can select the heading
or footing that you want to work with (Report Header, Page Header, Page Footer, Report
Footer). After you make your selection, the Header & Footer dialog box opens, and the
heading or footing that you selected is active.

From the Header & Footer dialog box, you can add and style the active heading or footing,
or choose a different heading and footing to work with by selecting the applicable tab. You
can switch among tabs, but InfoAssist+ does not save changes made on the tabs until you
click Apply or OK. If you click Apply, the Header & Footer dialog box remains open. If you
click OK, the dialog box closes.

You can style a selected heading or footing using the options on the styling toolbar. From
left to right, you can customize the font type, font size, and font style (bold, italic, or
underline). You can justify text (left, center, or right), select the font color and background
color, and restore styling settings to their default value from the template.

You can also add page footings to your reports or charts. From the Header & Footer dialog
box, select Page Footer. When working with reports, you may use the Additional alignment

options icon E_ to specify whether you want to align the footer relative to the data
(default) or relative to the page. The Align Relative to Data option places the footer directly
below the data, and the Align Relative to Page option positions the footer at the bottom of
the page. When working with charts, only the default page footer alignment option is
supported.

Note: The Align Relative to Page option works with reports that use positioned formats (for
example, PDF, PS, DHTML, PPT, and PPTX).

You can also insert quick text into a heading or footing. Quick text is supplied for you. It
includes information that is typically useful in identifying a report or chart. From the
preformatted text drop-down menu, you can select:

4 Draft
Page X of Y
Confidential

Date (multiple formats)

L U U U

Time (multiple formats)

Customizing Content 23



Customizing Reports

- Created by (followed by a name)

For charts, an icon ||" T on the far right of the styling ribbon is enabled. This icon
provides two options for controlling the way in which the page heading and page footing are
rendered. The default option, Create Header and Footer as text, renders the heading and
footing as text elements that are separate from the chart image. The option, Embed Header
and Footer in the chart, renders the heading and footing text as part of the chart image.

Once you have added a heading or footing to a report or chart, you can double-click it on
the canvas in design mode to reopen the Header & Footer dialog box. You can also right-
click an existing heading or footing in design mode and click Edit from the menu to open
the dialog box.

For more information on adding and styling headings and footings, see How to Add
Headings and Footings to a Report on page 13.

Column Totals. (Reports only) Adds a grand total row to the bottom of the report to sum
numeric data in each column.

Row Totals.(Reports only) Adds a grand total column to the right side of the report to sum
numeric data in each row.

Report Features

The options on the Format tab, in the Features group, while in Report mode, allow you to add
pop-up titles to columns, stack measures, and more.

_I

_I
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Title Popup. Displays pop-up titles when the mouse pointer hovers over a column title in
the report output.

Accordion. Creates expandable views of data for each vertical sort field. This option
displays data values only for the first vertical sort field when you first view the output. You
can manually expand your view to expose the data values of lower-level sort fields.

Note: You cannot use the Table of Contents with the Accordion feature.

Repeat Sort Value. Displays all repeated sort values instead of blanks in the output after
the first instance of a new sort value, which is the default behavior.

Stack Measures. Displays all numeric measure field names in a column of the report
output with the corresponding numeric data values.

active report options. Opens the active report options dialog box where you can configure
your active report options such as menu items, graph engine, and colors.
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The following table lists the output for which each feature is available. Yes means the output is
available for the feature. No means that the output is not available for the feature.

HTML HTML5 active PDF Excel PowerPoint
report
Title Popup yes no no no no no
Accordion yes no yes no no no
Repeat Sort Values yes yes yes yes yes yes
Stack Measures yes no no no no no
active report options no no yes no no no

Customizing Charts and Visualizations

Once you have created a visualization or chart, you can customize and style your content. For
example, you can add axis titles or a header. The customization options vary depending on the
type of chart or visual you are developing.

Chart Features

The options on the Format tab, in the Features group allow you to add effects and different
functionality to your charts.

_I

3D Effect. Sets the three-dimensional view to on or off. The 3D Effect feature is disabled
for 3D, stock, gauge, gauge thermometer, Pareto, spectral map, and funnel chart types. By
default, 3D effect is off for all chart types.

Rotate. Toggles between a vertical display or horizontal display of a chart. For more
information, see How to Rotate a Chart on page 92. The Rotate feature is disabled for

pie, scatter, 3D, stock, gauge, gauge thermometer, Pareto, spectral map, and funnel chart
types.

Reference. Opens a drop-down menu that provides the Add Reference Line to Y-Axis and
Add Reference Line to X-Axis options. Selecting one of these options opens the appropriate
Reference Line dialog box, where you can set the specific X-axis or Y-axis value, type the
text that you want, and position the reference line on a chart. For more information, see
How to Display a Static Reference Line on page 92. The Reference feature is disabled for
pie, 3D, stock, gauge, gauge thermometer, Pareto, spectral map, and funnel chart types.
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-1 Annotate. Opens a drop-down menu that provides the Add an annotation option. Selecting
this option opens the Annotation dialog box, where you can type the text that you want and
position the annotation on a chart.

4 Grid. Opens a drop-down menu allowing you to expand options for Horizontal or Vertical
Gridlines. Both selections allow you to enable or disable Major and Minor Gridlines. Clicking
More Options opens the Format Grid Lines dialog box. For more information, see Formatting
Gridlines on page 52.

. Frame & Background. Opens the Frame & Background dialog box where you can edit the
background style and frames for charts. The dialog contains different options depending on
the chart type selected. For more information, see Formatting a Frame and a Background
on page 71.

.4 Gauges. Opens the Gauge dialog box where you can edit your gauge chart. This button is
only available when a gauge chart type is selected. For more information, see How to Style
a Gauge Needle on page 88.

.4 active report Options. Opens the active report options dialog box where you can configure
your active report options, such as menu items, graph engine, and colors. This button is
available when the output type is set to active report.

Note: Annotate is not available in HTML5.

Labeling Charts

You can add labels to charts and visualizations using the Labels group on the Format tab.

.4 Axes. Opens a drop-down menu, where you can enable, stagger, and rotate horizontal and
vertical axis labels. You can also edit the axis labels by clicking More Horizontal Axis
Options or More Vertical Axis Options. For more information, see Formatting Axis Labels on
page 62.

4 Legend. Opens a drop-down menu, where you can select the Show Legend option to display
the legend on the chart, or clear your selection to hide the legend, change the default
legend position, and change the default legend orientation. For more information, see
Format Legend Dialog Box on page 48.
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Accessing Chart Formatting Tools

Your presentation of data on a chart or visualization is successful when it communicates to
your audience the message that you intend. InfoAssist+ helps you meet the needs of your
audience and convey your message by providing numerous chart features. For example, you
can adjust the appearance of a chart, add layers of information, or customize the labels that
identify the data on the chart.

Using Live Preview

In Live Preview, the canvas on the right of the window provides a preview of the content that
you can interact with. The preview is context sensitive, meaning that depending on what
portion you select different options become available.

In Live Preview, when you hover the mouse over a graph element (for example, legend, axis
label, title), the bounding area is highlighted with a dotted line.

In Live Preview, when you select a graph element (for example, legend, axis label, title), the
bounding area is highlighted with a solid line.

Once you select a chart element, you can access all available design options on the ribbon, or
you can right-click an element to open a shortcut menu of frequently-used design options. Once
you have selected your design option from the ribbon or the menu, InfoAssist+ instantly
applies it to the chart element, so that you see the result immediately.

Shortcut menus are enabled for charts that are generated with either sample data, or live data
from your data source.

The following sections describe the chart elements and the ribbon options that you can work
with to design your charts in Live Preview.

Related Information:

. Using Field Containers

Formatting a Series

A series is a measure field that is included in a chart or visualization. You can format a series
in a variety of ways. For example, you can change the color of a series, add a trendline to a
series, or change the appearance of markers on a series.

You can access the full set of formatting options on the Series tab and Field tab. For more
information, see Series Tab and Field Tab.

You can also access a subset of frequently-used options by right-clicking a series element on a
chart to open a menu of those options.
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Tip: The options that you see on the menu depend on the type of chart that you are creating.
For example, the Series Type option would not appear on the menu for a pie chart, but it would
appear for a bar, line, and area chart.

Associated Dialog Boxes

Whether you access series options from the ribbon or the shortcut menu, you are presented
with a dialog box of options. The following dialog boxes are commonly used for formatting a
series:

4 Format Series
4 Edit Title

- Traffic Light Condition

For Instructions on how to open these dialog boxes, see the procedures in Using Series
Properties on page 32.

Format Series Dialog Box

The Format Series dialog box contains options to format the fill and border of each series on a
chart. To access this dialog box, on the Series tab, in the Style group, click Style.

The Format Series dialog box contains the following tabs:
d Fill

.4 Border
Use the Fill tab to modify the color of a chart series.

The Fill tab contains the following options:
.4 No fill. Select this option to remove the color from the series.
4 Solid fill. Select this option to display the Color and Transparency options.

.4 Color. Click this icon to open the Color dialog box, where you can select a color for the
series.

d Transparency. Move the slider to make the bands opaque (0%) or transparent (100%).
The default is 0%.
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- Gradient fill. Select this option to display the direction of the gradient, the color pattern of
the gradient, and the degrees of transparency for the two colors that make up the gradient.
A gradient is a smooth color transition or blending of one color to another. The number of
colors to use in a gradient is defined by the stop or pin elements.

.4 Direction. Select from this drop-down menu to set the direction of the gradient fill. For
example, Gradient right or Gradient left.

Use the Border tab to specify a border for a chart series.

The Border tab contains the following options:
.d Show Border Color. Select this option to show a border color around each series.

.4 Border Color. Click this icon to open the Color dialog box, where you can select a color for
the border.

Edit Title Dialog Box

To edit the title of a series, right-click a series on the canvas, and click Change Title. The Enter
Title dialog box contains a text field in which you can type the title for a series on a chart. Click
OK and the title appears on the chart.

Traffic Light Condition Dialog Box

The Traffic Light Condition dialog box contains fields for adding new conditional styling or
modifying existing conditional styling by applying a traffic light color to the selected field.

The Traffic Light Condition dialog box contains the following fields.

4 Relational Operators. Select from this drop-down menu to set the relational operator. For
example, Equal to.

4 Type/Value. Click this unlabeled field to open a dialog box that contains the following
fields:

-1 Type. Opens a drop-down menu of the following values Constant and Field. Select
Constant to enter a constant value. Select Field to open a visual display of the fields in
your data source.

d Value: Enables you to specify a value based on the Type that you select.

Note: If you are creating a Traffic Light condition on a full date field, the Value field will
have a calendar icon adjacent to it. You can use this icon to select a date using a
calendar control.
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-1 Get Values. Select a value option from this drop-down list. For example, All or First.

The Traffic Light Condition dialog box contains the following buttons:

- Selected Condition. Click this icon to select a condition to work on.
New. Creates a new rule.

Delete. Deletes a rule.

Color. Opens the Color dialog box.

L LU U L

Drill Down. Opens the Drill Down dialog box, where you can drill down to a webpage or a
URL. Specify the following:

d URL of the webpage or location of the report
- A description
- Target (New Window, Same Window, a value that you enter)

1 Parameters that you want to use (Name, Value)

Series Elements Shortcut Menu

When you right-click a series, a menu of options opens. The menu contains options that are
available on the Field and Series tabs.

The menu options are described in the following table. The table provides links to the sections
of this document in which those options are also discussed.

Option Description

Filter Values Enables you to create or modify a WHERE statement, using the
Filter dialog box. With a WHERE statement, you select only the
data that you want to display, and exclude unwanted data.

For information on filtering your data, see Data Tab and Field
Tab.

Sort Enables you to sort the series in either ascending or
descending order.
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Option

Description

Visibility

Controls the display of the selected series (field) on a chart.
The value Hide suppresses the display of the series, and the
default value Show displays the series.

For instructions, see How to Hide a Field in a Series on page
37.

Change Title

Enables you to edit the title of the selected series. In the Edit
Title dialog box, type the new title in the Enter Title field, and
click OK.

Series Type

Changes the chart type of the selected series to bar, line, or
area. The option None (default) returns the series to the chart
type that was in effect before you changed it. This option
applies to bar, line, and area chart types only.

Series Color

Enables you to specify the color of the selected series, using
the Color dialog box. For more information, see Color Dialog Box
on page 21.

More Style Options

Opens the Format Series dialog box. For more information, see
Format Series Dialog Box on page 28.

Data Labels

Controls the display of data labels (values) on the selected
series. The default value Hide suppresses the display of labels,
and the value Show displays labels.

This option does not apply to the gauge chart type.

For instructions, see How to Show and Hide Data Labels on
page 46.

Color Mode

Controls how color is applied to a series (measure field) on a
chart. The possible settings are By Series (default) and By
Group. For example, assume that there is only one series on a
sample bar chart. The By Series setting applies the same color
to all the bars in the series. The By Group setting applies a
different color to each bar.

For instructions, see How to Control the Color Mode on page
41.

Customizing Content
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Option Description

Add Trendline Draws a line on a chart to indicate a statistical trend.

This option does not apply to the pie, funnel, 3D, gauge, or
stock chart type.

For an example of a chart with a trendline, see How to Add a
Trendline on page 34.

Drill Down Opens the Drill Down dialog box, where you can configure a
hyperlink or a drill-down procedure for the selected field.
Clicking that field in the report output, at run-time, redirects you
to the URL you specified or executes the indicated procedure.

More Contains the Aggregation Functions, Traffic Light Conditions,
and Missing options.

Aggregation Functions assign an aggregation value to a numeric
measure field in a report. For instructions, see How to Display
Aggregations on Measure Data on page 37.

Traffic Light Conditions enables you to specify the color of
numeric measure fields in the output, depending on conditions
that you set. You can use the Traffic Light Condition dialog box
to specify the conditions and colors.

For instructions, see How to Apply Traffic Light Conditions With
Drill-Down to a Numeric Measure Field (By Constant) on page
38 and How to Apply Traffic Light Conditions With Drill-Down to
a Numeric Measure Field (By Field) on page 39.

The Missing option allows you to show or hide fields with no
value.

Delete Removes the selected series from the report and updates the
Live Preview accordingly.

Using Series Properties

The following sections contain procedures for customizing a series.
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Procedure: How to Select a Series

Create a chart or visualization.

On the Series tab, in the Select group drop-down menu, select the Series that you want to
customize.

The Series appears in the drop-down menu field.

Procedure: How to Format the Fill and Border of a Series

Create a chart or visualization.

Open the Format Series dialog box in one of the following ways:

.4 Ribbon: On the Series tab, in the Style group, click Style.

-1 Shortcut Menu: Right-click a series on the chart, and click More Style Options.

The Format Series dialog box opens.

Use the fill and border options to format the series.

For more information, see Format Series Dialog Box on page 28.

Click OK to close the dialog box.

The Format Series dialog box closes. The series fill and border are formatted accordingly.

Click Run to generate the report.

Enhancing Series Using the Series Tab

The Properties group contains commands for enhancing charts, such as changing the type or
adding a trendline, for the selected series.

Procedure: How to Change the Type of a Series

1.
2.

Create a bar, line, or area chart.

Access the list of series types in one of the following ways:
.4 Ribbon: On the Series tab, in the Properties group, open the Type drop-down menu.
.4 Shortcut Menu: Right-click a series on the chart, and point to Series Type.

Select the type that you want the series to become.

The chart contains the new series type.
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Procedure: How to Add a Trendline

A trendline is a line that is drawn over the plot area of a chart or visual to show the pattern of
data points. The pattern reveals a statistical trend. In particular, the slope of the trendline,
which is calculated by subtracting and dividing two different x, y coordinate values, is a value
that indicates the rate at which the y value of a line rises or falls as the x value increases.
Once the slope of your chart or visual is determined, you can further extrapolate your results
and gain further insight into your data.

Note: The mathematical equation for the selected trendline option is only available in chart
mode. It is not available in visualization mode.

1. Create a chart or visualization.
2. Access the menu of trendline types in one of the following ways:

- Ribbon: On the Series tab, in the Properties group, open the Trendline drop-down menu.

- Shortcut Menu: Right-click a series on the chart or visual, and point to Add Trendline.
3. Select the type of trendline that you want to display.
The trendline appears on the canvas.

4. Optionally, to display the mathematical equation for the selected trendline option, on the
Series tab, in the Properties group, click Equation.
Formatting Charts Using the Series Tab

The Series tab contains options for formatting charts.

Procedure: How to Apply Smooth Line Effect to a Line Chart
1. Create a line chart.
2. Select a series on the line chart.
3. On the Series tab, in the Line group, click Smooth Line.

The Smooth Line effect is applied to the series.

Procedure: How to Hide a Series Line Between Markers
Lines appear between markers by default.
To hide a series line between a marker:
1. Create a line chart.

2. Select a series on the line chart.
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3.

4.

On the Series tab, in the Series group drop-down menu, select the series that you want to
hide.

In the Line Group, click Connect Lines.
The series line between the markers disappears.

To make the series line reappear, click Connect Lines again.

Procedure: How to Change the Appearance of a Marker

Markers are used to display points of data on a line chart. They are also used in the legend to
identify the data that is on the chart. The different marker shapes distinguish one series from
another.

1.

2.
3.
4

Create a line chart.

Select a series on the line chart.

On the Series tab, in the Line group, click Marker to open a drop-down menu of options.
From the Marker drop-down menu, select the marker shape. For example, Diamond or
Hourglass.

The markers are formatted.

The following image shows a triangle marker for gross profit data and a star marker for
revenue data.
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Procedure:

Procedure:

Procedure:

Procedure:
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How to Expand Pie Slices

Create a pie chart.

On the Series tab, in the Select group, from the drop-down menu, select one of the
following;:

- All Series expands all slices out from the center of the pie.
- A specific series expands that particular slice out from the center of the pie.
In the Pie group, click Expand.

The pie expands accordingly.

How to Hide a Pie Slice

Create a pie chart.

On the Series tab, in the Select group, from the drop-down menu, select the series that you
want to hide. Then, in the Pie group, click Hide.

The slice is hidden.

How to Filter Values in a Series

Create a chart.
Select a series on the chart.

Open the Filter dialog box in one of the following ways:
- Ribbon: On the Field tab, in the Filter group, click Filter.

- Shortcut Menu: Right-click a series, and click Filter Values.
The Filter dialog box opens.

Select values for values and prompts.

Click OK to close the dialog box.

The series values are filtered.

How to Sort the Fields in a Series
1. Create a chart.

2. Select a series.
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3. Sort the series in one of the following ways:

.4 Ribbon: On the Field tab, in the Sort group, click Up to sort the series values from
smallest to largest, or click Down to sort the series values from largest to smallest.

.d Shortcut Menu: Right click a series on the chart, and point to Sort, and then Sort
again. Click Ascending to sort the series values from smallest to largest, or click
Descending to sort the series values from largest to smallest. Select Limit to open a
list of values to display for a sort group.

The chart appears with the series sorted accordingly.

Procedure: How to Hide a Field in a Series
1. Create a chart or visualization.
2. Hide a field in a series in one of the following ways:
4 Select the field in the Query pane.
.4 Right-click the field in the chart.

. Ribbon: Select the field in the Query pane or by right-clicking it in the chart. On the
Field tab, in the Display group, click Hide Field. Click Hide Field again to make the
series reappear.

4 Shortcut Menu: Right-click a series in the Query pane, or in the chart, point to Visibility,
and then click Hide. Right-click the same series, point to Visibility, and then click Show
to make the series reappear.

The field is hidden.

Procedure: How to Display Aggregations on Measure Data
You can display numeric measure data using a variety of aggregation values.
1. Create a chart or visualization.
2. Open the list of Aggregation options in one of the following ways:
.4 Ribbon: On the Field tab, in the Display group, click Aggregation.
4 Shortcut Menu: Right-click a series, point to More, and then Aggregation Functions.
3. Select an aggregation function.

The aggregation function is applied to the series.
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Note: If you change the Measure (Sum) Query field container in the Query pane from Sum
to Print, Count, or List, the change overrides all assigned aggregation values.

Procedure: How to Apply Traffic Light Conditions With Drill-Down to a Numeric Measure Field (By
Constant)

38

1.
2.

10.

Create a chart or visualization.
Open the Traffic Light Condition dialog box in one of the following ways:

.4 Ribbon: In the Query pane, select a field, and then on the Field tab, in the Display
group, click Traffic Lights.

.d Shortcut Menu: Right-click a series on the chart, point to More, and then click Traffic
Light Conditions.

The Traffic Light Condition dialog box opens. For more information, see Traffic Light
Condition Dialog Box on page 29.

From the Relational Operators drop-down menu below the field name, select a relational
operator. For example, Equal to.

In the field to the right of the Relational Operators drop-down menu, click the down arrow
for the Type drop-down menu.

The Type dialog box opens.
In the Type dialog box, select Constant.
Enter a value in the Value field, or

a. From the Get Values drop-down menu, select one of the following values All, First,
Last, Minimum, Maximum, From File. The value that you select appears in the Get
Values field.

b. Select the value in the Get Values field. The value that you selected appears in the
Value field.

Click OK.

The value that you selected appears in the field to the right of the operator drop-down
menu.

Click the Color button.

The Color dialog box opens.
Select a color.

Click OK.

The color appears in the Preview box.
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Procedure:

11.
12.

13.

14.
15.

Click OK.
Click the Drill Down button.
The Drill Down dialog box opens.

In the Drill Down dialog box, specify each of the following:
. Drill down to a report or a webpage

4 URL of the webpage

. An alternate comment

d Target (New Window, Same Window)

.d Parameters that you want to use (Name, Value)

Click OK to close the dialog box.

Click the New button to set traffic light conditions for additional fields.

How to Apply Traffic Light Conditions With Drill-Down to a Numeric Measure Field (By
Field)

1.
2.

Create a chart or visualization.

Open the Traffic Light Condition dialog box in one of the following ways:

.4 Ribbon: In the Query pane, select a field, and then on the Field tab, in the Display
group, click Traffic Lights.

. Shortcut Menu: Right-click a series on your chart, point to More, and then click Traffic
Light Conditions.

The Traffic Light Condition dialog box opens. For more information, see Traffic Light
Condition Dialog Box on page 29.

From the Relational Operators drop-down menu below the field name, select a relational
operator. For example, Greater than.

In the field to the right of the operator drop-down menu, click the arrow for the Type drop-
down menu.

The Type dialog box opens.
In the Type dialog box, select Field.
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The Type dialog box displays the Dimensions, and Measures and Properties of your data.
You can display the data in the following ways:

- View fields in business order. Select from the following options: Title, Description,
Name, or Alias.

- View fields in a sortable grid. Select from the following options: Name, Title, Alias,
Format, Segment, Filename, Description, or Reference.

- View the hierarchical structure of the data. Select from the following options: Title,
Description, Name, or Alias.

6. Select a field.
7. Click OK.

The field that you selected appears in the field to the right of the operator drop-down
menu.

8. Click the Color button.
The Color dialog box opens.
9. Select a color.
The color appears in the Preview box.
10. Click OK.
11. Click the Drill Down button.
The Drill Down dialog box opens.
12. In the Drill Down dialog box, specify each of the following:
- Drill down to a report or a webpage
d URL of the webpage
- An alternate comment

- Target (New Window, Same Window)

1 Parameters that you want to use (Name, Value)
13. Click OK to close the dialog box.
14. Click the New button to set traffic light conditions for additional fields.

Procedure: How to Change the Title of a Series

40

1. Create a chart or visualization.
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Procedure:

Procedure:

2. Open the Edit Title dialog box in one of the following ways:
.4 Shortcut Menu: Right-click a series on the chart, and click Change Title.
. Query Pane: Right-click a series, and click Change Title.
The Edit Title dialog box opens.
In the Enter Title field, type the new name for the series.
Click OK to close the dialog box.

The series has a new title.

How to Control the Color Mode

When you create a single-series chart, all series groups appear in the same color. To use a
different color for each group, set the color mode to By Group.

1. Create a chart or visualization.
2. Rightclick a series on the chart, point to Color Mode, and then click By Group.

A different color is applied to each group in the series. To return to the default display of
the series in one color, right-click the series, point to Color Mode, and then click By Series.

3. Click Run to generate the report.

How to Delete a Series
1. Create a chart or visualization.
2. Rightclick a series on the chart, and click Delete.

The series is deleted.

Formatting Data Labels

Data labels highlight important data points on a chart. They identify exact numbers. You can
customize data labels in a variety of ways to make them stand out more clearly on the chart.
For example, you can change the position, angle, color, or size of data labels.

Associated Dialog Boxes

Whether you access data label options from the ribbon or the shortcut menu, you are
presented with a dialog box of options. The following dialog boxes are commonly used for
formatting data labels:

. Format Labels
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- Style
d Line Style

For instructions on how to open these dialog boxes, see the procedures in Using Data Labels
Properties on page 46.

Format Labels Dialog Box

The Format Labels dialog box contains options for editing data labels. The Format Labels
dialog box offers different options depending on the chart type that you are using. Bar, line,
and area charts share the same tabs.

The Format Labels dialog box contains the following tabs:
4 General Options

Advanced

Pie Title (for pie charts only)

Pie Labels (for pie charts only)

L o o U

Funnel Labels (for funnel and pyramid charts)
General Options Tab

Use the General Options tab to add data labels to a chart and set their position, angle, and
radius.

The General Options tab contains the following options:

.d Show Data Labels. Select this option to show data labels on a chart. Clear this option to
suppress data labels.

4 Position. Select an option from this drop-down menu to determine where the data label will
be positioned. The options are:

L

Above
Below top edge

Center

L o U

Base
-1 Center back

4 Format Labels. Select from this drop-down menu of preset formats that can be applied to
the labels. Some of the options include Use Pattern, Currency General, and Date Full.
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- Custom Format. Enter a standard number format pattern for the data label. This option is
only available when you select the Use Pattern option from the Format Labels drop-down
menu.

The following table describes the characters that you can use in a custom format.

Character Description

# Is a digit.

0 (zero) Shows as absent.

. (period) Is a placeholder for decimal separator.

, (comma) Is a placeholder for grouping separator.

; (semicolon) Separates formats.

- (dash) Is the default negative prefix.

% (percent) Divides by 100 and shows as a percentage.

X Determines that any other characters can be used in
the prefix or suffix.

‘ (apostrophe) Is used to quote special characters in a prefix or
suffix.

.4 Style Labels. Click this icon to open the Style dialog box, where you can style text. For
more information, see Style Dialog Box on page 45.

- Show Cumulative Sums. Select this option to have the data text labels show cumulative
sums. Clear this option to have data text labels show individual sums. This option is
available for stacked charts.

.d Show Stacked Total. Select this option to display stacked totals. Data position should be
set to Center to display a stacked total. This option is available for stacked charts.

Advanced Tab
Use the Advanced tab to modify additional data labels properties.

The Advanced tab contains the following options:

d Show Zero Labels. Select this option to display zero values in a chart. Clear this option to
display all data values except zero.

Customizing Content 43



Customizing Charts and Visualizations

- Apply color to negative data labels. Select this option to style negative data labels
separately from positive data labels.

- Color. Click this icon to open the Color dialog box, where you can select a color for the
negative number.

Pie Title Tab
Use the Pie Title tab to create and style a pie title.

The Pie Title tab contains the following options:

- Show Pie Title. Clear this option to suppress a pie title. Select this option to display a pie
title. This is the default option.

- Style Title. Click this icon to open the Style dialog box, where you can style pie title text.
Pie Labels Tab
Use the Pie Labels tab to customize your pie data labels.

The Pie Labels tab contains the following options:

- Label Position. Select from this drop-down menu an option to control the display of feeler
lines and labels on a pie chart.

- Label Display. Select from this drop-down menu an option to control the format of labels
displayed next to feelers on a pie chart.

-1 Format Labels. Select from this drop-down menu of preset formats that can be applied to
labels.

J Custom Format. Select this option to use a custom format from a list of preset formats.
See the following table for a list and description of the characters that you can use in a
custom format.

- Style Labels. Click this button to open the Style dialog box, where you can style text.

Ring Label

1 Show Ring Label. Select this option to control the display of the total label on a pie ring
chart.

-1 Format Labels. Select from this drop-down menu of preset formats that can be applied to
labels.

- Custom Format. Enter a standard number format pattern for the data label. This option is
only available when you select the Use Pattern option from the Format Labels drop-down
menu.
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- Style Labels. Click this button to open the Style dialog box, where you can style text.

Feeler Line

. Line Style. Click this button to open the Line Style dialog box, where you can edit the color,
weight, and style of the feeler line.

Funnel Labels Tab
Use the Funnel Labels tab to customize the labels on a funnel or a pyramid chart.

The Funnel Labels tab contains the following options:

. Label Position. Select an option from this drop-down menu to control the display of feeler
lines and labels on a funnel chart.

d Format Labels. Select from this drop-down menu of preset formats that can be applied to
labels.

.d Custom Format. Select this option to use a custom format. See the table in the previous
section for a list and description of the characters that you can use in a custom format.

.4 Style Labels. Click this button to open the Style dialog box, where you can style text.
.4 Style Value. Opens the Style dialog box, where you can style the value.
Feeler Line

d Show Feeler Lines. (Default) Clear this option to suppress feeler lines. Select this option to
display feeler lines.

. Line Style. Click this button to open the Line Style dialog box, where you can edit the color,
weight, and style of the feeler line.

Note: While some style options, such as Show Pie Title and Show Feeler Lines, are enabled
by default, a stylesheet applied to the chart may contain different settings that will override
these default settings.

Style Dialog Box
The Style dialog box contains options to style the data labels.

The Style dialog box contains the following options:
. Font. Use the drop-down menu to change the font.

. Font size. Use the drop-down menu to change the numeric value for the font size.
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- Font style. Click the appropriate button (bold, italic, underline) to style the selected text.
- Text alignment. Click the appropriate button (left, center, right) to align the selected text.

- Font color. Click the button to open the Color dialog box, where you can select the font
color.

- Reset to Quick Styles from Template. Click the button to reset all settings to the default
settings from the template.

Note: Reset only works while the Style dialog box is open. Once you click OK, all changes
are committed. To undo global styling after it has been committed, you must use the Undo
command on the Quick Access Toolbar.

Line Style Dialog Box
The Line Style dialog box contains options to style lines on a chart.

The Line Style dialog box contains the following options:

- Color. Click this button to open the Color dialog box, where you can select the color for the
line.

- Weight. Click this button to open a drop-down menu of line weight options.
- Style. Click this button to open a drop-down menu of line style options.

d Reset. Click this button to reset the line to the default options.

Data Labels Elements Shortcut Menu

When you right-click a data label on a bar, line, or area chart, a menu of the following options
opens:

- Data Labels. Point to this option to toggle between Show and Hide.
1 More Label Options. Click this option to open the Format Labels dialog box.

The shortcut menu contains options that are available on the Series tab.

Using Data Labels Properties

The following sections contain procedures for customizing data labels.

Procedure: How to Show and Hide Data Labels

46

1. Create a chart or visualization.
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2. You can access the option to show data labels in one of the following ways:

.4 Ribbon: On the Series tab, in the Properties group, click Data Labels, and from the drop-
down menu, click More Data Label Options. The Format Labels dialog box opens. On
the General Options tab, select the Show Data Labels check box, and click OK to close
the dialog box. You can use this dialog box to format and style the data labels. For
more information, see Format Labels Dialog Box on page 42. To hide data labels, clear

this option.

-1 Shortcut Menu: Right-click a series on the chart, point to Data Labels, and then click
Show. To hide data labels, right-click a series on the chart, point to Data Labels, and

then click Hide.
The data labels appear, and are formatted and styled accordingly.

The following image shows a chart with data labels.
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Procedure: How to Change the Position of Data Labels
1. On the Series tab, in the Properties group, click Data Labels.
2. On the menu, select the position for the data labels.
The data labels are positioned accordingly.
47
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Formatting a Legend

A legend contains information that is necessary to accurately interpret the data on a chart. By
default, a chart displays either a vertical axis title if there is a single measure field, or a legend
if there are multiple measure fields.

Format Legend Dialog Box

Whether you access legend options from the ribbon or the shortcut menu, you are presented
with the Format Legend dialog box of options. For instructions on how to open this dialog box,
see Using Legend Properties on page 50.

The Format Legend dialog box contains options for formatting a legend on a chart or
visualization. It contains the following tabs:

- Legend Options
4 Markers & Labels
1 Fill

.d Border Styles

For instructions on how to open this dialog box, see the procedures in Using Legend Properties
on page 50.

Use the Legend Options tab to customize the appearance of a legend on a chart or
visualization.

The Legend Options tab contains the following options.

d Show Legend. When selected, a legend displays on a chart or visualization. Clear this
option to suppress a legend on a chart or visualization.

.4 Legend Position. Opens a drop-down menu of options to position the legend. For example,
top or left.

.d Reverse Legend Order. Specifies that the legend be drawn in reverse order. Clear this
option to specify that the legend be drawn in normal order.

Use the Markers & Labels tab to customize the appearance of markers and labels on legends.

The Markers & Labels tab contains the following options:
- Style Labels. Opens the Style dialog box, where you can style text.

d Marker Position. Opens a drop-down menu of options to set the position of text relative to
the legend marker. For example, Left of Text or Above Text.

Information Builders



1. Customizing Content I

Use the Fill tab to modify the color of the legend area. For more information, see Format Series
Dialog Box on page 28.

Use the Border Styles tab to place a border around a legend. For more information, see Format
Series Dialog Box on page 28.

The Border Styles tab contains the following options:
d Show Border. Select this option to place a border around a legend.

.4 Color. With the Show Border option selected, you can click this button to open the Color
dialog box, where you can select a color for the border.

Legend Elements Shortcut Menu

When you right-click a legend on a chart, a menu of options opens. The menu contains options
that are available on the Format tab.

The shortcut menu options are described in the following table. The table provides links to the
sections of this document in which those options are also discussed.

Option Description

Show legend Controls the display of the legend. InfoAssist+ displays the legend
by default. When you clear this option, InfoAssist+ suppresses
the legend. For instructions, see Using Legend Properties on page
50.

The background shortcut menu has an option to restore the
legend after it has been suppressed.

Legend Position Controls the placement of the legend on the chart. For
instructions see, Using Legend Properties on page 50.

Legend Area Color Enables you to specify the color of the legend background area
using the Color dialog box.

This option is available only when you right-click the area around
the legend. For instructions see, Using Legend Properties on page
50.
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Option Description

Legend Border Color Enables you to specify the color of the border around the legend
background area using the Color dialog box.

This option is available only when you right-click the area around
the legend. For instructions see, Using Legend Properties on page
50.

More Legend Options Opens the Format Legend dialog box.

Using Legend Properties

The following sections contain procedures for customizing legend. The procedures are
organized by the tab and group in which their associated options appear on the ribbon.

How to Hide a Legend
1. Create a chart or visualization with multiple measure fields.

2. Clear the Show legend option in one of the following ways:

- Ribbon: On the Format tab, in the Labels group, click Legend, then click Show legend to
clear the option.

- Shortcut Menu: Right-click the legend, and clear the Show legend option.
The legend is hidden.

How to Position a Legend
1. Create a chart or visualization with multiple measure fields.

2. Open the menu of label position options in one of the following ways:

- Ribbon: On the Format tab, in the Labels group, click Legend, then point to Legend
Position.

- Shortcut Menu: Right-click the legend, and point to Legend Position.

3. Select a position for the legend. For example, Auto or Right.

How to Specify the Color of a Legend Border

1. Create a chart or visualization with multiple measure fields.
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2. Open the Format Legends dialog box in one of the following ways:

[ Ribbon: On the Format tab, in the Labels group, click Legend, then click More Legend
Options.

I1 Shortcut Menu: Right-click the legend, and click More Legend Options.

The Format Legends dialog box opens. For more information, see Format Legend Dialog
Box on page 48.

On the Border Styles tab, select the option to Show Border.

Click the Color icon to open the Color dialog box, where you can specify the color of the
legend border.

5. Click OK to close the Color dialog box.
Click OK to close the Format Legend dialog box.

The legend border is formatted accordingly.

The following image is an example of a bar chart with a styled legend.
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Formatting Gridlines

Gridlines are used on a chart as a reference to help you understand the quantities and values
of your data and decode information on the axis. There are four types of gridlines that you can
display and edit on your chart. They are:

.4 Horizontal major gridlines
.4 Horizontal minor gridlines
-1 Vertical major gridlines

- Vertical minor gridlines

Major gridlines enhance the display of values, while minor gridlines supplement major
gridlines. If a plot point falls in between major gridlines, you can use minor gridlines for more
precise interpretation of the data.

. Vertical gridlines in a vertical chart run on the X axis.
.d Horizontal gridlines in a vertical chart run on the Y axis.

. Horizontal major gridlines enhance the display of values, compared to the Y-axis scale
alone. They are enabled by default on many charts. They do not apply to the pie, 3D,
gauge, spectral map, or funnel chart type.

.d Horizontal minor gridlines are disabled by default. They do not apply to the pie, 3D, gauge,
spectral map, or funnel chart type.

- Vertical major gridlines enhance the display of values, compared to the X-axis scale alone.
They are enabled by default. They do not apply to the pie, 3D, gauge, spectral map, or
funnel chart type.

.4 Vertical minor gridlines are disabled by default. They do not apply to the pie, 3D, gauge,
spectral map, or funnel chart type.

Note: The orientation of a chart determines the available gridline options.

Format Grid Lines Dialog Box

You can format horizontal and vertical gridlines, color bands, and frames on a chart using the
options in the Format Grid Lines dialog box. For instructions on how to open this dialog box,
see the procedures in Using Gridline Properties on page 55.

Color bands come in a pair, with each band uniquely colored. They appear in a continually
repeating pattern behind a series on a chart. The contrast of colors is designed to make the
chart easier to read.
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Alternate formatting can be used to apply different colors to sections, called regions, of an
axis.

The Format Grid Lines dialog box contains the following tabs:

4 Major Grid Lines

.4 Minor Grid Lines

.4 Color Bands

4 Frames

Use the Major Grid Lines tab to format the major gridlines on the chart.
The Major Grid Lines tab contains the following options:

-1 Show Grid Lines. Select this option to display major gridlines on a chart if minor gridlines
are the default for the chart.

. Line Style. Click this icon to open the Line Style dialog box, where you can edit the color,
weight, and style of the gridline.

.4 Show Ticks. Select this check box to enable or disable the tick mark functionality.
d Tick Style. Select from this drop-down menu of tick styles (Inside, Outside, Spanning).

.4 Line Style. Click this icon to open the Line Style dialog box, where you can edit the color,
weight, and style of the gridline.

Use the Minor Grid Lines tab to format the minor gridlines on your chart.

The Minor Grid Lines tab contains the following options:

.d Show Grid Lines. Select this option to display minor gridlines on a chart. By default, this
option is enabled.

.4 Line Style. Click this icon to open the Line Style dialog box, where you can edit the color,
weight, and style of the gridline.

Grid count. Set the number of minor gridlines that will appear between major gridlines.
Show Ticks. Select this check box to enable or disable the tick mark functionality.

Tick Style. Select from this drop-down menu of tick styles (Inside, Outside, Spanning).

L U oo u

Line Style. Click this icon to open the Line Style dialog box, where you can edit the color,
weight, and style of the gridline.

Use the Color Bands tab to format the color bands on your chart.
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The Color Bands tab contains the following options:
1 Band 1. Select this option to add Band 1 to a chart.

- Color. Click this icon to open the Color dialog box, where you can edit the color of Band
1.

- Transparency. Move the slider to make Band 1 opaque (0%) or transparent (100%). The
default is 0%.

- %. Enter or select the percentage of the transparency of Band 1.
- Band 2. Select this option to add Band 2 to a chart.

- Color. Click this icon to open the Color dialog box, where you can edit the color of Band
2.

- Transparency. Move the slider to make the Band 2 opaque (0%) or transparent (100%).
The default is 0%.

- %. Enter or select the percentage of the transparency of Band 2.

Use the Quadrant Lines tab to control the placement and style of the quadrant lines in your
scatter and bubble chart.

The Quadrant Lines tab contains the following options:

- Show Quadrant Line. Select this option to show the quadrant line. Clear this option to
suppress the quadrant line.

- Value. Enter a value to control where the quadrant line will be placed on the X axis.

- Line Style. Click this icon to open the Line Style dialog box, where you can edit the
color, weight, and style of the quadrant line.

Use the Frames tab to enable or disable frame regions, and to set the location and style of the
frame text.

The Frames tab contains the following options:

- Show Frame Regions. Select this option to show a frame region. Clear this option to
suppress a frame region.

- Region. Select from this drop-down list, the region that you want to format.
- Add. Click this button to add a region.

-1 Remove. Click this button to remove a region.
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Procedure:

- Location. Enter the location of the region.

.4 Color. Click this icon to open the Color dialog box, where you can edit the color of the
frame.

4 Border Color. Click this icon to open the Color dialog box, where you can edit the color of
the frame border.

- Text. Enter the text that you want to appear on the frame.

4 Style Text. Click this icon to style the frame text.

For instructions on how to open this dialog box, see the procedures in Using Gridline Properties
on page 55.

Gridline Elements Shortcut Menu

When you right-click a gridline on a chart, a menu of options opens. The options for the gridline
elements are described in the following table.

Element Option Description

Horizontal Major Gridlines Delete Removes the gridline from the
chart and updates the Live
Preview accordingly.

Horizontal Minor Gridlines

Vertical Major Gridlines
Set Line Color Enables you to specify the color of

the gridline, using the Color dialog
box. For more information, see
Color Dialog Box on page 21.

Vertical Minor Gridlines

More Grid Lines Opens the Format Gridlines dialog
Options box.

Using Gridline Properties

The following sections contain procedures for customizing gridlines.

How to Display Horizontal Major Gridlines
If your chart does not display gridlines by default, use this procedure to generate gridlines.

1. Create a chart or visualization.
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2. On the Format tab, in the Features group, open the Grid drop-down menu, point to
Horizontal Gridlines, and then click Major Gridlines.

Horizontal major gridlines are added to the chart.

Procedure: How to Display Horizontal Minor Gridlines
1. Create a chart or visualization.

2. Access the option to show gridlines in one of the following ways:

- Ribbon: On the Format tab, in the Features group, open the Grid drop-down menu. On
the Grid drop-down menu, point to Horizontal Gridlines, and then click Minor Gridlines.

- Shortcut Menu: Right-click the gridlines on the chart, and click More Grid Lines Options.
The Format Horizontal Grid Lines dialog box opens. On the Minor Grid Lines tab, select
Show Grid Lines.

Horizontal minor gridlines are added to the chart.

Procedure: How to Display Vertical Major Gridlines
1. Create a chart or visualization.

2. Access the option to show gridlines in one of the following ways:

- Ribbon: On the Format tab, in the Features group, open the Grid drop-down menu. On
the Grid drop-down menu, point to Vertical Gridlines, and then click Major Gridlines.

- Shortcut Menu: Right-click the gridlines on the chart, and click More Grid Lines Options.
The Format Vertical Grid Lines dialog box opens. On the Major Grid Lines tab, select
Show Major Grid Lines.

Vertical major gridlines are added to the chart.

Procedure: How to Display Vertical Minor Gridlines
1. Create a chart or visualization.

2. Access the option to show gridlines in one of the following ways:

- Ribbon: On the Format tab, in the Features group, open the Grid drop-down menu. On
the Grid drop-down menu, point to Vertical Gridlines, and then click Minor Gridlines.

- Shortcut Menu: Right-click the gridlines on the chart, and click More Grid Lines Options.
The Format Vertical Grid Lines dialog box opens. On the Minor Grid Lines tab, select
Show Minor Grid Lines.
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Vertical minor gridlines are added to the chart.

Procedure: How to Set the Color, Weight, and Style of a Gridline

1.

Open the Format Grid Lines dialog box in one of the following ways:

.4 Ribbon: On the Format tab, in the Features group, open the Grid drop-down menu, point

to the gridline type that you want to format, and click More Grid Lines Options.

.4 Shortcut Menu: Right-click a gridline, and click More Grid Lines Options.
The Format Grid Lines dialog box opens.

Click the Line Style icon.

The Line Style dialog box opens.

Set the color, weight, and style of the gridline.

Click OK to close the Line Style dialog box.

Click OK again to close the Format Grid Lines dialog box.
The gridline is formatted accordingly.

The following image shows a line chart with styling applied to the gridlines.
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Procedure: How to Set Ticks

Ticks are short lines which are perpendicular to a gridline. They are used to tick off specific
increments along the gridline.

1. Create a chart or visualization with gridlines.

2. Open the Format Grid Lines dialog box in one of the following ways:

. Ribbon: On the Format tab, in the Features group, open the Grid drop-down menu, point
to the gridline type that you want to format, and click More Grid Lines Options.

.4 Shortcut Menu: Right-click a gridline, and click More Grid Lines Options.
The Format Grid Lines dialog box opens.

3. From the Tick Style drop-down menu select a tick style option. The options are:
- Inside
4 Outside

d Spanning

4. Click the Line Style icon to open the Line Style dialog box, where you can edit the color,
weight, and style of the gridline.

5. Click OK to close the Line Style dialog box.
Click OK again to close the Format Grid Lines dialog box.

The tick marks are formatted accordingly.
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The following image shows a chart with tick marks spanning both the vertical axis and
horizontal axis.
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Procedure: How to Set Color Bands
1. Create a chart or visualization with gridlines.

2. Open the Format Grid Lines dialog box in one of the following ways:

. Ribbon: On the Format tab, in the Features group, open the Grid drop-down menu, point
to the gridlines that you want to format, and click More Grid Lines Options.

.4 Shortcut Menu: Right-click a gridline, and click More Grid Lines Options.
The Format Grid Lines dialog box opens.

3. On the Color Bands tab, click the Color icon to open the Color dialog box, where you can
set the color of the color bands.

4. Use the transparency slider, or the percentage box, to type or select the percentage of the
transparency that you want to apply to the color.

Click OK to close the Color dialog box.

6. Click OK again to close the Format Grid Lines dialog box.
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The following image shows a chart with color bands along the horizontal gridline.
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How to Delete a Gridline
1. Create a chart or visualization with gridlines.
2. Select a gridline.

3. Delete the gridline in one of the following ways:

.4 Ribbon: On the Format tab, in the Features group, open the Grid drop-down menu. From
the menu, point to the gridline that you want to format, and click More Grid Lines to
open the Format Grid Lines dialog box. On the tab for the gridline that you want to
delete, clear the Show Grid Lines option, and click OK.

. Shortcut Menu: Right-click the gridline, and from the menu, select Delete.

The gridline is deleted from the chart.

How to Display Quadrant Lines

Use the options on the Quadrant Lines tab to control the placement and style of the quadrant
lines in your scatter and bubble chart.

1. Create a scatter chart.
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On the Format tab, in the Features group, click Grid.

On the drop-down menu, point to either Horizontal Gridlines or Vertical Gridlines, and then
click More Grid Lines Options.

The Format Grid Lines dialog box opens.
On the Quadrant Lines tab, select Show Quadrant Line.
The quadrant line displays on the chart.

Click OK to close the Format Grid Lines dialog box.

Procedure: How to Add Frames to Regions on a Chart

1.
2.
3.

Create a chart or visualization.
On the Format tab, in the Features group, click Grid.

On the drop-down menu, point to either Horizontal Gridlines or Vertical Gridlines, and then
click More Grid Lines Options.

The Format Grid Lines dialog box opens.
On the Frames tab, select the Show Frame Regions check box.
Click Apply.

Colored frames are added to the chart, using the default styling options. Optionally, you
may use the color and border color options to change these.
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The following image shows a bar chart with colored frames around each region.
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Formatting Axis Labels

Vertical and horizontal axes are based on the orientation of the graph. For example, in a

vertical graph, the horizontal axis refers to the X axis and the vertical axis refers to the Y axis.
In a horizontal graph, the horizontal axis refers to the Y axis and the vertical axis refers to the
X axis. This is important to consider, since options could change depending on the orientation

of the graph.

A chart can contain the following types of axis labels:

I Horizontal axis labels represent the X axis. They do not apply to pie, funnel, or gauge
charts.

I Vertical axis labels represent the Y1 axis in a single axis chart. They represent a numeric
scale, usually located on the left side of a vertical chart.
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-l Secondary horizontal and vertical labels can only be used when dual axes charts are
selected.

Format Axis Dialog Box

Whether you access axis options from the ribbon, or the shortcut menu, you are presented
with the Format Axis dialog box of options for formatting for both vertical and horizontal axes.
The Format Axis dialog box contains the following tabs:

d General
d Scale
d Title
d Labels

4 Advanced

Reference: Format Vertical Axis Dialog Box

You use the Format Vertical Axis dialog box to specify formatting options for the vertical axis in
your chart.

Use the Scale tab to modify scale properties.

The Scale tab contains the following options:

-1 Automatic Minimum. Supplies the minimum value on the Y-axis scale automatically. To
use manual scaling, clear this option. You can then set the minimum value by entering a
number into the Value text box.

.4 Value. Type the minimum value in this text box if you have not selected Automatic
Minimum.

d Automatic Maximum. Supplies the maximum value on the Y-axis scale automatically. To
use manual scaling, clear this option. You can then set the maximum value by entering a
number into the Value text box.

4 Value. Type the maximum value in this text box if you have not selected Automatic
Maximum.
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-l Automatic Grid Step. Calculates the number of major grid steps automatically. To use
manual scaling, clear this option. You can then set the value by typing the number into the
Value text box.

- Value. Type the value in this text box if you have not selected Automatic Grid Step.

- Logarithmic Scale. Controls whether or not the Y-axis scale progresses logarithmically
instead of linearly. This option is disabled by default. When selected, the logarithmic base
is set to 10.0, but can be changed by entering another value.

- Log scale base. Type the base value to be shown on the logarithmic scale.

- Include zero on scale. Controls whether or not a zero (0) value appears on the scale. This
option is enabled by default.

Use the Title tab to create and style the title for the axis.

The Title tab contains the following options:

- Text. Type a title for the axis in the Text field.

- Style text. Opens the Style dialog box, where you can style the text.
Use the Labels tab to format the layout of the axis labels.

The Labels tab contains the following options:

- Show Labels. Displays labels next to the axis. This is enabled by default. Clear this option
to suppress labels.

d Axis side. Contains a list of position options for the labels on the axis. The options are
Left (default), Right, or Both.

d Style labels. Opens the Style dialog box, where you can style text.
- Format Labels. Contains a list of preset formats that can be applied to the labels.

- Custom Format. Allows you to use a custom format. This option is activated when Use
Pattern /100 and Use Pattern are selected as the format labels.

The Format Labels drop-down menu provides a list of preset formats that you can apply to
labels. When you select a custom format, it must be defined using a custom format pattern.
See the following table for a list and description of the characters that you can use in a
custom format.
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Character Description

# Is a digit.

0 (zero) Shows as absent.

. (period) Is a placeholder for a decimal separator.

, (comma) Is a placeholder for a grouping separator.

; (semicolon) Separates formats.

- (dash) Is the default negative prefix.

% (percent) Divides by 100 and shows as a percentage.

X Determines that any other characters can be used in the
prefix or suffix.

‘ (apostrophe) Is used to quote special characters in a prefix or suffix.

Use the Advanced tab to modify additional axis properties.

The Advanced tab contains the following options:

_I

-
d
d

Exclude Minimum Label. Excludes the label with the lowest axis value from the chart.
Exclude Maximum Label. Excludes the label with the highest axis value from the chart.
Descending Axis. Draws the axis in descending order.

Show axis line. Controls the display of the axis baseline.

. Line Style. Opens the Line Style dialog box, where you can edit the color, weight, and
style of the axis line.

Show zero line. Controls the display of the zero line.

. Line Style. Opens the Line Style dialog box, where you can edit the color, weight, and
style of the zero line.

Custom Baseline. Controls the display of the custom baseline.
. Value. Type a value for the custom baseline.

4 Line Style. Opens the Line Style dialog box, where you can edit the color, weight, and
style of the custom baseline.

Customizing Content 65



Customizing Charts and Visualizations

Reference:

66

For instructions on how to open this dialog box, see the procedures in Using Axis Properties on
page 68.

Format Horizontal Axis Dialog Box

You use the Format Horizontal Axis dialog box to specify formatting options for the horizontal
axis in your chart.

The General tab contains the Show axis line check box, which controls the display of the axis
line. When this check box is selected, you can style the axis line.

The General tab contains the following options:
- Show axis line. Enables the display of the axis line.

- Line Style. Opens the Line Style dialog box, where you can edit the color, weight, and
style of the axis line.

Use the Title tab to create and style the title for the axis.

The Title tab contains the following options:
- Text. Type a title for the axis in the Text field.

- Style. Opens the Style dialog box, where you can style the text.
Use the Labels tab to format the layout of the axis labels.

The Labels tab contains the following options:

- Show Labels. Displays labels next to the axis. This is enabled by default. Clear this option
to suppress labels.

- Axis side. Contains a list of position options for the labels on the axis. The options are
Left (default), Right, or Both.

- Style labels. Opens the Style dialog box, where you can style text.

- Stagger Labels. Sets the labels to appear staggered.
Use the Advanced tab to modify additional axis properties.

The Advanced tab contains the following options:
- Exclude Minimum Label. Excludes the label with the lowest axis value from the chart.
- Exclude Maximum Label. Excludes the label with the highest axis value from the chart.

-1 Reverse Groups. Reverses the order of the display of the groups on the horizontal axis.

Information Builders



1. Customizing Content I

For instructions on how to open this dialog box, see the procedures in Using Axis Properties on
page 68.
Secondary Axes Options

Formatting options are available for secondary axes in dual-axis charts. For example, in a
vertical dual-axis chart, the secondary vertical axis refers to the Y2 axis.

The Format Secondary Axis dialog box contains the following tabs for both vertical and
horizontal axes:

4 General. For more information, see the Scale tab options in Format Axis Dialog Box on page
63.

1 Title. For more information, see the equivalent tab in Format Axis Dialog Box on page 63.
.4 Labels. For more information, see the equivalent tab in Format Axis Dialog Box on page 63.
.4 Advanced. For more information, see the equivalent tab in Format Axis Dialog Box on page

63.

Axis Elements Shortcut Menu

When you right-click an axis label or title in a chart in Live Preview, a menu of options opens.
The options for the right-click axis label elements are described in the following table.

Element Option Description

Axis Title Delete Deletes the axis title from the chart and updates the Live
Preview accordingly.

Change Title Enables you to change the axis title.

Style Title Enables you to apply styling to the axis title, using the Style
dialog box. For more information, see Style Dialog Box on
page 45.
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Element Option Description
Horizontal Delete Deletes labels from the chart and updates the Live Preview
Labels accordingly.

Stagger Controls the positioning of the labels. The On value
positions the labels in a zigzag pattern. The Off default
value positions the labels in a straight row.

Rotate Rotates the labels a specified number of degrees.

Style Labels Enables you to apply styling to the labels, using the Style
dialog box. For more information, see Style Dialog Box on
page 45.

More Axis Opens the Format Axis dialog box. For more information,

Options see Formatting Axis Labels on page 62.

Vertical Delete Deletes labels from the chart and updates the Live Preview
Labels accordingly.

Rotate Rotates the labels a specified number of degrees.

Format Formats the labels according to the value that you specify.

Labels

Style Labels Enables you to apply styling to the labels, using the Style
dialog box. For more information, see Style Dialog Box on
page 45.

More Axis Opens the Format Axis dialog box. For more information,

Options see Formatting Axis Labels on page 62.

Using Axis Properties

The following sections contain procedures for customizing an axis. The procedures are
organized by the tab and group in which their associated options appear on the ribbon.

Axis labels appear by default.

Procedure: How to Delete Axis Labels

1. Create a chart or visualization.

68
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2. You can delete axis labels in one of the following ways:

4 Ribbon: On the Format tab, in the Labels group, open the Axes drop-down menu, point
to the axis that you are working with, and clear the Show Labels option.

. Shortcut Menu: Right-click an axis label on the chart, and click Delete.

The axis labels are deleted from the chart.

Procedure: How to Stagger Axis Labels
Note: You can only apply a staggered effect to horizontal axis labels.
1. Create a chart or visualization with at least one axis label on display.

2. Access the Stagger option in one of the following ways:

- Ribbon: On the Format tab, in the Labels group, open the Axes drop-down menu, point
to the axis that you are working with, and click Stagger Labels.

.4 Shortcut Menu: Right-click an axis label on the chart, point to Stagger and select On.

The axis labels are staggered.

Procedure: How to Rotate Axis Labels
1. Create a chart or visualization with axis labels.

2. Access the Rotate option in one of the following ways:

4 Ribbon: On the Format tab, in the Labels group, open the Axes drop-down menu, point
to the axis that you are working with, point to Rotate Labels, and then click the degree
to which you want to rotate the axis labels.

.4 Shortcut Menu: Right-click an axis label on the chart, point to Rotate, and then click
the degree to which you want to rotate the axis labels.

The axis labels are rotated.

Procedure: How to Format Axis Labels
1. Create a chart or visualization with an axis label.
2. Access the list of axis label options in one of the following ways:
.4 Ribbon: On the Format tab, in the Labels group, open the Axes drop-down menu, point
to the axis that you are working with, and click More Axis Options to open the Format

Axis dialog box. Open the Labels tab, and from the Labels option drop-down menu,
select the formatting option that you want.
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- Shortcut Menu: Right-click an axis label, point to Format Labels, and click the
formatting option that you want.

The axis labels are formatted accordingly.

Procedure: How to Manually Set the Scale of an Axis

Procedure:

70

1. Create a chart or visualization.

2. Open the Format Axis dialog box in one of the following ways:

- Ribbon: On the Format tab, in the Labels group, open the Axes drop-down menu, point
to the axis that you are working with, and click More Axis Options.

- Shortcut Menu: Right-click an axis value on the chart, and click More Axis Options.

The Format Axis dialog box opens.

3. On the scale tab, clear the Automatic Minimum option and enter your own minimum value
in the Value text box.

4. Clear the Automatic Maximum option, and enter your own maximum value in the Value text
box.

5. Clear the Automatic Grid Step option, and enter your own grid step value in the Value text
box.

6. Optionally, you can select the Logarithmic Scale option and enter the log scale base in the
text field of that name. You can also clear the Include zero on scale option if you do not
want zero to appear on the axis.

7. Click OK to close the dialog box.

The axis scale is set accordingly.

How to Add an Axis Title

1. Create a chart or visualization with an axis label.

2. Open the Format Axis dialog box in one of the following ways:

- Ribbon: On the Format tab, in the Labels group, open the Axes drop-down menu, point
to the axis that you are working with, and click More Axis Options.
- Shortcut Menu: Right-click an axis label, and click More Axis Options.
The Format Axis dialog box opens.
On the Title tab, type the axis title in the Text field.
4. Click the Style text icon to open the Style dialog box, where you can style the text.
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The axis title is styled accordingly.

Note: Right-click the axis title to delete, change, or style the axis title.

Procedure: How to Set Advanced Axis Properties
1. Create a chart or visualization with an axis label.

2. Open the Format Axis dialog box in one of the following ways:

.4 Ribbon: On the Format tab, in the Labels group, open the Axes drop-down menu, point
to the axis that you are working with, and click More Axis Options.

.4 Shortcut Menu: Right-click an axis label, and click More Axis Options.
The Format Axis dialog box opens.

3. On the Advanced tab, set the following options:

Exclude Minimum Label

Exclude Maximum Label

Descending Axis

Show axis line

Show zero line

L U o o o U

Custom Baseline (Value)

You can edit the color, weight, and style of all the lines that you set in the Line Style
dialog box.

4. Click OK.

The axis advanced options are set accordingly.

Formatting a Frame and a Background

The frame of a chart is the area that contains the plot points. It is also the area in which
horizontal and vertical gridlines are drawn.

The background of a chart is the area around the frame.
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You can adjust the appearance of the frame and background to achieve different visual effects
for your charts. For example, you can change the appearance of the chart frame line, or you
can change the color of the background of your chart, as shown in the following image.
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Frame & Background Dialog Box

Whether you access frame and background options from the ribbon, or the shortcut menu, you
are presented with the Frame & Background dialog box of options for formatting the frame and
background of a chart. The Frame & Background dialog contains the following tabs:

1 Frame
Id Frame Edge
Id Background

The Frame & Background dialog box and pertinent tabs are discussed in this section for the
following types of charts:

Id 2D Charts and 2D Charts with 3D Effects (Frame and Frame Edge tabs)
[d Pie Charts (Frame and Frame Edge tabs)
Id 3D Charts (Left Wall, Right Wall, Floor, and Advanced tabs)

Note: The options in the Frame tab vary based on the chart type selected.
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Use the Frame tab for 2D charts and 2D charts with 3D effects to set a frame depth angle and
depth radius, select a fill for a frame, and set a shadow for a frame for these types of charts.

The Frame tab for 2D charts and 2D charts with 3D effects contains the following options:

4 Depth Angle. Enter the angle from the front of the chart to the back where the chart risers
and frames are drawn. You can set the depth angle from zero to 180 degrees, but it must
be used along with Depth Radius.

.d Depth Radius. Enter how far out the extruded frame will be extended. Small values, such
as zero, produce very narrow charts. Large values, the maximum being 100, produce
thicker charts.

Fill
4 No fill. (Default). Select this option to keep the legend colorless.
4 Solid fill. Select this option to display the Color and Transparency options.

. Color. Click this icon to open the Color dialog box, where you can select a color for a
frame.

4 Transparency. Move the slider to make the frame opaque (0%) or transparent (100%).
The default is 0%.

4 Gradient fill. Select this option to display the direction of the gradient, the color pattern of
the gradient, and the degrees of transparency for the two colors that make up the gradient.
A gradient is a smooth color transition or blending of one color to another. The number of
colors to use in a gradient is defined by the stop or pin elements.

4 Direction. Select from this drop-down menu to set the direction of the gradient fill. For
example, Gradient right or Gradient left.

Gradient style

.4 Color Pattern. Select the color pattern for the data series. The color pattern option on the
left is an AB wash that uses two colors in the pattern colorl - color2, for example, red-
green. The color pattern option on the right is an ABA wash that uses two colors in the
pattern colorl - color2 - colorl, for example, red-green-red.

.4 First Color. Click this icon to open the Color dialog box, where you can select a color for the
first color.

4 Second Color. Click this icon to open the Color dialog box, where you can select a color for
the second color.
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Shadow

- Show Shadow. Select this option to set a shadow.

Use the Frame Edge tab for 2D charts and 2D charts with 3D effects to set a frame depth
angle and depth radius, select a fill for a frame, and set a shadow for a frame for these types
of charts.

The Frame tab for 2D charts and 2D charts with 3D effects contains the following options:

- Automatically Shade Frame Edge. Select this option to automatically shade the frame
edge. Clear this option to enable the Side Frame and Bottom Frame options.

Side Frame
1 Show Color. Select this option to show the color of the side frame.

1 Color. Click this icon to open the Color dialog box, where you can select a color for the side
frame.

-1 Show Border Color. Select this option to show the color of the border of the side frame.

- Border Color. Click this icon to open the Color dialog box, where you can select a color for
the border of the side frame.

Bottom Frame
1 Show Color. Select this option to show the color of the bottom frame.

- Color. Click this icon to open the Color dialog box, where you can select a color for the
bottom frame.

1 Show Border Color. Select this option to show the color of the bottom frame.

- Border Color. Click this icon to open the Color dialog box, where you can select a color for
the border of the bottom frame.

Use the Frame tab for pie charts to set pie depth and tilt, select a fill and color for a pie frame,
and set a shadow for the frame.

The Frame tab for pie charts contains the following options:

1 Pie Depth. Set the depth of the edge of a pie chart. You can select a value from zero to
100 to set the thickness of an edge.

- Pie Tilt. Set the tilt of the pie chart. The smaller the value you add, the flatter the pie chart
appears. The larger the value you add, more of the pie edge appears.

Information Builders



1. Customizing Content I

Fill
.4 No fill. (Default). Results in no color added to the edge of the pie.

4 Solid fill. Select this option to display the Color and Transparency options.

.4 Color. Click this icon to open the Color dialog box, where you can select a color for the
frame.

.4 Transparency. Move the slider to make the fill opaque (0%) or transparent (100%). The
default is 0%.

4 Gradient fill. Select this option to display the direction of the gradient, the color pattern of
the gradient, and the degrees of transparency for the two colors that make up the gradient.
A gradient is a smooth color transition or blending of one color to another. The number of
colors to use in a gradient is defined by the stop or pin elements.

.4 Direction. Select from this drop-down menu to set the direction of the gradient fill. For
example, Gradient right or Gradient left.

- Gradient Style

4 Color Pattern. Select the color pattern for the data series. The color pattern option
on the left is an AB wash that uses two colors in the pattern colorl - color2, for
example, red-green. The color pattern option on the right is an ABA wash that uses
two colors in the pattern colorl - color2 - colorl, for example, red-green-red.

. First Color. Click this icon to open the Color dialog box, where you can select a color
for the first color.

-1 Second Color. Click this icon to open the Color dialog box, where you can select a
color for the second color.

Shadow
d Show Shadow. Select this option to set a shadow around the frame.
Use the Frame Edge tab for pie charts to set the edge of a pie frame.

The Frame Edge tab for pie charts contains the following options:

d Automatically Shade Frame Edge. Select this option to automatically shade the frame
edge. Clear this option to enable the Side Frame and Bottom Frame options.

- Show Color. Select this option to show the color of the side frame.
.4 Color. Click this icon to open the Color dialog box, where you can select a color for side

frame.
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-1 Show Border Color. Select this option to show the color of the border of the side frame.

- Border Color. Click this icon to open the Color dialog box, where you can select a color for
the border of the side frame.

Bottom Frame
-1 Show Color. Select this option to show the color of the bottom frame.

- Color. Click this icon to open the Color dialog box, where you can select a color for the
bottom frame.

1 Show Border Color. Select this option to show the color of the bottom frame.

- Border Color. Click this icon to open the Color dialog box, where you can select a color for
the border of the bottom frame.

Use Wall and Floor tabs to set the walls and floor of a 3D chart.

These Wall and Floor tabs contain the following options:

-l Show Wall or Show Floor. Select this option to show the wall or floor (depending on the
tab) of the 3D chart.

1 Wall Thickness. Specify the thickness of the wall or floor.
- Cube Size. Specify the cube size of the wall or floor.

- Color. Click this icon to open the Color dialog box, where you can select a color for the wall
or floor.

- Border Color. Click this icon to open the Color dialog box, where you can select a color for
the border of the wall or floor.

d Show Wall (Left Wall). Select this option to show the left wall.

- Show Wall (Right Wall). Select this option to show the right wall.

-1 Show Floor. Select this option to show the floor.

Use the Advanced tab for 3D charts to modify additional properties for 3D frames.
The Advanced tab contains the following options:

- Viewing Angles. Select from a drop-down menu of viewing angles for three-dimensional
charts. For example, Standard or Group View.

- Isometric Projection. Select this option to ignore perspective distortion in a project graph
cube from an isometric view.
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-1 Proportional Cube. Select this option to define the axis size proportional to the number of
series or groups.

. Automatic shading of walls. Select this option to shade chart walls.

4 Automatically Shade Frame Edge. Select this option to automatically shade the frame
edge.

-1 3D Zoom Factor. Enter a value in the text box to set the global scaling factor for
zooming in and out in a 3D chart. Smaller values zoom out and produce a smaller
display of the chart within a frame. Larger values zoom in and produce a larger display
of the chart within a frame.

.d Pan Horizontally. Enter a value in the text box to pan a 3D chart in the horizontal
direction. Smaller values move the frame of the chart to the left. Larger values move the
frame of the chart to the right.

4 Pan Vertically. Enter a value in the text box to pan a 3D chart in the vertical direction.
Smaller values move the frame of the chart upward. Larger values move the frame of
the chart downward.

Use the Background tab to set and customize a border for a chart.
The Background tab contains the following options:
- Show Border Color. Select this option to show the color of the border.

.4 Border Color. Click this icon to open the Color dialog box, where you can select a color for
the border.

4 Solid fill. Select this option to display the Color and Transparency options.

.4 Color. Click this icon to open the Color dialog box, where you can select a color for the
frame.

.4 Transparency. Move the slider to make the background opaque (0%) or transparent
(100%). The default is 0%.

4 Gradient fill. Select this option to display the direction of the gradient, the color pattern of
the gradient, and the degrees of transparency for the two colors that make up the gradient.
A gradient is a smooth color transition or blending of one color to another. The number of
colors to use in a gradient is defined by the stop or pin elements.

. Direction. Select from this drop-down menu to set the direction of the gradient fill. For
example, Gradient right or Radial.
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Gradient Style

.4 Color Pattern. Select the color pattern for the data series. The color pattern option on the
left is an AB wash that uses two colors in the pattern colorl - color2, for example, red-
green. The color pattern option on the right is an ABA wash that uses two colors in the
pattern colorl - color2 - colorl, for example, red-green-red.

.4 First Color. Click this icon to open the Color dialog box, where you can select a color for the
first color.

.4 Second Color. Click this icon to open the Color dialog box, where you can select a color for
the second color.

For instructions on how to open this dialog box, see the procedures in Using Frame and
Background Properties on page 79.
Frame and Background Shortcut Menu

When you right-click a chart background, a menu of options opens. The options for the
background and frame elements are described in the following table.

Element Option Description

Background Background Color Enables you to specify the color of the
background, using the Color dialog box. For
instructions, How to Change the Color of
the Background on page 80.

Show legend Controls the display of the legend on the
background. When selected, it displays the
legend. When cleared, it suppresses the
display of the legend.

More Frame and Opens the Frame & Background dialog box.
Background Options For more information, see Frame &
Background Dialog Box on page 72.
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Element Option Description
Frame Frame Color Enables you to specify the color of the
frame, using the Color dialog box. For more
information, see Color Dialog Box on page
21.
Show 3D Controls the depth of the frame. The value

On renders the frame in 3D depth. The
value Off renders the frame in one
dimension.

More Frame and
Background Options

Opens the Frame & Background dialog box.
For more information, see Frame &
Background Dialog Box on page 72.

Using Frame and Background Properties

The following sections contain procedures for customizing frame and background properties.
The options for the following procedures are found in the Features group of the Format tab.

Procedure: How to Change the Color of the Frame

The default color of the frame in a chart is determined by the Document Theme selected on
the Options window. For more information, see Changing InfoAssist+ User Preferences.

This procedure describes how to change the color of the frame.

1. Create a chart or visualization.

2. Access the Frame & Background dialog box in one of the following ways:

4 Ribbon: On the Format tab, in the Features group, click Frame & Background.

.4 Shortcut Menu: Right-click the chart, and click More Frame & Background Options.

The Frame & Background dialog box opens.

3. On the Frame tab, in the Fill area, click the Color icon.

Note: Solid fill must be selected for the Color icon to appear.

The Color dialog box opens. Select a new color for the frame. For more information on the
Color dialog box, see Color Dialog Box on page 21. You can also set the depth angle and
depth radius for the frame, as well as set a shadow for the frame.

Customizing Content

79



Customizing Charts and Visualizations

4. Click OK.

The chart displays the new frame color.

Procedure: How to Change the Color of the Background

80

The default color of the background of a chart is determined by the Document Theme selected
on the Options window. For more information, see Changing InfoAssist+ User Preferences.

1. Create a chart or visualization.
2. Open the Frame & Background dialog box in one of the following ways:

- Ribbon: On the Format tab, in the Features group, click Frame & Background.

- Shortcut Menu: Right-click the background of the chart, and click Background Color.
The Frame & Background dialog box opens.
3. On the Background tab, in the Fill area, click the Color icon.

The Color dialog box opens. Select a new color for the background. For more information
on the Color dialog box, see Color Dialog Box on page 21.

4. Click OK.

The chart displays the new background color.

Formatting a Gauge Chart

A gauge chart is a circular chart that indicates the current position of a single data value within
a given spectrum.

You can change the appearance of a gauge chart by using the gauge chart options found on
the Format Gauge dialog box. To access the Format Gauge dialog box, on the Format tab, in
the Features group, click Gauges.

Format Gauge Dialog Box

Whether you access gauge options from the ribbon, or the shortcut menu, you are presented
with the Format Gauge dialog box of options for formatting a gauge chart. Such options include
setting and styling a title for the gauge chart, setting tick marks, enabling and styling color
bands, as well as setting advanced options, such as the gauge start and stop angle.

The Format Gauge dialog box contains the following tabs:
1 General Options

- Axis Scale & Labels
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- Tick Marks

4 Bands

4 Advanced

Use the General Options tab to set general gauge options.
The General Options tab contains the following options:

-l Gauges per row. Enter or select how many gauges appear on each row. The default setting
displays two gauge charts. A maximum of 32 gauge charts can appear on each row.

Note: The number of charts displayed per row can differ, based on the output format
selected. For example, HTML format will display two charts per row, and HTML5 will display
three.

Gauge Needle

4 Style. Select a style from a drop-down menu of options to be applied to the gauge needle.
For example, Pencil.

.4 Color. Click this icon to open the Color dialog box, where you can select a color for the
gauge needle.

Note: If you are working with a gauge chart with more than one series, then you use the
Format Series dialog box to format the color of the gauge needle and its border.

-1 Border Color. Click this icon to open the Color dialog box, where you can select a color for
the gauge needle border.

Note: If you are working with a gauge chart with more than one series, then you use the
Format Series dialog box to format the color of the gauge needle and its border.

Gauge Title

-1 Show title. (Default) Displays a gauge title appear for each gauge. Clear this option to
suppress the title.

. Position. Select a position for the gauge title. Above is the default value.

4 Style. Click this icon to open the Style dialog box, where you can style text.

Gauge value
-1 Show value. (Default) Clear this option to suppress the gauge value.

.4 Style. Click this icon to open the Style dialog box, where you can style text.
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-1 Format Value. Contains a list of preset formats that can be applied.

- Custom Format. Allows you to use a custom format. This option is activated when Use
Pattern /100 and Use Pattern are selected as the format labels.

Use the Axis Scale & Labels tab to set the axis scale and label properties for the gauge
needle.

The Axis Scale & Labels tab contains the following options:

Scale

- Automatic Minimum. (Default) Sets the engine to automatically supply the minimum value
on the scale. Clear this option to manually set the minimum value by entering a number
into the Value text box.

- Value. Enter the minimum value in this text box if you have not selected Automatic
Minimum.

- Automatic Maximum. (Default) Sets the engine to automatically supply the maximum value
on the scale. Clear this option to manually set the maximum value by entering a number
into the Value text box.

- Value. Enter the maximum value in this text box if you have not selected Automatic
Maximum.

Labels

- Show Labels. (Default) Displays labels next to the axis. Clear this option to suppress
labels.

- Style Labels. Click this icon to opens the Style dialog box, where you can style text.

- Format Labels. Select from a drop-down menu of present formats that can be applied to
the labels. When a custom format is selected, the format must be defined using a custom
format pattern. For a list and description of the characters that you can use in a custom
format, see the table in Formatting Data Labels on page 41.

- Custom Format. Text field to enter the custom format that you want to use.
The Tick Marks tab contains options to format tick marks on a gauge chart.
The Tick Marks tab contains the following options:

- Automatic Grid Step. (Default) Automatically calculates the number of major grid steps in a
gauge chart. Clear this option to manually set the value by entering a number in the Value
text box.
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- Value. Enter the value in this text box if you have not selected Automatic Grid Step.

.4 Tick Color. Click this icon to open the Color dialog box, where you can select a color for the
tick marks.

4 Tick Mark Length. Enter a value for the relative length of major tick marks in a gauge chart.
The valid range is from 0.0 to 0.5. If you set the smallest value, major tick marks do not
appear.

The Bands tab contains options to format the color of the scale background on a gauge chart.
The Bands tab contains the following options:
.4 Band 1. Opens a drop-down menu of available bands.

.4 Add. Adds the band selected from the drop-down menu of bands to the gauge chart.
You can create up to five bands for a gauge chart.

d Remove. Removes the band selected from the drop-down menu of bands to the gauge
chart.

.4 Minimum Value. Enter a minimum value to a quality band in the gauge chart.
.d Maximum Value. Enter a maximum value to a quality band in the gauge chart.

.4 Border Color. Opens the Color dialog box, where you can edit the color of the gauge band
border.

Fill
. No fill. Removes fill from the quality band.
4 Solid fill. (Default) Applies a solid color to the quality band.

.4 Color. Click this option to open the Color dialog box, where you can select the color for the
quality band.

.4 Transparency. Move the slider to make the band opaque (0%) or transparent (100%). The
default is 0%.

The Advanced tab contains options to set additional properties for the gauge needle.
The Advanced tab contains the following options:

. Descending Axis. Select this option to draw the gauge scale in descending order. When
this option is cleared (default), the gauge scale is drawn in ascending order.

.d Show Zero Label. Displays the zero label on the axis scale. Clear this option to start the
gauge at another value. This option is selected by default.
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Procedure:
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-l Gauge Center by Quality. Select this option to have the center of the gauge needle appear
in the same the color as the band to which it is pointing.

-l Gauge Start Angle. Enter a value to rotate the gauge start angle to a specified number of
degrees. Values can range from O to 359 degrees. The default is 220 degrees.

-1 Gauge Stop Angle. Enter a value to rotate the gauge stop angle to a specified number of
degrees. Values can range from O to 359 degrees. The default is 320 degrees. Setting a
start angle to 0, and a stop angle to 180, creates a semi-circle.

- Relative Inner Radius. Enter a value to define the inner radius of the gauge bands and
labels relative to the outer background of the gauge. Smaller values, such as 0.0, place the
inner radius closer to the center of the gauge. A maximum value of 1.0, places the inner
radius close to the gauge outline.

- Relative Thickness. Enter a value to define the relative thickness of the gauge bands.
Values can range from 0.0 to 1.0.

-1 Same Size Gauges. This option applies to multi-category gauge charts. If you are working
with three or more gauges per row, you can select this option to have the gauges display in
the same size.

Gauge Elements Shortcut Menu

When you right-click a gauge chart, a menu containing the More Gauge Options becomes
available. Select this option to open the Format Gauge dialog box. This is only available when
using the HTML output format.

Using Gauge Properties

The following sections contain procedures for gauge properties. The Gauges option can be
found on the Format tab, in the Features group.

Note: This option is only available when you are working with a gauge chart.

How to Set the Number of Gauges Per Row

If you have multiple gauges on a chart, you might want to specify how many gauges appear on
each row.

1. Create a gauge chart that has multiple values.

2. Open the Format Gauge dialog box in one of the following ways:

- Ribbon: On the Format tab, in the Features group, click Gauges.
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-1 Shortcut Menu: Right-click the gauge chart and select More Gauge Options.
The Format Gauge dialog box opens.

3. On the General options tab, in the Gauges per row field, enter or select the number of
gauges that you want to appear on one row.

4. Click OK.
The gauges now appear on one row.

After changing the setting from the default of 2 gauges per row to 3 gauges per row, all
the charts now appear on one row.

Procedure: How to Set the Minimum and Maximum Axis Scale Values

1. Create a gauge chart.

2. Open the Format Gauge dialog box in one of the following ways:
4 Ribbon: On the Format tab, in the Features group, click Gauges.

.4 Shortcut Menu: Right-click the gauge chart, and click More Gauge Options.
The Format Gauge dialog box opens.

3. On the Axis Scale & Labels tab, in the Scale area, either accept the minimum and
maximum values for the scale automatically supplied by the chart engine, or enter your
own in the Value fields.

4. Click Apply.

The gauge scale reflects the selections that you have made.

Procedure: How to Style Axis Labels
1. Create a gauge chart.

2. Open the Style dialog box in one of the following ways:

.4 Ribbon: On the Format tab, in the Features group, click Gauges to open the Format
Gauge dialog box. In the Format Gauge dialog box, open the Axis Scale & Labels tab. In
the Labels area, click the Style Labels icon.

.4 Shortcut Menu: Right-click an axis label, and click Style.
The Style dialog box opens.

Select your styling options.

Click OK.
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The scale labels reflect the style selections that you have made.

Procedure: How to Format Axis Labels

Procedure:

Procedure:
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1. Create a gauge chart.
2. Access the menu of available format options for axis labels in one of the following ways:

- Ribbon: On the Format tab, in the Features group, click Gauges to open the Format
Gauge dialog box. In the Format Gauge dialog box, open the Axis Scale & Labels tab. In
the Labels area, open the Format Labels drop-down menu.

- Shortcut Menu: Right-click an axis label, and point to Format.

The menu of available format options opens.

3. Select your format option.

Note: If you select a custom format (for example, User Pattern, or Use Pattern /100), from

the Format Labels menu on the Format Gauge dialog box, the Custom Format menu

becomes available. When you select a custom format, it must be defined using a custom
format pattern. For a list and description of the characters that you can use in a custom

format, see the table in Formatting Data Labels on page 41.

4. Click OK.
The scale labels reflect the format selection that you have made.

How to Rotate Axis Labels

1. Create a gauge chart.

2. Rightclick an axis label.

3. On the shortcut menu, point to Rotate, then select the degree to which you want the labels
rotated.

How to Set Gauge Tick Marks

This procedure describes how to set the grid step, tick color, and tick length for the major and
minor tick marks.

1.
2.

Create a gauge chart.

Open the Format Gauge dialog box in one of the following ways:
- Ribbon: On the Format tab, in the Features group, click Gauges.

- Shortcut Menu: Right-click the gauge chart and select More Gauge Options.

Information Builders



1. Customizing Content I

The Format Gauge dialog box opens.

3. On the Tick Marks tab, for the Automatic Grid Step, either accept the value automatically
supplied by the chart engine, or enter your own, in the Value fields.

4. Click the Tick Color icon, to open the Color dialog box, where you can select a color for the
tick mark.

5. For the Tick Mark Length, either accept the value automatically supplied by the chart
engine, or enter your own, in the Value fields.

Procedure: How to Set Gauge Color Bands
1. Create a gauge chart.
2. Open the Format Gauge dialog box in one of the following ways:

4 Ribbon: On the Format tab, in the Features group, click Gauges.

.4 Shortcut Menu: Right-click the gauge chart, and click More Gauge Options.
The Format Gauge dialog box opens.

3. Set the minimum and maximum value for each band that you want to appear on the gauge
chart.

4. Set the color of the fill and border for each color band.
Note: The gradient fill option is not available for color bands.
5. Click OK to close the Format Gauge dialog box.

The bands are formatted accordingly.

Procedure: How to Match Needle Center Color to Band Color (Gauge Center by Quality)

This option matches the needle center color to the color of the band that the needle is pointing
to.

1. Create a gauge chart.
2. On the Format tab, in the Features group, click Gauges.
The Format Gauge dialog box opens.

3. On the Bands tab, set the minimum and maximum value for each band that you want to
appear on the gauge chart

4, Set the color of the fill and border for each color band.
Note: The gradient fill and transparency options are not available for gauge needles.

5. On the Advanced tab, select Gauge Center by Quality.
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Procedure:

Procedure:
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Note: This option displays in HTML, but not in HTML5.
6. Click OK to close the Format Gauge dialog box.

The color of the center of the gauge needle now matches the color of the band.

How to Style a Gauge Needle

This procedure explains how to change the gauge needle from the Normal style to the Pencil
style.

1. Create a gauge chart.
2. Open the Format Gauge dialog box in one of the following ways:

- Ribbon: On the Format tab, in the Features group, click Gauges.

- Shortcut Menu: Right-click the gauge chart, and click More Gauge Options.

The Format Gauges dialog box opens.

4. In the General Options tab, in the Gauge Needle section, from the Style drop-down menu,
select Pencil.

5. Click OK.

The gauge needle changes to a pencil.

How to Set Gauge Needle Colors in a Multi Series Gauge Chart

You cannot change the fill color and border color of the needles in a multi-series gauge chart
through the General Options tab of the Format Gauge dialog box. You can do so through the
Format Series dialog box. However, you can still use the General Options tab to change the
style of the needle.

1. Create a gauge chart with more than one measure field.

2. On the Series tab, from the Series drop-down menu, select the series that you want to
style.

3. In the Properties group, click Style.
The Format Series dialog box opens.

4. On the Fill tab, select the fill and color options for the gauge needle for the selected
series.

5. On the Border tab, select the Show Border Color option, if you want the gauge needle to
have a border. You can select the color for the border, as well.

6. Click Apply.
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7.
8.

Repeat steps 2 through 5 for each series gauge needle that you want to style.

When you are finished, click OK to close the Format Series dialog box.

The color of the gauge needles and their borders changes accordingly.

Formatting Page Headings and Page Footings

Page headings and page footings supply context and key information about a chart, such as its
purpose, audience, and author. Page headings and page footings also enhance visual appeal.

Procedure: How to Add a Page Heading and Page Footing to a Chart

The procedure uses sample values, but you can supply values that apply to your own charts.

This feature is available in Query Design view, Live Preview, and Document view.

1.
2.

Create a chart or visualization.
On the Home tab, in the Report group, click Header & Footer.

The Header & Footer dialog box opens.

Tip: Another way to access the Heading & Footing dialog box is to click the arrow next to
the Header & Footer button. Doing so opens a drop-down menu from which you can select
the heading or footing that you want to work with. After you make your selection, the
Header & Footer dialog box opens, and the heading or footing that you selected is active.

Click the tab for the page heading or page footing, depending on which you want to add.

By default, the Page Heading tab is selected. In this procedure, accept the default to add
a page heading first.

Click inside the design area of the dialog box, and type the text for the page heading.
For example, the text for a sample page heading might be Customers By Occupation.
Using the styling options, apply styling to the page heading text.

For example, 14 pt. bold Helvetica with center alignment.

Click Apply to save the changes that you have made, without closing the dialog box.
To add a page footing, click the Page Footer tab.

For this procedure, you are going to add one of the supplied quick text options, followed by
some text of your own.

Click the down arrow next to the preformatted text button, and click Created by from the
drop-down list.

Complete the text by typing the applicable value within the supplied text, for example,
Sales Manager.
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10. Change the styling as you want.

11. Click OK to save the page heading and page footing and close the Header & Footer dialog
box.

The chart contains the page heading and page footing that you added and styled.

The following image shows a chart with a styled header and footer.

Semiannual Revenue by Product Category
January 2015 - June 2015
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@
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Revenue

40M

Created By Sales Manager

12. To make changes to either the page heading or page footing, return to Design view. Right-
click the header or footer, and click Edit from the drop-down menu.

Procedure: How to Control the Rendering of a Page Heading and Page Footing

You can control the way in which a page heading and page footing are rendered on a chart at
run time.

1. Create a chart or visualization.

2. Open the Header & Footer dialog box, as described in How to Add a Page Heading and
Page Footing to a Chart on page 89.

3. Click the Text options for chart button lm .

A drop-down menu, with two options for rendering the page heading and page footing,
opens.
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Tip: Your selection for a page heading also applies to a page footing, and vice versa.

|1 Create Header and Footer as text renders the heading and footing as text elements
that are separate from the chart image.

Id Embed Header and Footer in the chart renders the heading and footing text as part of

the chart image. This is the default value.

4. Click OK to save your selection and close the Heading & Footing dialog box.

Using Additional Formatting Features

This section describes additional formatting features that are available for charts.

Procedure: How to Set 3D Depth on a Bar Chart

You can apply a 3D-effect to a 2D-chart.

Note: If you find that the depth of the 3D effect makes it difficult to distinguish the values on
the Y-axis scale, then you can turn this option off. This procedure explains how to set the 3D
effect for a default vertical bar chart.

The following image shows a bar chart before the 3D effect is applied.
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1. Create a 2D chart.
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Procedure:

Procedure:
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2. In Live Preview, apply the 3D effect in one of the following ways:
Id Ribbon: On the Format tab, in the Features group, click 3D Effect.

Id Shortcut Menu: Right-click the frame of the chart, point to Show 3D, and click On.
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The 3D effect is applied to the chart, as shown in the following image.
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How to Rotate a Chart
You can rotate bar, line, and area charts to change the orientation of the data.

1. Create a chart or visualization.

2. Onthe Format tab, in the Features group, click Rotate.

The chart is rotated 90 degrees clockwise.

How to Display a Static Reference Line

Reference lines draw attention to specific data locations on a chart. You can add up to three
horizontal (X axis) and three vertical (Y axis) reference lines to a chart.

Reference lines can be created using either a constant or a computed field.

Field values allow a property to be dynamic, so that the reference line can change position
dynamically on the chart depending on the value of the field that is assigned to it.
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Note: A reference line value should be a single value, such as 10K, for example. In the
Reference line dialog box, if you select a field with multiple values, (Quantity Sold, for
example), then InfoAssist+ plots the last value on the chart.

1.
2.
3.

10.

Create a chart or visualization.
On the Format tab, in the Features group, click Reference.

In the drop-down menu that opens, select one of the following:
.d Add Reference Line to Y-Axis

4 Add Reference Line to X-Axis

The Reference Line dialog box opens.

Create the reference line with a static value that you set.
a. Select the Value option.

b. In the Value text field, type the value that you want to distinguish with the reference
line.

In the Text field, type the text for the reference line.

In the Position drop-down menu, select the position for the reference line on the chart. For
example, Above Center.

Click the Style button to set the style for the reference line. For example, Solid.

Click the Color button to open the Color dialog box, where you can select a color for the
reference line and the text.

Click the Weight button to select the weight of the reference line. For example, 1px - Light.

Click OK to save the options that you have selected, and close the Reference Line dialog
box.

The reference line is added to the chart.

Procedure: How to Display a Dynamic Reference Line

Reference lines can be created using either a constant or a computed field.

Field values allows a property to be dynamic, so that the reference line can change position
dynamically on the chart depending on the value of the field that is assigned to it.

Note: A reference line value should be a single value, such as 10K, for example. In the
Reference line dialog box, if you select a field with multiple values, (Quantity Sold, for
example), then InfoAssist+ plots the last value on the chart.
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The following procedure provides an example of how to create a dynamic reference line, where
the value changes based on the date. In this example, you can track the number of estimated
delivery days per shipping company, where the number of days estimated for delivery are
based on whether or not the sale date is a holiday.

1. Create a COMPUTE field to calculate the Reference Line.
a. On the Data tab, in the Calculation group, click Summary (Compute).
The Summary Field (COMPUTE) dialog box opens.
b. In the Field text box, enter Reference.
c. Set the format to D12.2.

d. Enter IF WF_RETAIL_LITE.WF_RETAIL_TIME_SALES.TIME_HOL EQ 'Y' THEN 5 ELSE 2
into the expression.

e. Click OK to close the dialog box.
Hide the Reference field from the chart.
3. Add a dynamic reference line.
a. Onthe Format tab, in the Features group, click Reference.
b. From the drop-down menu, select Add Reference Line to Y-Axis.

The Reference Line dialog box opens.

c. Select the Field option.

d. From the Field drop-down menu, select Reference.

e. Inthe Text field, enter Acceptable.

f.  From the Weight drop-down menu, select 2px - Medium.

g. From the Position drop-down menu, select Above Letft.
h. Optionally, you can change the color and style of the Reference line.
i. Click OK to close the Reference Line dialog box.
4. Run the chart.
Auto Prompt appears.

a. Select 20100101 (January 1, 2010) and click Run to see that five days are
acceptable since the date is a holiday.

b. Select 20100202 (January 2, 2010) and click Run again to see that two days are
acceptable since the date is not a holiday.

5. Click Save.

94 Information Builders



1. Customizing Content I

Procedure: How to Display Annotations

Annotations are explanatory notes or comments. You can add up to eight annotations on a
chart.

1. Create a chart or visualization.

2. On the Format tab, in the Features group, click Annotate.

3. In the drop-down menu that opens, click Add an annotation.
The Annotation dialog box opens.

4. In the text input field, type the text for the annotation.

In the Position drop-down menu, select the position for the annotation on the chart. For
example, Top Left.

6. Click OK to save the options that you selected, and close the Annotation dialog box.
The annotation is added to the chart.

7. Click Run to generate the report.

Collation in Charts

Charts that have the new attribute syntax respect collation, which provides alphabetical
sorting. Collation is also used in other areas, such as filtering.

Collation is set to CODEPAGE by the WebFOCUS Business User Edition installation, by default.
This can be changed in the Custom Settings section of the Administration Console. For more
information, see Configure Collation Sequence Settings.

Using Storyboards

The Storyboard feature allows you to capture and preserve snapshots of your visualizations as
you create them.

Each time you add something to the storyboard, it is placed onto a unique PowerPoint slide.
When you click Show, you can open and review your slides in PowerPoint.

Since storyboards give you the ability to turn your visualizations into a PowerPoint presentation,
you can modify your storyboard to create a customized demo. For example, you can rearrange
or delete slides, or add titles and text.

You can also make your visualization portable by saving the PowerPoint files that you create
and sharing the slides through email or other electronic distribution.
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Procedure: How to Create a Storyboard
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1.
2.

Create a visual, for example, a bar chart or a grid.

On the Home tab, in the Storyboard group, click Add.

Note: When you receive the Added to Storyboard message, click OK.

Insert another visual. On the Home tab, in the Visual group, click Insert.

Note: You can also click the down-arrow on the Insert button to insert a chart, grid, or text.
On the Home tab, in the Storyboard group, click Add.

Repeat steps 2 through 4 until you complete your data analysis.

On the Home tab, in the Storyboard group, click Show.

A new browser window opens, and you are prompted to open or save the PowerPoint file
that contains your storyboard.

. If you click Open, the storyboard opens in PowerPoint. You can save the file as a
PowerPoint presentation on your machine.

. If you click Save, the storyboard will be saved to a PowerPoint (.pptx) file and placed in
the Downloads folder on your machine. Click the down arrow on the right side of the
Save button to perform a Save as. This allows you to specify the drive and directory to
which the file will be saved.
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In PowerPoint, each storyboard frame displays as a PowerPoint slide, as shown in the
following image.

Animating Visualizations

You can animate visuals in a visualization. Each individual visual can have different animation
settings. The animations for each visual execute when you run the visualization.

Procedure: How to Add Animation to a Visual

1.

2
3.
4

Create a visualization with one or more visuals.

Select the visual that you want to animate.

On the Format tab, in the Interactive group, click Interactive Options.

On the Interactive Options dialog box, select the Show Animation check box.
This animates the visual.

Set the duration for the animation, which determines the speed at which the animation
occurs. The default value is 1400ms. Increase the value to make the animation slower,
and decrease the value to make it faster.

Optionally, clear the Enable Hover Over Effect check box.

This option lightens or adds a border to the segment of the visual that you move your
mouse over.

Click OK.
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8. Click Run.

Your visual animates automatically based on the options that you specified.

Using Filters to Customize the Display of Data

98

Filters enable you to customize the display of data in your report, chart, document, or
visualization. This gives you the advantage of viewing only the data that you want to see and
use.

When creating a report, you refer to fields in several parts of the request. For example, in
display commands (PRINT, SUM), in sort phrases (BY, ACROSS), and in selection criteria
(WHERE, WHERE TOTAL, IF).

The WHERE phrase selects records from the data source to be included in a report. The data is
evaluated according to the selection criteria before it is retrieved from the data source. You
can use as many WHERE phrases as necessary to define your selection criteria.

In WHERE TOTAL tests, however, data is selected after all the data has been retrieved and
processed.

You can group conditions and expressions within filter criteria. In addition, you can apply
functions and calculations within criteria. For more information on filtering options, see Field
Tab.

You can create Where and Where Total filters in the Filter dialog box by clicking WHERE.

Double-clicking the Double-click or press F2 to edit! text opens drop-down menus for Fields and
Subqueries, Operators, and Values.

You can retrieve fields and values from the Master File and data source and Subqueries from a
HOLD file.

The Field drop-down menu provides a field list from the Master File. The Field list can be
viewed as follows:

d In business order (default)

d In a sortable grid

- In a hierarchical structure of the data
N

If you select Subquery, then the Operator drop-down menu is replaced by a menu with the
options of In list and Not in list.

- In list. Activates a drop-down menu in the right-most part of the expression. The drop-
down menu contains a list of all subqueries that you have created from the Master file
in use, and an EXISTING option.
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Click EXISTING to open the Open dialog box, where you can select a subquery from a
different Master file.

4 Not in list. Opens the Open dialog box, where you can select a subquery from a
different Master file.

The Operator (default) drop-down menu provides various operators for your filter. For example,
Equal to.

The Value drop-down menu opens a dialog box with multiple options.

Note: If you are creating a filter on a full date field, the Value field will have a calendar icon
adjacent to it. You can use this icon to select a date using a calendar control.

The Type drop-down menu contains the following options:
.d Constant. Enables the entry of a literal constant value.

d Parameter. Enables you to specify a parameter by entering a name and description in the
provided text input areas, as well as selecting the type of parameter (Simple, Static,
Dynamic, or Optional).

. Field. Enables the specification of a field name to compare against.

The value area generally contains a text input box that you can use to manually insert values.
However, if you are working with a date field, the Value field is set to Today. You can optionally
select Beginning of Month, End of Month, Beginning of Quarter, End of Quarter, Beginning of
Year, End of Year, or you can specify a Custom date using the calendar that displays when you
make that selection.

Note: The default date of Today applies to Report, Chart, and Document modes only.

The value area also contains a Get Values drop-down menu, which supplies the following
options:

All. Retrieves all the values from the selected field.

First. Retrieves the first value from the selected field.

Last. Retrieves the last value from the selected field.
Minimum. Retrieves the minimum value from the selected field.

Maximum. Retrieves the maximum value from the selected field.

L o U o o U

From File. Retrieves a value that you specify. Selecting this option opens the Select From
File dialog box, where you can browse to a local file and specify a file format, such as a flat
file (CSV) or an Excel spreadsheet (XLS or XLSX).
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Note: The Get Values drop-down menu is only accessible if you have already selected a field.

After selecting the values that you want, you can move them into and out of the Multiple
Values area with the left and right arrows. You can also change the value order and delete
values with the up and down arrows and the Delete icon.

After creating a condition, you can insert additional conditions before and after the selected
condition by using the Insert Before and Insert After buttons at the top of the Filter dialog box.
You can use either the And or the Or conjunction to link conditions and the Group and Ungroup
buttons to nest and organize conditions.

You can create additional filters by clicking the New Filter button at the top of the Filter dialog
box.

After creating the filters that you want, click OK to save and apply the filters. You can access
them from the Filter pane of the Resources panel.

Including or Excluding a Filter

Once you have created a filter, you can make decisions about when and where you want to
include it in your report. For example, you might want to include one filter and exclude another.
Using the Include and Exclude options in the Filter group on the Home or Field tabs, you can
set filters accordingly.

You can use the following information to make decisions about your filters:
d Exclude. Removes, but does not delete, the filter from the report.

d Include. Restores a filter that was previously excluded from a report.

Using the Prompt Functionality to Select Field Information at Run Time
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Using the prompt functionality, you can create an auto prompting parameter for which you can
define a value at run time. This feature is located in the Filter Group on the Field tab.

To create an auto prompting parameter:
1. Select a field for which you want to create a parameter in your report.
2. On the Field tab, in the Filter group, click Prompt.
The Create a filtering condition dialog box displays.
3. Double-click the Value field.

Note: Parameter is selected, by default, when you are defining a prompt.
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The following options display, from which you can make a selection:
.4 Simple. This is used for prompts using Text Input. This is the default value.

. Static. This is used for prompts using Selection. This option allows you to select
multiple values at run time.

.d Dynamic. This is used for prompts using Data Values. This option allows you to select
multiple values at run time.

.4 Optional. This is used for prompts using Single or Multiselect parameters.
4. Click OK, and click OK again to close the Create a filtering dialog box.

When you run your report, you will be prompted for information based on the parameters
you created.

Using Auto Drill

Auto Drill enables you to navigate through different levels within the dimension hierarchy of
your data source. This allows you to review underlying data for a particular area, and move
through the structure of your data source based on your informational needs.

In order to use Auto Drill, you must enable it by clicking the Auto Drill button on the Format tab,
in the Navigation group.

Once you have enabled Auto Drill, you can develop your report or chart and run it to activate
the hyperlinks that Auto Drill creates. This enables you to navigate up or down through the
related hierarchy of your data source by clicking the links that display.

When you click a hyperlink, the option to drill up or drill down displays, depending on where you
are in the hierarchy of your data. You can then select one of these options to begin navigating
your data. For example, if you have Product Category in your hierarchy, you would be able to
drill down to Product SubCategory. When you drill down, you can subsequently drill back up to
the originating dimension sort field. If you have selected a data source that has multiple levels
and your report or chart uses a component in the middle of the hierarchy, both the Drill up and
Drill down options will display. Once you have started navigating your data using the Drill up
and Drill down options, the Restore Original option displays, enabling you to start your data
analysis over by re-executing the original Auto Drill request.

At run-time, the Auto Drill functionality displays a breadcrumb header. This defines your current
location in the hierarchy of your data source and enables you to navigate back and forth
between different levels in your data.
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Procedure:

102

Important:

-

-

-

The Auto Drill functionality is only available for data sources that have a dimension
hierarchy.

If you have Auto Drill enabled and you attempt to run your report or chart in deferred mode,
the hyperlinks will not display. This is also true for Auto Drill enabled reports that are
distributed through ReportCaster.

With the exception of Visualization mode, Auto Drill is available at run-time, but not in Live
Preview.

Auto Drill is supported for HTML and active report output format reports.

Auto Drill is automatically enabled in Visualization mode for data sources that have a
dimension hierarchy.

Auto Drill functionality is not available in reports distributed by ReportCaster, because Auto
Drill uses live data, in an interactive session, for data drilling. Data values and totals may
not be the same if the data has changed since the last distribution. Mixing past data with
current data could impact data analysis.

Auto Drill is not supported for HTML5 output format charts that do not support the new
chart attributes syntax.

Auto Drill is not supported on Across fields in active reports.

You must use dimension fields as a sorting field, either BY or ACROSS.

How to Use Auto Drill to Navigate the Hierarchy of Your Data Source

1.
2.

Select a data source that has a dimension hierarchy. For example, wf_retail_lite.mas.

Create a report or chart with one or more hierarchical fields (for example,
Product,Category).

On the Format tab, in the Navigation group, click Auto Drill.
Click Run.
The report or chart displays.

For reports, click a hyperlinked field within your report. For charts, hover over a chart
aspect (for example, a bar).

A menu appears.
Select a hierarchical value to which to drill down to.

Once you have drilled down on a field, you can subsequently drill up.
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7. To return to the default state of the report or chart, click a hyperlink or hover over a chart
aspect, and then click Restore Original.

Using the Auto Linking Feature to Link Content

Auto Linking makes it easy to connect reports and charts in your development environment,
expanding the reporting capabilities of your organization. Using Auto Linking, you can
dynamically link HTML reports, active reports, and HTML5 charts with a single report or chart of
any format, based on their common sort (BY) fields and parameters referenced in any filters. It
is this commonality that dynamically links content in your WebFOCUS repository, allowing you
to discover new possibilities in your data, and explore new relationships within your reporting
enterprise. In addition, Auto Linking saves development time and effort, because drilldowns do
not need to be manually created and maintained.

To use Auto Linking, you must use the Enable Auto Linking option in InfoAssist+ to set the
reports or charts that can be auto-linked. In addition, you must also set reports or charts to be
Auto Link targets. The options to enable and disable Auto Linking and Auto Link Target
functionality are available on the Format tab, in the Auto Linking group, in InfoAssist+.

Note:

.d The Auto Link Enabled option is activated only when the HTML, HTML5, and active report
output format is selected.

-l You can open an existing report or chart and enable Auto Linking or set the item as an Auto
Link target.

When Auto Link functionality is activated, your reports or charts display a link for each sort (BY)
field with qualifying target reports or charts at run time. In Auto Link enabled reports, you must
add sort (BY) fields in the BY field container. In Auto Link enabled charts, you can add sort (BY)
fields to the Horizontal Axis, Vertical Axis, or Color field containers.

To qualify a report or chart as an Auto Link target, you must include filters that contain the
parameters that you selected as the sort field or fields in the enabled report or chart. The
parameter names defined in these filters must be the same as the sort (BY) field names in the
Auto Link enabled report. When you select a report or chart as the Auto Link Target, it specifies
that the parameter information should be catalogued, and will be evaluated when an Auto Link
enabled report or chart is run.
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For an Auto Link enabled report at run time, the qualifying target reports and charts are those
that have filters with parameters for the selected sort field and the sort fields that precede it,
which appear to the left. For an Auto Link enabled chart at run time, the target reports and
charts are those that have filters with parameters for all sort fields. For run time for both
reports and charts, the linked sort field values in the Auto Link enabled report or chart are
passed to the Auto Link target report so that it can be filtered by the sort (BY) field values.

For example, you may have an Auto Link enabled report that contains sort (BY) fields Product
Category and Model, with a measure (Sum) field, Revenue. To qualify as an Auto Link target,
other reports or charts in your repository can contain a single filter with a parameter for
Product Category, or two filters with parameters for both Product Category and Model. When
you run the Auto Link enabled report, the Product Category field will link to target reports or
charts that have a filter with a parameter for Product Category and the Model field will link to
target reports or charts that have filters for both Product Category and Model.

If you use the same example for an Auto Link enabled chart instead of a report, you can
access the target reports or charts from a tooltip option that displays when you point your
mouse over an area of the chart, such as a bar that represents Revenue by Product Category
and by Model.

Note:

d The linked reports displayed are limited to those that you are authorized to run or run
deferred.

- When running an HTML report with On-demand Paging enabled, the qualifying Auto Link
targets appear on the menu in the order that they are specified in the request. This is also
true for a chart request that is a legacy graph format (PFJ-based formats, such as PNG and
non-bucket HTML5). In reports, horizontal lines appear in the menu to separate user
specified drilldowns and Auto Link navigation options.

- Consideration should be given to how many reports or charts are indicated as Auto Link
targets, as the run time Multi-drill menu for the qualifying target reports may become long in
length. In these cases, some browsers may display a script processing warning message.

- The Auto Link Enabled and an Auto Link Target options can be set individually or both can
be set on the same report or chart if that item meets the Auto Linking requirements.

Procedure: How to Set an Existing Report or Chart as Auto Link Enabled

104

1. In the Resources tree, right-click a report or chart and click Edit.

InfoAssist+ opens in the relevant mode.
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Verify that there is a sort (BY) field in the report or chart.

4 For reports, sort fields are added to the BY field container.

.4 For charts, sort fields are added to the Horizontal, Vertical, or Color field containers.
On the Format tab, in the Auto Linking group, click Enable Auto Linking.

Save the report or chart.

Your existing report or chart is now Auto Link enabled.

Procedure: How to Set an Existing Report or Chart as an Auto Link Target

1.

In the Resources tree, right-click a report or chart and click Edit.

InfoAssist+ opens in the relevant mode.
On the Format tab, in the Auto Linking group, click Auto Link Target.

Note: Selecting Auto Link Target specifies that the parameter information for this report or
chart will be stored, adding it to the repository of reports and charts that will be evaluated
when an Auto Link enabled report is run.

Add a filter with a simple or optional parameter to the target report or chart. Qualifying
target reports are those that have filters with parameters for the sort (BY) fields in Auto
Link enabled reports or charts.

a. From the Data pane, drag a sort (BY) field into the Filter pane.

b. Using the Create a filtering condition dialog box, add the selected parameter as
simple, as shown in the following image.

'rrCreate a filtering condition
,h? :ﬂ? ",r ‘z - Ungroup
L 7 0
= ¥ WHERE

Product,Category Egual to

Type: Parameter =

Mame: PRODUCT_CATEGORY Description: Product Category:
(@ Simple () Static (O) Dynamic
[ Optional
" 0K {8) Cancel
v ®
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4.

c. Click OK, and then click OK again to exit the Create a filtering dialog box.

Save the report or chart.

Your existing report or chart is how set as an Auto Link target.

Procedure: How to Create a New Auto Link Enabled Report or Chart

1.

2
3.
4

5.

Open InfoAssist+ in report or chart mode.

From the Open dialog box, select a data source.
On the Format tab, in the Auto Linking group, click Enable Auto Linking.

Add fields to the report or chart, ensuring that one is a sort (BY) field.

4 For reports, sort fields are added to the BY field container.

4 For charts, sort fields are added to the Horizontal, Vertical, or Color field containers.

=) query

4 E Report {wf_retail_lite)

4 F Sum
B Cost of Goods
4 =5 By

B Product.Category

JEIT,
=| Across

Save the report or chart.

%) Live Preview (500 Records)

Product

Category Cost of Goods
ACCEss0ries $69,753,598.00
Camcorder 5104,566,857.00
Computers 569,807 664.00
Media Player £150,24D,481.00

Stereo Systems
Televisions

Yideo Production

Your report or chart is now set as Auto Link Enabled.

Procedure: How to Create a New Auto Link Target Report or Chart
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1.
2.
3.

Open InfoAssist+ in report or chart mode.

From the Open dialog box, select a data source.
On the Format tab, in the Auto Linking group, click Auto Link Target.

$205,113,663.00
$61,551.100.00
$40,105.657.00

Note: Selecting Auto Link Target specifies that the parameter information for this report or
chart will be stored, adding it to the repository of reports that will be evaluated when an

Auto Link enabled report is run.
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4, Add fields to the report or chart.
5. Add a filter with a simple or optional parameter to the target report or chart.
a. From the Data pane, drag a sort (BY) field into the Filter pane.

b. Using the Create a filtering condition dialog box, add the selected parameter as
simple or optional.

Note: When creating a parameter for a field, the parameter name defaults to the
fieldname that you select. In the previous image, the creation of a filter with
parameter Product Category is shown. To ensure that the name of the parameter is
the same as the sort (BY) field in the Auto Link enabled report or chart, do not change
the name of the parameter that is generated by your field selection.

c. Click OK, and then click OK again to exit the Create a filtering dialog box.
6. Save the report or chart.

Your report or chart is stored as an Auto Link target.

Procedure: How to Run an Auto Link Enabled Report or Chart
You can run an Auto Link enabled report or chart from within InfoAssist or from the Portal.

1. Open and run an Auto Link enabled report or chart in one of the following ways:

d In InfoAssist+, open or create an Auto Link enabled report and on the Quick Access
toolbar, click Run.

.4 From the Portal, right-click a report or chart that is Auto Link enabled and click Run.
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2. Use the hyperlinks to link to other reports and charts, based on the following information:

Id Reports. Displays with hyperlinks on the sort (BY) fields that have qualifying target

108

reports. Click a hyperlink to display the menu with the Auto Links option, which
cascades to list the qualified Auto Link target reports and charts, as shown in the

following image.

Product Quantity

Category Revenue Sold Cost of Goods Gross Profit
Accessories w Sales 2015 511,667 $89,753,890.00 $359,854,44053
Camcorder Sales 2014 455244 $104,666,857.00 $49595,84524
Computers $103.31_6:4B2.12 31,777 569.807,664.00 $33,508,518.12
Media Player $246,073,055 36 771,934 5$190,240,4581.00 $55,83257836
Stereoc Systems  $291,294,933.52 1,114,332 §$205,113,863.00 $586,181,070.52
Televisions $78,381,132.81 105,188  561,551,109.00 $16,830,023.81
Video Production  $58,053,276.62 199,749  540,1065657.00 $17,947.619.62
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Id Charts. Displays with aspects over which you can hover (for example, a bar) in the
chart. A tooltip displays with the Auto Link target reports and charts, as shown in the

following image.

Using Multi Drill

100Mm

20M

60M

40Mm

20M

0

Product Category: Camcorder

Gross Profit 49593845
Auto Links Sales 2013
Sales 2014

Accessones

Camcorder

Computers

IMedia Player
Stereo Systems

Product Category

Televisions

Video Production

B Discount
Gross Profit

The Multi Drill functionality enables you to create multiple drill down links on a data field in a
report or chart. This is useful when you want to define custom links to other reports or

websites.

Using the Multi Drill functionality, you can define conditions for drilling down or through the
data element that you select. Once drill down information is saved and you run the report or
chart, the drill down options display when you click or hover over the defined area of a report or

chart, respectively.

Customizing Content
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You can create drill down links by selecting a field in the Query pane. On the Field tab, in the
Links group, click Drill Down to open the Drill Down dialog box. You can also right-click a field in
the Query pane, and click Drill Down. The Drill Down dialog box is shown in the following image.

%‘IDriII Down - Revenue

N X

Drill Down 1 .
@ Report (7)) Refresh BIPortal () Auto Link Target () Web Page

Report™
Browse
Description
Drill Down 1
Target

Mew Window -

Parameters

Mame Value

*Required Field

v Delete all and exit

When you access the Drill Down dialog box, the name of the field that you selected displays in
the title bar. This enables you to identify the current field and is useful when working with Drill
Down parameters.

In the Drill Down dialog box, you can configure a hyperlink or drill-down procedure. When you
run the report, you can click the link that is created, which would take you to the specified URL
or execute the specified procedure.

You can also create multiple drilldowns for a selected field. The drill down links that you define
display as separate entries in the drill down list, also known as the drill menu, at run-time. The
display of these entries is based on the naming conventions that you applied when creating
the multi-drill scenario.
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Once your drilldown options are defined, you must run your report in order to access the drill
down links that you have created. For reports, the links display when you click on a hyperlink
for the data field that you selected. For charts, they display when you hover over an area of the
chart for which the drill down has been defined (that is, the field that you selected when you
defined the drill down).

These links enable you to drill directly through to an external procedure or URL.

For example, you can create one drill down link for an existing procedure, and another for a
webpage. Both drill downs are stored for the underlying field that you selected. Once you
define the first drill down, additional options display on the toolbar, as shown in the following
image.

él Dirill Down - Product, Category

+ OO0 X &

e B (®) Report () Refresh BI Portal () Auto Link Target () Web Page
Report™
IBFS:/WFC/Repository/Getting_Started/~manager/Report2.| Browse

New Window =

g
1

[

Parameters

Name Value

* Required Field
v a ®

Note: You can rename a drill down using the Description field in the right pane of the Drill
Down dialog box.
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The following icons are available on the Drill Down dialog box toolbar:

-1 Create a new drill down. This option is enabled when all required information is provided
for the first drill down. When you click Create a new drill down, a new drill down item is
created. This switches the drill down functionality from a regular drill down to multi-drill. By
default, the name of the drilldown is Drill Down n, where n is a consecutive integer, such as
Drill Down 1, Drill Down 2, etc. This option is initially disabled, but is enabled after you
have created at least one drill down link.

-1 Duplicate the selected drill down. When an existing drill down item is selected, clicking
this option duplicates the item. A (Copy n) is appended to the name of the drill down, where
n is the consecutive number assigned to the duplicated drill down. Once assigned, the
name can subsequently be changed in the Description field. Consecutive copies can also
be rearranged by dragging the drill down items into the desired order.

Note: The Duplicate button is only active when sufficient information is available for the
selected drill down item.

-1 Rename the selected drill down. This option enables you to rename an existing drilldown
and is active by default. When this option is selected, the Description field is selected,
allowing you to provide a new name for the drill down link. You can enter a description up to
100 characters long. If you remove the description, the drilldown is renamed to the default
name.

-l Remove the selected drill down. If you have a drill down item selected, the Remove the
selected drill down option is active. When you select this option, the current drilldown is
deleted. If a drill down item is removed, the next drill down item is automatically selected. If
you remove the last drill down item, the Drill Down dialog box resets to its initial state,
restoring Drill Down 1 as the default value.

-l Options. The Options functionality enables you to change the order of your drill down items.
This allows you to control the order in which the items are presented in the drill menu when
you run your report and click on a hyperlink. You can change the order by selecting a
defined drill down in the list that is presented under Edit Order and then clicking the Move
Up or Move Down button. You can also remove one or more drill down items from the list by
selecting the desired items and then clicking the Remove from List button. If you multi-
select your drill down items using the CTRL key, the Move Up and Move Down buttons are
disabled.

Note: Move Up, Move Down, and Delete are also available as context menu options when
you right-click a drill down item in the Edit Order list.

The Drill Down dialog box contains the following options for specifying drill down information for
the selected field:
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Note: When specifying parameters for your drill down, click Add Parameter to add them to your
parameters list.

- Report. Select this option to choose a report for the current drill down. This option is
selected by default.

4 Report. Enables you to browse to a stored report.

.4 Description. Provides a field in which to describe the report. If you selected a report by
browsing, this field is automatically populated with the title of the procedure or the
name where procedure titles are not accessible. This field is also used to rename a
specified drill down.

.4 Target. Allows you to specify a target for the drill down. Options include: New Window,
Same Window, or a value that you specify. The default value for report is New Window.

d Parameters. Displays the parameters that you have indicated for the current drill down.

1 Refresh Bl Portal. Select this option to refresh the components of the Bl Portal and pass
parameters to them.

.4 Refresh. Provides options by which to refresh the page. Options include Current Page
and All Pages.

.4 Description. Provides a field in which to describe the refresh process. This field is also
used to rename a specified drill down.

4 Target. Reflects the target for the drill down. The only applicable value for Refresh Bl
Portal is Same Window.

d Parameters. Displays the parameters that you have indicated for the current drill down.

d Auto Link Target. Select this option to create an explicit list of Auto Link targets. Upon
selection, these will be available in the drill down menu at run time.

Note: When working with reports, the Auto Link Target drill down option is only available for
a selected dimension (BY) field. For more information, see Using the Auto Linking Feature to
Link Content .

.4 Auto Link Target. Enables you to browse to a stored target report.

-1 Description. Provides a field in which to describe the target report. If you originally
selected a report by browsing, this field is automatically populated with the report title
or the name where titles are not accessible. This field is also used to rename a
specified drill down.
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- Target. Enables you to specify a target for the drill down. Options include: New Window,
Same Window, or a value that you specify. The default value for Auto Link Target is New
Window.

- Parameters. Displays the parameters that meet the column-to-parameter requirement
for the selected target report.

For more information, see Using the Auto Linking Feature to Link Content .

-1 Web Page. Select this option to indicate that you want to drill through to a webpage. Enter
a value in the URL field.

d URL. Enables you to specify the URL for the webpage to which to drill down. This option
is available only when Web Page is selected.

- Description. Enables you to enter additional comments related to the drill down. This
field is also used to rename a specified drill down.

- Target. Enables you to specify a target for the drill down. Options include: New Window,
Same Window, or a value that you specify. The default value is New Window.

1 Parameters. Displays the parameters that you have indicated for the current drill down.
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If you are working with a report that has parameters, the parameter names are automatically
retrieved and made available from the Name control in the Parameters section of the Drill
Down dialog box, as shown in the following image.

é‘ Dirill Down - Product, Category

# 00N X &

Simmary Sales Report

(®) Report () Refresh BI Portal () Auto Link Target () Web Page
Infarmation Center Website Report

IBFS: /WIFC/Repository/Getting_Started/~manager/Report20 Browse

Diescription

Simmary Sales Report
Target

New Window

Parameters i

Name Name:

PRODUCT_CATEGORY

COG5_US
—
Field -
Value:
* Required Field
Cost of Goods -

oK (§) Cancel

By default, the field is labeled with a value of Name. If there are multiple parameters to choose
from, you can use the drop down list to make a selection. You can also manually enter a name
to create a new parameter. The parameters that display are populated from the underlying
report procedure (.fex) that you selected for your drill down.

The Type field enables you to specify a field or constant value. The options in the Value list are
based on the fields that you selected for your report. The item that you select determines the
value for the parameter (for example, Discount or Revenue).

Note: If you switch the Type field from Field to Constant or from Constant to Field, the Value
field is reset, enabling you to specify a unique value.
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Procedure: How to Create a Single Drill Down Link
You can create a single drill down link on a measure field.
1. Create a report or chart with at least one measure field.

2. In the Query pane, do one of the following:
. Right-click the measure field and click Drill Down.
. Click the measure field and on the Field tab, in the Links group, click Drill Down.

The Drill Down Dialog box displays, as shown in the following image.

%Drill Down - Revenue

N X

Drill Down 1 ]
@ Report () Refresh BI Portal () Auto Link Target () Web Page

Report™®
Browse
Description
Drill Down 1
Target

Mew Window -

Parameters

Mame Value

* Required Field

. Delete all and exit
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3. Select one of the following Drill Down options:
4 Report
. Refresh Bl Portal
. Auto Link Target

4 Web Page
4. Populate the fields based on the drill down option you selected.
Note: Descriptions for these fields are provided earlier in this topic.

5. Optionally, rename the Drill Down using the Description field. This dictates how the Drill
Down will appear in the left pane of the Drill Down dialog box.

6. Click OK.

The drill down link displays when you hover over the defined area of a report or chart, at
run time.

Procedure: How to Create Multi Drill Links
You can create a multiple drill down links on a single dimension field.
1. Create a report or chart with at least one dimension field.

2. In the Query pane, do one of the following:
d Right-click the dimension field and click Drill Down.

. Click the dimension field and on the Field tab, in the Links group, click Drill Down.
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The Drill Down Dialog box displays, as shown in the following image.

élDrill Down - Product, Category

Drrill Down 1 e i e ] o
(®) Report () Refresh BI Portal (_) Auto Link Target (_) Web Page
Report®

Browse

Description
Drill Down 1
Targst

New Window =

Parameters

Mame Value

* Required Field

v Delete all and exit I @

3. Select one of the following Drill Down options:
4 Report
.4 Refresh Bl Portal
4 Auto Link Target

4 Web Page
4. Populate the fields based on the drill down option you selected.
Note: Descriptions for these fields are provided earlier in this topic.

5. Optionally, rename the Drill Down using the Description field. This dictates how the Drill
Down will appear in the left pane of the Drill Down dialog box.

6. Repeat steps 3-5 until you have added all of the drill down links required.

Note: The following image defines three unique drill down links for the selected dimension
field.
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#30rill Down - Product.Category

# B3 X B

Usage Analysis Summary

 Sales Report

Company Website

7. Click OK.

The links display when you hover over the defined area of a report or chart, at run time, as
shown in the following image.

Customizing Content

(®) Report () Refresh BI Portal () Auto Link Target () Web Page
Report™
IBFS: '"WFC/Repository/Getting_Started/~manager/Repaort2.i Erowse

Description
Sales Rapert
Target

New Window

Parametars @

Name Value

* Required Field

v = ®

Product

Category Cost of Goods Discount
Accessories $85. 753 805.00 36,014 845 52
Camcorder Usage Analysis Summary 7,108,408.27
Computers | cgles Report B4.808 910,10
Media Played Company VWebsite 1,219,142.41
Stereo Systems £205,113,863.00 513,530,873.57
Televisions $61,551,109.00 $3,635,693.38

Video Production $40,105,657.00 52,695,690.76
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Adding Parameters for Data Selection at Run Time
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You can add new parameters to your report or chart to create parameter options for selection
at run time. This enables you to dynamically select and review different scenarios with your
data, offering you on-demand, dynamic report or chart creation at run time.

When you add a parameter, it becomes a field container into which you can add one or more
measures and dimensions. You create a new parameter by right-clicking on a field container in
the Query pane and clicking New Parameter. This creates a numbered parameter (for example,
Parameter 1). In cases where you have multiple parameters defined, the numbering is applied
sequentially.

Once you add a parameter, you can rename the variable by right-clicking the Parameter-n field
container and clicking Rename Variable , where n is the number of the parameter that was
added. Once you rename a parameter field container, the new title displays in the Query pane
and at run-time. This allows you to easily identify the parameters while categorizing the data
fields that you want each to contain. For example, if you add a number of Sales-related fields
to a parameter, you can rename the parameter with a title of Sales to encapsulate the data
fields that you selected. Parameters should be renamed before you run the report or chart so
that they are easy to identify.

In order to populate parameters in your report or chart, data fields must be placed in the
parameter field container. You can do this by selecting fields from the Data pane and dragging
them into the relevant parameter field containers that you create.

Note: Double-clicking the data fields in the Data pane places the data field in the default field
containers in the Query pane, not the parameter field container. For example, in a report, if you
double-click Discount, the data field is placed in the Sum container (outside of the parameter
field container that you created). You can always drag a data field into a parameter container
from another field container in the Query pane if you wish to consider it a parameter.

You can also reorder the data fields that you have placed in a given parameter field container
by dragging them into the order that you wish to display them at run time. Parameters can be
specified in any field container, with the exception of Multi-graph. Once you have defined your
parameters and selected the relevant data fields, run the report or chart. Using the drop-down
lists for each parameter, you can select different options from the parameter lists to view the
data in your report or chart dynamically. To load different scenarios, select the values and then
click Run.
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The following image shows the Query pane with a number of parameters and data fields
specified.
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Procedure: How to Add a Parameter
1. Create a new report or chart or open an existing one.

2. Add a new parameter by right-clicking a field container and clicking New Parameter , as
shown in the following image.
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A new parameter field container is added.
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Adding Parameters for Data Selection at Run Time

3. Add the data fields that you would like to display in a parameter list at run time to the new
parameter field container.

4. Optionally, rename the parameter by right-clicking the parameter and clicking Rename
Variable.

This is not required, but it does help in differentiating the various numbered parameters
that display, depending on how many you define.

5. Optionally, add one or more additional parameters, and relevant data fields, into the field
containers for which you would like to select data values at run time.

6. On the Quick Access toolbar, click Run.

You can use the Parameter drop-down lists that display at run-time to create different
views of your data, as shown in the following image.

Sales

Discount

Product

Product Category

Note: You can optionally run your report or chart using the default parameters without
making a selection. Click the down arrow on the Run button in the Quick Access toolbar
and select Run with Default Parameter Values.

The following navigational icons display at run time:

Icon Description

Close Filter Panel. Click this option to collapse the filter panel,
displaying more of the report or chart in the right pane.

Reset filter values. Click this option to reset the filter values to
their default values, as indicated when the parameter was initially
set up.

122 Information Builders



1. Customizing Content I

Icon Description

Run with filter values. Click this option to run the report or chart
based on your selections.

Show filter panel. Click this option to show the filter panel when
viewing a report or chart. When viewing the filter panel, you can
close it by clicking Close Filter panel.

Working With Slicers

Slicers provide a quick and easy way to add dynamic user controls to a chart or report, giving
you the ability to filter the data in use as you create or view content. Slicers are dynamic filters
that can be changed by making a selection from a menu of fields. You can use them to filter
your content by modifying a slicer in the Slicers tab and running the chart or report, or you can
use them at run time when running a report in InfoMini with the Slicers tab selected.

Creating Slicers

You can create slicers by dragging fields to the Slicers tab or through the context menu of a
field. When you create a slicer group, it appears on the Slicers tab.

You can use slicers to dynamically filter reports at design time.

You can dynamically filter reports at run time when they are included in an InfoMini application.
For more information on InfoMini, see Understanding and Building InfoMini Applications.

Procedure: How to Create a Slicer
1. Click the Slicers tab.

2. Create a new slicer by using one of the following methods:
.4 Click the New Group button to create a new slicer group.

Select a field from the Data pane and drag it onto the Drag Fields Here to Create Slicers
text on the Slicers tab.

Note: You cannot drag parent-child hierarchies onto the Slicers tab.
The field is added to the new group.
or
.4 Right-click a field in the Data pane, point to Slicers, and then click New Group.

The field is added to the new group.
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If you are creating a slicer on a full date field, a calendar icon displays adjacent to the
field. You can use this icon to select a date using a calendar control.

Procedure: How to Add a Field to an Existing Slicer Group
1. Click the Slicers tab.

2. Add a field to an existing slicer group using one of the following methods:
- Select a field from the Data pane and drag it onto an existing slicer group.
or
- Right-click a field in the Data pane, point to Slicers, and then click Existing Group.
Select an existing group from the menu, and then click OK.

The field is added to the existing group.

Procedure: How to Add a Hierarchy as a Slicer Group
Note: You cannot drag parent-child hierarchies onto the Slicers tab.
1. Click the Slicers tab.
2. Add a hierarchy as a slicer group using one of the following methods:
- Select a hierarchy from the Data pane and drag it onto an existing slicer group.

The hierarchy is added as a new group, not as a slicer in the existing group. The new
group is given the same name as the hierarchy.

or

- Click the New Group button to create a new slicer group.

Select a hierarchy from the Data pane and drag it onto the Drag Fields Here to Create
Slicers text of the Slicers tab.

The hierarchy is added to the new group. The name of the new group changes to the
name of the hierarchy automatically.

Note: Hierarchies cannot be added to existing slicer groups. If a hierarchy is dragged onto
an existing slicer group, a new group is created automatically.

There is no right-click context menu for hierarchies. To add a hierarchy as a slicer group,
you must drag it into a new slicer group.
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Filtering With Slicers

Once you add slicers to an InfoAssist+ report, you can use them to filter the report. You can
select values from the slicers menus, change the number of records that appear, create new
slicer groups, clear existing slicer groups, and update the report preview.

Slicers that are not selected have their values filtered by the selected slicers. Only values that
meet the criteria for previously selected slicers will appear in the menu for the next slicer.
Slicers are not filtered in the order they appear in the slicer group, but by the order they are
selected. Cascading of slicers is only valid for hierarchies.
Procedure: How to Change the Relationship Operator in a Slicer

1. With at least one slicer added to the report, click the Slicers tab.
2. Click the operators button on the slicer for the operation you want to change.

A list of operators (numeric) appears in the menu.

Note: Alpha fields just flip between equal and not equal.

3. Select the operator that you want from the menu. You can rest the mouse on an operator
to display a tooltip describing the operation.

How Slicers Cascade Together
Slicers cascade within a hierarchy (cube or dimension builder-based), rather than in the order
of user interaction, eliminating potential performance issues.
Procedure: How to Cascade Slicers
Controls with fields from the same hierarchy are cascaded together.
1. Create a report.
2. Create multiple slicer groups, as described in How to Create a Slicer on page 123.

Note: You can select multiple values by holding down the CTRL key while selecting items
in the drop-down list box. In cases where multiple items are selected, the label for the
drop-down list is set to Multiple. You can click the drop-down list to review the selections.

Once you click OK, the new control appears in the drop-down menu.

The 1 prior to the decimal point indicates that this is the first cascade you have interacted
with. The 1 after the decimal point indicates that it is the first control in that cascade.

3. Filter the report using the controls in the slicer groups that you created.
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Note: The order of a cascade is dynamic. For example, if you selected Camcorder from
Product Subcategory first, then the Product Category control would have a value of Video
Production.

Changing a Field Format

You can change the format of any field except a Sort field. You can change the format of
measure fields, as well as any calculated fields.

The following procedures show how to change a field format from the Field Format Options
dialog box. For more information on how to use the Format group options, see Field Tab.

Procedure: How to Assign an Alphanumeric Format

1. With a report open in Live Preview, right-click a virtual field or column measure field, and
select Edit Format.

The Field Format Options dialog box opens.
2. From the Field type list, select Alphanumeric.

3. To assign a different length, specify a number between 1 and 4095 in the Total length
field. The default value is 20.

4. Click OK to close the Field Format Options dialog box and return to the canvas.

The new format appears in the previously selected column.

Procedure: How to Assign a Numeric Format

126

1. With a report open in Live Preview, right-click a virtual or column measure field, and click
Edit Format.

The Field Format Options dialog box opens.

2. From the Field type list, click one of the following options:
- Floating Point (default length 7.2)
d Integer (default length 5)
- Decimal (default length 12.2)

- Packed (default length 12.2)
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If the selected field matches the selected format type, its current length appears in the
Field Length field. Otherwise, the default length appears in the Field Length field. The
Decimals field shows the numbers of decimal places for Floating Point, Decimal, and
Packed.

4 To assign a different length, specify it in the Field Length field for format types as
follows: 1-9 for Floating Point, 1-11 for Integer, 1-20 for Decimal, and 1-33 for Packed.

4 To assign a different number of decimal places for Floating Point, Decimal, or Packed,
specify the number in the Decimals field.

3. Click OK to close the Field Format Options dialog box and return to the canvas.

The new format appears in the previously selected column.

Procedure: How to Assign a Date Format

1. With a report open in Live Preview, right-click a virtual or column measure field, and select
Edit Format.

The Field Format Options dialog box opens.
From the Field type list, click Date.

3. To assign a different date display format, select a date format from the Date Format list.
The default date display format is MDY.

4. Click OK to close the Field Format Options dialog box and return to the canvas.

The new format appears in the previously selected column.

Procedure: How to Assign a Date-Time Format

1. With a report open in Live Preview, right-click a virtual or column measure field, and select
Edit Format.

The Field Format Options dialog box opens.
From the Field type list, click Date-Time.

3. To assign a different date-time format, select the date format you want to use from the
Date Format list. Expand Year First, Month First, or Day First to see the available options.

4. Select a time format (if applicable) from the Time Format list.

If you select the Time Only check box then you can only set a time format. Expand Hour
First, Minute First, or Seconds First to see the available options.

Note: These expansion options are only visible when you select Time Only.
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5. Click OK to close the Field Format Options dialog box and return to the canvas.

The new format appears in the previously selected column.

Procedure: How to Add a Percent Sign to a Numeric Field

You can add a percent sign to the end of a numeric value (Decimal, Integer, and Floating Point
formats). This numeric display option includes a percent sign along with the numeric data, but
does not calculate the percent.

1. With a report open in Live Preview, right-click a virtual or column measure field, and select
Edit Format.

The Field Format Options dialog box opens.

2. From the Field type list, click a numeric value format (Floating point, Integer, Decimal, or
Packed), and then select the Percent (%) check box.

3. Click OK to close the Field Format Options dialog box and return to the canvas.

The new format appears in the previously selected column.

Dynamic Grouping
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Dynamic grouping allows you to create groups of elements based on the field data type that
you select. For example, in the wf_retail_lite database, there are a number of brands of
televisions. Using the dynamic grouping functionality, you can create groups based on the
popularity of a particular brand. The first group might include top sellers such as LG and Sony.
The second group might contain the remaining brands (Panasonic, GPX, Supersonic, Tivax, and
Audiovox). This would allow you to group top sellers into one group, and the remaining brands
into another group.

Note: The Create Group option is only available for dimension fields of non-numeric format or
attribute.

You can also specify multiple, unique groupings in the same session. For example, you might
want to group the data to indicate groups or products, or specific regions.

Note: If you want to exclude a specific data element from your analysis, you can use the filter
functionality.

The grouping that you specify is applied and this new group then replaces the original field that
you selected in the Query pane. The hame that you specify when creating the group is reflected
in the Query pane.

Note: You can edit the group once it has been created by right-clicking on the higher-level field
and clicking Edit Group .
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Procedure: How to Create a Dynamic Group
1. From the Data pane, add one or more data fields to your report or chart.
2. In the Query pane, right-click the data field for which you want to apply dynamic grouping.
Note: The Create Group option is also available in the Data pane shortcut menu.
3. Click Create Group.
The Create a Group dialog box displays.
4. In the Field text box, optionally type a name for the new group.

Select the data values that you want to group. Use CTRL + click to select more than one
value, as shown in the following image.

& Create a Group

Field: |PRDDUCT SUBCATEG_1

i Groups

Add to: | I~| search:

Charger
DVD Players

Home Theater Systems

Professional

Receivers

Speaker Kits
Standard

Streaming

Universal Remote Controls |—

Video Editing

6. Click Group .

Note: To ungroup values, click a group and then click Ungroup.
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7. Optionally, create additional groups, as shown in the following image.

iﬁﬁﬁtﬁm@

== Ungroup All | * * Show Other

nddm:| Izl Seard'1:| | 2 ox

:
@
B
r

DVD Players - Portable

Handheld
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oK Cancel . Apply
8. Click OK.
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Your grouped data will display in the Data pane when your report, chart, or visualization
refreshes, as shown in the following image.
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