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Module 4: Creating Content - Lesson 6: Creating Documents = Try Now!

In this Try Now! exercise, you will be creating a document in your Sales domain by adding content you have
already created, which is based on the data you uploaded from your Microsoft® Excel® spreadsheet
(retail_data_extract.xlsx). You will also add sample content to this document that was automatically
generated based on your data. The tutorial will also show you how to arrange the layout of your document
and add additional content as required.

1. Inthe Resources tree on the Home page, right-click the published My Sales Content folder, select
New from the context menu, and then click Document, as shown in the following image.
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InfoAssist+ opens in the background and an Open dialog box is displayed in the foreground, as
shown in the following image.
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2. Select sales in the left pane and the retail_sales Synonym (also known as a Master File) in the right
pane. The Synonym includes a .mas extension.

3. Click Open.



The retail_sales Synonym is loaded into InfoAssist+, as shown in the following image.
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Note: Although you have selected a data source (retail_sales.mas), you do not need to create new
reports and charts to populate your document. In this example, you are going to populate the

document with existing content.



Notice that your document canvas is automatically formatted in a portrait layout that can be
viewed on a screen or printed on a standard printer, as shown in the following image.
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For this exercise, you are going to change the orientation of our document to landscape.

4. On the Layout tab in the Page Setup group, click the Orientation icon on the ribbon and select
Landscape, as shown in the following image.
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5. Click the Home tab and notice that the default output format for the document is active report and that
Report is also selected by default, as shown in the following image.
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Selecting the drop-down arrow next to the active report icon on the ribbon shows you a list of
supported formats that can be selected and used on a document, as shown in the following image.
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6. Inthe Data pane, expand the following dimensions:

e Retail _sales

e Sale Date, Simple
e Store

e  Product

Double click Sale Date Year, Product Category, Product Subcategory, and Store Type.



These dimensions are added to the Query pane as By fields and also to the Document canvas as a
simple report, as shown in the following image.
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In the Query pane, right-click Sale Date Year, select Sort, select Sort again, and click Descending, as

shown in the following image.
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In the Data pane, under Measures, double-click Revenue, Gross Profit, and Quantity Sold.



These measures are added to the Query pane as Sum fields and also to the Document canvas, as shown

in the following image.
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the following image.

On the Format tab in the Features group, click the ac

tive report options icon on the ribbon, as shown in
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The active report options dialog box opens, as shown in the following image.
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10. Change the Display Window from Cascade to Tabs and Records Per Page to 20.

11. Click OK.



12. Resize the report and move it down on the page to allow room for several filtering list boxes to be
added, as shown in the following image.
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13. Onthe Insert tab in the Active Dashboard Prompts group, click the List icon on the ribbon, as shown in
the following image.
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A list box is added to the Document canvas, as shown in the following image.
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14. Move the list box to the top of the document.

15. From the report, click the Sale Date Year field and drag it to the list box, where those values will be

listed.
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16. On the Insert tab in the Active Dashboard Prompts group, click the List icon on the ribbon, as shown in

the following image.
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A second list box is added to the Document canvas, as shown in the following image.
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17. Move this list box next to the first one.

18. From the report, click the Product Category field and drag it to the second list box, where those
values will be listed, as shown in the following image.
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19. Right-click on the first list box and select Properties from the context menu, as shown in the
following image.
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The Active Dashboard Properties dialog box opens, as shown in the following image.
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In the Prompt Source & Targets tab, the two list boxes that you added are shown, along with their
corresponding properties. Currently, the only available target report is Reportl. As you add more
reports, each report will also be available for selection from the Report drop-down list.

20. Click list_1 (the first list box you added) in the Prompts area and then select Descending from the
Sort drop-down list.

21. Click the Cascades tab.

22. In the Available Prompts area, select list_1 and list_2, and then move them to the Selected Prompts
area.
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This action will chain the values together at run time.
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23. Click OK.

Let’s add a second page to your document.

24. On the Insert tab, click the Page icon on the ribbon, as shown in the following image.
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You are now going to create a new chart on the second page of your document.

25. From the Home tab in the Format group, click Chart on the ribbon, as shown in the following image.
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26. In the Data pane, double-click Sale Date, Year under the Sale Date,Simple dimension, then double-
click Product Category under the Product dimension, as shown in the following image.
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27. On the Format tab in the Chart Types group, click the Other icon on the ribbon.



28.

29.

30.

The Select a chart dialog box opens, as shown in the following image.

Select the Pie category and then click Ring Pie, as shown in the following image.
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Resize the chart, as shown in the following image.
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In the Query pane, notice that the Sale Date,Year dimension has been added to the Columns field,

and that the Product Category dimension has been added to the Color field.

. In the Data pane, drag the Revenue measure to the Measure field in the Query pane, the Quantity

Sold measure to the Size field, and the Gross Profit measure to the Tooltip field, as shown in the

following image.
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Notice that the first chart is no longer selected, as shown in the following image.

32. Click anywhere in the white space area below the existing chart so you can create a second chart.
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33. In the Data pane, double-click Sale Date,Year under the Sale Date,Simple dimension.




34. Move the chart and resize it, as shown in the following image.
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35. On the Format tab in the Chart Types group, click the Scatter icon on the ribbon, as shown in the

following image.
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The chart is refreshed, as shown in the following image.
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36. In the Query pane, move Sale Date,Year from the Detail field to the Columns field under Matrix.




37. From the Data pane, drag Revenue to the Vertical Axis field in the Query pane, Quantity Sold to the
Horizontal Axis field, Gross Profit to the Size field, and Product Category to the Detail field and Color

field, as shown in the following image.
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Let’s customize your page settings.

38. In the upper-right corner of your document, click the drop-down arrow to the right of Page 2 and
select Page Options... from the context menu, as shown in the following image.

[]Page2-

Page 1

L

Page 2

Mew Page

L&

Page Options...




39. Right-click Page 1 and select Rename from the context menu, as shown in the following image.

Page Options

40. Rename Page 1 to Detail and click OK.
41. Right-click Page 2 and select Rename from the context menu.

42. Rename Page 2 to Visualization and click OK, as shown in the following image.
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43. In the upper-right corner of your document, click the drop-down arrow to the right of Visualization
and select Detail from the context menu to switch to the Detail page of your document.
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44. Right-click the first list box and select Properties from the context menu, as shown in the following
image.
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The Active Dashboard Properties dialog box opens, as shown in the following image.
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45. Click list_1 in the Prompts area, select Chart2 and Chartl in the Candidate Reports area, and move
them to the Targets area, as shown in the following image.

This ensures that when list_1 is changed, it will affect all three objects on the document.
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46. Click OK.

47. Repeat Step 45 for the list_2 prompt.

48. Run your document by clicking the Run icon on the Quick Access Toolbar, as shown in the following
image.
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49. Click the Visualization tab on your document to switch to that page, as shown in the following

image.
a]l)ocumenn[o]
Layouts Detail Visualization
I
Accesseries
Camcorder
Computers
Media Plaver
Stereo Systems -
Report
Sale Date
Year ¥ Product Category ¥ Product Subcategory ¥ Store Type v Revenue ¥ Gross Profit ¥ Quantity Sold ¥
2013 Accessories Charger Store Front 1,647 481.15 805,813.15 43184
Headphones Store Front 31,313 30250 10,077,007.59 93402
Universal Remote Controls Store Front 2024722383 5479402 83 72985
Camcorder Handheld Store Front 17,181706.23 875871723 102471
Professional Store Front 14 682 062.35 295750835 4279
Web 2,887,242.00 582,868.00 843
Standard Store Front 28,356,156.37 8,021561.37 79435
Computers Smartphone Store Front 29.130518.85 5719,242.85 74731
Tablet Store Front 34,059,483.03 12,958,422.03 114005
Media Player Blu Ray Store Front 05342 88532 21,149,135.32 278203
Streaming Store Front 4,105 35008 1,088.490.08 37580
Stereo Systems Home Theater Systems Store Front 34 558 640.44 11.437,009.44 163467
Receivers Store Front 23,285 69856 6,7569,172.56 61664
Speaker Kits Store Front 43,868 017.15 10,556,588.15 99928
iPod Docking Station Store Front 16,867 270.54 6.244,914.54 126692
Televisions Flat Panel TV Store Front 30,964,700.29 6,560,087.29 38123
Video Production Video Editing Store Front 2381000417 7.330,486.17 81585
2012 Accessories Charger Store Front 761217.61 373,692.61 19872
Web 340170.68 166,700.68 8874
Headphones Store Front 14,495 747 80 4676,220.80 43234
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50. Click the Detail tab on your document to switch to that page and then make several selections in
the list boxes, as shown in the following image.
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[Al] Camcorder -
_ Computers
_ Media Player
2011 StmeoSystems
2010
2000 - fideo Preduction -
Report
Sale Date
Year ¥ Product Category ¥ Product Subcategory ¥ Store Type v Revenue ¥ Gross Profit ¥ Quantity Sold ¥
2013 Stereo Systems Home Theater Systems Store Front 34 558 640.44 11437,009.44 163467
Receivers Store Front 23,285,698.56 6759,172.56 61664
Speaker Kits Store Front 43868,017.15 10,556,588.15 99028
iPod Docking Station Store Front 16,867 270.54 524491454 126692
Televisions Flat Panel TV Store Front 30964,700.29 6,560,087.29 38123
2012 Stereo Systems Home Theater Systems Store Front 1587411212 525467912 75069
Web 727262066 2,407 589 66 34407
Receivers Store Front 10684,046.13 313446813 28025
Weh 4.806,175.18 139407518 12698
Speaker Kits Store Front 2041524902 4924 663.02 46250
Web 8.930,321.81 2.147.620.81 20578
iPod Docking Station Store Front 7.854,909.65 2,900,358.65 59205
Web 350650327 1,296,120 27 26485
Televisions Flat Panel TV Store Front 13672.802.95 2920,959.95 17086
Weh 6.370,05272 134119572 7854
15 of 186 records, Page 1 of 1




51. Click the Visualization tab on your document to switch to that page.

Notice that your two charts have been refreshed based on your selections in the list boxes, as
shown in the following image.
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52. Click the Detail tab on your document to switch to that page.



shown in the following image.
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53. Click the drop-down arrow next to Revenue and select Sort Descending from the context menu, as

This quickly shows the products that have the most revenue over the years selected, as shown in

the following image.
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54. Click the drop-down arrow next to Quantity Sold, select Chart, Pie, and then click Product Category
from the context menu, as shown in the following image.

Video Production -
Report
Sale Date
Year ¥ Product Category ¥ Product Subcategory ¥ Store Type v Revenue ¥ Gross Profit ¥ Quantity Sold ¥

2013 Stereo Systems Speaker Kits Store Front 43,868,017.15 10,556,588.15 ggg  Sort Ascending
2013 Stereo Systems Home Theater Systems Store Front 34,558,640.44 11,437,000.44 (G SoilE==r
2013 Televisions Flat Panel TV Store Front 30,964,700.29 6,560,087.29 381 L N
2013 Stereo Systems Receivers Store Front 23,285,698.56 6,759,172.56 616 -
2012 Stereo Systems Speaker Kits Store Front 20,415,249.02 4,924,663.02 ‘
2013 Stereo Systems iPod Docking Station Store Front 16,867 270.54 Group By (X) Rolup >
2012 Stereo Systems Home Theater Systems Store Front 15,874,112.12 e , Pwot (Cross Tab) »
2012 Televisions Flat Panel TV Store Front 13,672802.95 SeotT e o , Visuaize
2012 Stereo Systems Receivers Store Front 10.684,046.13 280
2012 Stereo Systems Speaker Kits Web 893032181 Subcaeoory 205 Z::Tcﬂ'“”
2012 Stereo Systems iPod Docking Station Store Front 7,854,900.65 Store Type 592 Chart/Rollup Tool
2012 Stereo Systems Home Theater Systems Web 7.272,620.66 Revenue 344 Pivot Tool
2012 Televisions Flat Panel TV Web 6,370,062.72 Groas Profit 78
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Notice that the results are placed in a new tab based on the active report output settings you
specified earlier, as shown in the following image.
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55. Continue to explore with other selections to see additional results based on your data.

56. Save your document by clicking the Save icon on the Quick Access Toolbar, as shown in the

following image.
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The Save As dialog box opens.
57. Provide a name for your new document and then click Save.

You are now ready to move on to Module 5, where you will learn how to create a Distribution List used by
ReportCaster, the scheduling and distribution feature of the WebFOCUS Business User Edition. In addition,
you will also learn how to create and manage a Schedule. This allows you to automatically send reports to

key members in your department and organization.



